summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-03-02 22:57:00 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-03-02 22:57:00 +0000
commitd4b477187d007c76406fbfd736dc6629365df3e1 (patch)
tree75e00d8fb087a108b39fced7f90336668fe67b6d /net-dns/djbdns
parentStable on alpha, bug #396981 (diff)
downloadgentoo-2-d4b477187d007c76406fbfd736dc6629365df3e1.tar.gz
gentoo-2-d4b477187d007c76406fbfd736dc6629365df3e1.tar.bz2
gentoo-2-d4b477187d007c76406fbfd736dc6629365df3e1.zip
Add missing nofiles group. Bug #388537. Add proxy-maintainers herd
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/djbdns')
-rw-r--r--net-dns/djbdns/ChangeLog10
-rw-r--r--net-dns/djbdns/djbdns-1.05-r25.ebuild136
-rw-r--r--net-dns/djbdns/metadata.xml1
3 files changed, 145 insertions, 2 deletions
diff --git a/net-dns/djbdns/ChangeLog b/net-dns/djbdns/ChangeLog
index b4fd60ac4a7b..08e001e9633a 100644
--- a/net-dns/djbdns/ChangeLog
+++ b/net-dns/djbdns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/djbdns
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/ChangeLog,v 1.124 2011/04/11 13:08:57 c1pher Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/ChangeLog,v 1.125 2012/03/02 22:57:00 hwoarang Exp $
+
+*djbdns-1.05-r25 (02 Mar 2012)
+
+ 02 Mar 2012; Markos Chandras <hwoarang@gentoo.org> +djbdns-1.05-r25.ebuild,
+ metadata.xml:
+ Add missing nofiles group. Bug #388537. Add proxy-maintainers herd
11 Apr 2011; Dane Smith <c1pher@gentoo.org> djbdns-1.05-r24.ebuild,
+files/makefile-parallel.patch:
diff --git a/net-dns/djbdns/djbdns-1.05-r25.ebuild b/net-dns/djbdns/djbdns-1.05-r25.ebuild
new file mode 100644
index 000000000000..69d8def19c94
--- /dev/null
+++ b/net-dns/djbdns/djbdns-1.05-r25.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r25.ebuild,v 1.1 2012/03/02 22:57:00 hwoarang Exp $
+
+EAPI="2"
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Excellent high-performance DNS services"
+HOMEPAGE="http://cr.yp.to/djbdns.html"
+IPV6_PATCH="test23"
+
+SRC_URI="http://cr.yp.to/djbdns/${P}.tar.gz
+ ipv6? ( http://www.fefe.de/dns/${P}-${IPV6_PATCH}.diff.bz2 )"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ipv6 selinux static"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ virtual/daemontools
+ sys-apps/ucspi-tcp
+ doc? ( app-doc/djbdns-man )
+ selinux? ( sec-policy/selinux-djbdns )
+"
+
+src_prepare() {
+ echo
+ elog 'Several patches have been dropped from this djbdns ebuild revision.'
+ elog 'Please use the DJBDNS_PATCH_DIR variable to specify a directory'
+ elog 'of custom patches.'
+ elog
+ elog 'Some of them can be found at http://tinydns.org/ or'
+ elog 'http://homepages.tesco.net/J.deBoynePollard/Softwares/djbdns/'
+ elog
+
+ epatch \
+ "${FILESDIR}/headtail.patch" \
+ "${FILESDIR}/dnsroots.patch" \
+ "${FILESDIR}/dnstracesort.patch" \
+ "${FILESDIR}/string_length_255.patch"
+
+ # Fix CVE2009-0858
+ epatch "${FILESDIR}/CVE2009-0858_0001-check-response-domain-name-length.patch"
+
+ if use ipv6; then
+ elog "At present dnstrace does NOT support IPv6. It will"\
+ "be compiled without IPv6 support."
+ cp -pR "${S}" "${S}-noipv6"
+ # Careful -- >=test21 of the IPv6 patch includes the errno patch
+ epatch "${DISTDIR}/${P}-${IPV6_PATCH}.diff.bz2"
+
+ # Fix CVE2008-4392
+ epatch \
+ "${FILESDIR}/CVE2008-4392_0001-dnscache-merge-similar-outgoing-queries-ipv6.patch" \
+ "${FILESDIR}/CVE2008-4392_0002-dnscache-cache-soa-records-ipv6.patch" \
+ "${FILESDIR}/makefile-parallel.patch"
+
+ cd "${S}-noipv6"
+ fi
+
+ # Fix CVE2008-4392
+ epatch \
+ "${FILESDIR}/CVE2008-4392_0001-dnscache-merge-similar-outgoing-queries.patch" \
+ "${FILESDIR}/CVE2008-4392_0002-dnscache-cache-soa-records.patch"
+
+ epatch "${FILESDIR}/${PV}-errno.patch"
+
+ if [[ -n "${DJBDNS_PATCH_DIR}" && -d "${DJBDNS_PATCH_DIR}" ]]
+ then
+ echo
+ ewarn "You enabled custom patches from ${DJBDNS_PATCH_DIR}."
+ ewarn "Be warned that you won't get any support when using "
+ ewarn "this feature. You're on your own from now!"
+ echo
+ ebeep
+ cd "${S}" && epatch "${DJBDNS_PATCH_DIR}/"*
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "/usr" > conf-home
+ #emake -j1 || die "emake failed"
+ emake || die "emake failed"
+
+ # If djbdns is compiled with IPv6 support, it breaks dnstrace.
+ # Therefore we must compile dnstrace separately without IPv6
+ # support.
+ if use ipv6; then
+ elog "Compiling dnstrace without ipv6 support"
+ cd "${S}-noipv6"
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "/usr" > conf-home
+ #emake -j1 dnstrace || die "emake failed"
+ emake dnstrace || die "emake failed"
+ fi
+}
+
+src_install() {
+ insinto /etc
+ doins dnsroots.global || die
+
+ into /usr
+ dobin *-conf dnscache tinydns walldns rbldns pickdns axfrdns \
+ *-get *-data *-edit dnsip dnsipq dnsname dnstxt dnsmx \
+ dnsfilter random-ip dnsqr dnsq dnstrace dnstracesort || die
+
+ if use ipv6; then
+ dobin dnsip6 dnsip6q "${S}-noipv6/dnstrace" || die
+ fi
+
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION || die
+
+ dobin "${FILESDIR}/dnscache-setup" || die
+ dobin "${FILESDIR}/tinydns-setup" || die
+ newbin "${FILESDIR}/djbdns-setup-r17" djbdns-setup || die
+}
+
+pkg_preinst() {
+ # The nofiles group is no longer provided by baselayout.
+ # Share it with qmail if possible.
+ enewgroup nofiles 200
+
+ enewuser dnscache -1 -1 -1 nofiles
+ enewuser dnslog -1 -1 -1 nofiles
+ enewuser tinydns -1 -1 -1 nofiles
+}
+
+pkg_postinst() {
+ elog "Use dnscache-setup & tinydns-setup or djbdns-setup to configure djbdns."
+}
diff --git a/net-dns/djbdns/metadata.xml b/net-dns/djbdns/metadata.xml
index 5c912d008819..4d30ad251c79 100644
--- a/net-dns/djbdns/metadata.xml
+++ b/net-dns/djbdns/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<herd>proxy-maintainers</herd>
<maintainer>
<email>c1pher@gentoo.org</email>
<name>Dane Smith</name>