summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2005-03-27 11:15:35 +0000
committerJon Portnoy <avenj@gentoo.org>2005-03-27 11:15:35 +0000
commit53b3c1ee11fbfe8a37820bcf0ac1c0ac44809a2b (patch)
treebf3bcc88a50c0490374afa928fe0affa46bdcd34 /net-dns/dnsmasq/dnsmasq-2.21.ebuild
parentStable on alpha. (diff)
downloadgentoo-2-53b3c1ee11fbfe8a37820bcf0ac1c0ac44809a2b.tar.gz
gentoo-2-53b3c1ee11fbfe8a37820bcf0ac1c0ac44809a2b.tar.bz2
gentoo-2-53b3c1ee11fbfe8a37820bcf0ac1c0ac44809a2b.zip
Version bump, security fix for bug 86710
(Portage version: 2.0.51-r12)
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.21.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.21.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.21.ebuild b/net-dns/dnsmasq/dnsmasq-2.21.ebuild
new file mode 100644
index 000000000000..31c41fda1cdf
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.21.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.21.ebuild,v 1.1 2005/03/27 11:15:35 avenj Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/_/}"
+MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ >=sys-apps/portage-2.0.51"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ epatch ${FILESDIR}/dnsmasq221-netlink.diff
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ make \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR=${D} \
+ install || die
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd ${FILESDIR}/dnsmasq-init dnsmasq
+ newconfd ${FILESDIR}/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+}