summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRajiv Aaron Manglani <rajiv@gentoo.org>2009-08-12 01:11:50 +0000
committerRajiv Aaron Manglani <rajiv@gentoo.org>2009-08-12 01:11:50 +0000
commit3654ec09eac6f269c8c04a908258228b013c6cf4 (patch)
treecaf6f160aa6ab2a45923804128ba50d8e6098f23 /net-dns/dnstop
parentFix building with GCC 4.4+ wrt #273560. (diff)
downloadgentoo-2-3654ec09eac6f269c8c04a908258228b013c6cf4.tar.gz
gentoo-2-3654ec09eac6f269c8c04a908258228b013c6cf4.tar.bz2
gentoo-2-3654ec09eac6f269c8c04a908258228b013c6cf4.zip
cleanup.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-dns/dnstop')
-rw-r--r--net-dns/dnstop/ChangeLog8
-rw-r--r--net-dns/dnstop/dnstop-20070510-r1.ebuild38
-rw-r--r--net-dns/dnstop/dnstop-20080502.ebuild3
-rw-r--r--net-dns/dnstop/files/dnstop-20070510-handle_ipv6.patch25
4 files changed, 8 insertions, 66 deletions
diff --git a/net-dns/dnstop/ChangeLog b/net-dns/dnstop/ChangeLog
index 43c0fbf84bde..2d42fcd20904 100644
--- a/net-dns/dnstop/ChangeLog
+++ b/net-dns/dnstop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/dnstop
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/ChangeLog,v 1.25 2009/07/12 08:50:56 rajiv Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/ChangeLog,v 1.26 2009/08/12 01:11:50 rajiv Exp $
+
+ 12 Aug 2009; Rajiv Aaron Manglani <rajiv@gentoo.org>
+ -dnstop-20070510-r1.ebuild, -files/dnstop-20070510-handle_ipv6.patch:
+ cleanup.
*dnstop-20090128 (12 Jul 2009)
diff --git a/net-dns/dnstop/dnstop-20070510-r1.ebuild b/net-dns/dnstop/dnstop-20070510-r1.ebuild
deleted file mode 100644
index d60ba1bc120b..000000000000
--- a/net-dns/dnstop/dnstop-20070510-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/dnstop-20070510-r1.ebuild,v 1.4 2007/07/25 21:32:07 angelos Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="Displays various tables of DNS traffic on your network."
-HOMEPAGE="http://dnstop.measurement-factory.com/"
-SRC_URI="http://dnstop.measurement-factory.com/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc sparc x86"
-
-IUSE="ipv6"
-DEPEND="sys-libs/ncurses
- virtual/libpcap"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-handle_ipv6.patch"
-}
-
-src_compile() {
- use ipv6 && append-flags -DUSE_IPV6
-
- sed -i "s:^CFLAGS=.*$:CFLAGS=${CFLAGS} -DUSE_PPP:" Makefile
-
- emake || die "emake failed."
-}
-
-src_install() {
- dobin dnstop
- doman dnstop.8
- dodoc LICENSE
- dodoc CHANGES
-}
diff --git a/net-dns/dnstop/dnstop-20080502.ebuild b/net-dns/dnstop/dnstop-20080502.ebuild
index ff7030f2add4..3b77733c7f28 100644
--- a/net-dns/dnstop/dnstop-20080502.ebuild
+++ b/net-dns/dnstop/dnstop-20080502.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/dnstop-20080502.ebuild,v 1.4 2009/01/11 19:09:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnstop/dnstop-20080502.ebuild,v 1.5 2009/08/12 01:11:50 rajiv Exp $
DESCRIPTION="Displays various tables of DNS traffic on your network."
HOMEPAGE="http://dnstop.measurement-factory.com/"
@@ -13,6 +13,7 @@ KEYWORDS="amd64 ~hppa ~ppc sparc x86"
IUSE="ipv6"
DEPEND="sys-libs/ncurses
virtual/libpcap"
+RDEPEND="${DEPEND}"
src_compile() {
econf $(use_enable ipv6) || die "econf failed."
diff --git a/net-dns/dnstop/files/dnstop-20070510-handle_ipv6.patch b/net-dns/dnstop/files/dnstop-20070510-handle_ipv6.patch
deleted file mode 100644
index 4405b7686c67..000000000000
--- a/net-dns/dnstop/files/dnstop-20070510-handle_ipv6.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -uNr dnstop-20070510/dnstop.c dnstop-20070510-r1/dnstop.c
---- dnstop-20070510/dnstop.c 2007-05-11 00:51:12.000000000 -0400
-+++ dnstop-20070510-r1/dnstop.c 2007-06-17 18:57:26.000000000 -0400
-@@ -825,8 +825,10 @@
- memcpy(&family, pkt, sizeof(family));
- if (AF_INET == family)
- return handle_ipv4((struct ip *)(pkt + 4), len - 4);
-+#if USE_IPV6
- if (AF_INET6 == family)
- return handle_ipv6((struct ip6_hdr *)(pkt + 4), len - 4);
-+#endif
- return 0;
- }
-
-@@ -838,8 +840,10 @@
- memcpy(&family, pkt, sizeof(family));
- if (AF_INET == ntohl(family))
- return handle_ipv4((struct ip *)(pkt + 4), len - 4);
-+#if USE_IPV6
- if (AF_INET6 == ntohl(family))
- return handle_ipv6((struct ip6_hdr *)(pkt + 4), len - 4);
-+#endif
- return 0;
- }
-