summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarl Perry <edolnx@gentoo.org>2003-06-01 21:44:39 +0000
committerCarl Perry <edolnx@gentoo.org>2003-06-01 21:44:39 +0000
commita58d3ab92020447b8249ad8176d0c2b862f30cd8 (patch)
tree0740d29cc017f5be7be78deb83b881e4b4bdf32f /net-dns/ldapdns/ldapdns-2.04.ebuild
parentCleanup & version bumped. Closes #21964. (diff)
downloadgentoo-2-a58d3ab92020447b8249ad8176d0c2b862f30cd8.tar.gz
gentoo-2-a58d3ab92020447b8249ad8176d0c2b862f30cd8.tar.bz2
gentoo-2-a58d3ab92020447b8249ad8176d0c2b862f30cd8.zip
Updated to latest stable version and unmasked
Diffstat (limited to 'net-dns/ldapdns/ldapdns-2.04.ebuild')
-rw-r--r--net-dns/ldapdns/ldapdns-2.04.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-dns/ldapdns/ldapdns-2.04.ebuild b/net-dns/ldapdns/ldapdns-2.04.ebuild
new file mode 100644
index 000000000000..80ece4e7d866
--- /dev/null
+++ b/net-dns/ldapdns/ldapdns-2.04.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A tiny, fast authoritative nameserver that queries LDAP and can be updated instantly"
+SRC_URI="http://www.nimh.org/dl/${P}.tar.gz"
+HOMEPAGE="http://www.nimh.org/code/ldapdns/"
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ >=net-nds/openldap-2"
+RDEPEND="${DEPEND}
+ >=sys-apps/daemontools-0.70
+ sys-apps/ucspi-tcp"
+
+src_compile() {
+ local myconf="--prefix=/usr "
+
+ cd ${S}
+ ./configure ${myconf}
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+
+ dodoc AUTHORS CHANGELOG FAQ INSTALL COPYING NEWS README* TODO
+}
+
+pkg_postinst() {
+
+ groupadd &>/dev/null nofiles
+
+ id &>/dev/null ldapdns || \
+ useradd -g nofiles -d /nonexistent -s /bin/false ldapdns
+ id &>/dev/null dnslog || \
+ useradd -g nofiles -d /nonexistent -s /bin/false dnslog
+
+ einfo "Read the readme.configure and use ldapdns-conf to setup"
+}
+