summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-11-11 21:15:38 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-11-11 21:15:38 +0000
commit66e3114f6340f91cd1597f81ddfb35faa51d0fcf (patch)
tree99b2d018dac49e41adf490b9d7dc08464b437d45 /net-dns/ldapdns/ldapdns-2.05.ebuild
parentversion bump (diff)
downloadgentoo-2-66e3114f6340f91cd1597f81ddfb35faa51d0fcf.tar.gz
gentoo-2-66e3114f6340f91cd1597f81ddfb35faa51d0fcf.tar.bz2
gentoo-2-66e3114f6340f91cd1597f81ddfb35faa51d0fcf.zip
version bump
Diffstat (limited to 'net-dns/ldapdns/ldapdns-2.05.ebuild')
-rw-r--r--net-dns/ldapdns/ldapdns-2.05.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-dns/ldapdns/ldapdns-2.05.ebuild b/net-dns/ldapdns/ldapdns-2.05.ebuild
new file mode 100644
index 000000000000..59cdcba94ab5
--- /dev/null
+++ b/net-dns/ldapdns/ldapdns-2.05.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldapdns/ldapdns-2.05.ebuild,v 1.1 2003/11/11 21:15:31 jhhudso Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A tiny, fast authoritative nameserver that queries LDAP and can be updated instantly"
+SRC_URI="http://www.nimh.org/dl/${P}.tar.gz"
+HOMEPAGE="http://www.nimh.org/code/ldapdns/"
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=net-nds/openldap-2"
+RDEPEND="${DEPEND}
+ >=sys-apps/daemontools-0.70
+ sys-apps/ucspi-tcp"
+
+src_compile() {
+ local myconf="--prefix=/usr "
+
+ cd ${S}
+ ./configure ${myconf}
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+
+ dodoc AUTHORS CHANGELOG FAQ INSTALL COPYING NEWS README* TODO
+}
+
+pkg_postinst() {
+
+ groupadd &>/dev/null nofiles
+
+ id &>/dev/null ldapdns || \
+ useradd -g nofiles -d /nonexistent -s /bin/false ldapdns
+ id &>/dev/null dnslog || \
+ useradd -g nofiles -d /nonexistent -s /bin/false dnslog
+
+ einfo "Read the readme.configure and use ldapdns-conf to setup"
+}
+