summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2014-03-10 21:52:43 +0000
committerSven Wegener <swegener@gentoo.org>2014-03-10 21:52:43 +0000
commit93ae5310b33d308646f8bd386d9215367d9d3d7d (patch)
tree2af73c4e3fc22fae3125a1770d572e7b257f4ab8 /net-dns/pdns-recursor
parentDrop linux-sources from *DEPEND, bug #502174. (diff)
downloadgentoo-2-93ae5310b33d308646f8bd386d9215367d9d3d7d.tar.gz
gentoo-2-93ae5310b33d308646f8bd386d9215367d9d3d7d.tar.bz2
gentoo-2-93ae5310b33d308646f8bd386d9215367d9d3d7d.zip
Version bump, bug #473684 by Thomas D.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x64D4CF24)
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/ChangeLog9
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.5.3.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index fd76848ce6ae..efcc81651220 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/pdns-recursor
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.41 2013/05/04 20:54:57 swegener Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.42 2014/03/10 21:52:43 swegener Exp $
+
+*pdns-recursor-3.5.3 (10 Mar 2014)
+
+ 10 Mar 2014; Sven Wegener <swegener@gentoo.org> +pdns-recursor-3.5.3.ebuild:
+ Version bump, bug #473684 by Thomas D.
*pdns-recursor-3.5.1 (04 May 2013)
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.5.3.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.5.3.ebuild
new file mode 100644
index 000000000000..749d2b62dd67
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.5.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.5.3.ebuild,v 1.1 2014/03/10 21:52:43 swegener Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND="lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ >=dev-libs/boost-1.33.1"
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.7.2-error-message.patch
+
+ sed -i -e s:/var/run/:/var/lib/powerdns: "${S}"/config.h || die
+}
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control
+ doman pdns_recursor.1 rec_control.1
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf
+
+ doinitd "${FILESDIR}"/precursor
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}