summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-08-14 07:07:45 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-08-14 07:07:45 +0000
commitcc1285a23aa079984dee72af43aa826c50607ac2 (patch)
tree8b5730f79cf046c975e1d19d7fb78e9435ab5d2f /net-dns/totd/totd-1.5.1.ebuild
parentadding some fixes and improvements (bug #102417), removing old versions, stab... (diff)
downloadgentoo-2-cc1285a23aa079984dee72af43aa826c50607ac2.tar.gz
gentoo-2-cc1285a23aa079984dee72af43aa826c50607ac2.tar.bz2
gentoo-2-cc1285a23aa079984dee72af43aa826c50607ac2.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-dns/totd/totd-1.5.1.ebuild')
-rw-r--r--net-dns/totd/totd-1.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-dns/totd/totd-1.5.1.ebuild b/net-dns/totd/totd-1.5.1.ebuild
new file mode 100644
index 000000000000..3b308dd7b67a
--- /dev/null
+++ b/net-dns/totd/totd-1.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/totd/totd-1.5.1.ebuild,v 1.1 2005/08/14 07:07:45 dragonheart Exp $
+
+DESCRIPTION="Trick Or Treat Daemon, a DNS proxy for 6to4"
+HOMEPAGE="http://www.vermicelli.pasta.cs.uit.no/ipv6/software.html"
+SRC_URI="ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/${P}.tar.gz"
+LICENSE="BSD as-is"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ econf --enable-ipv4 --enable-ipv6 --enable-stf \
+ --enable-scoped-rewrite --disable-http-server || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dosbin totd
+ doman totd.8
+ dodoc totd.conf.sample README INSTALL
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/totd
+}
+
+pkg_postinst() {
+ einfo "/usr/share/doc/${P}/totd.conf.sample.gz contains"
+ einfo "a sample config file for totd. Make sure you create"
+ einfo "/etc/totd.conf with the necessary configurations"
+}