summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-25 15:41:15 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-25 15:41:15 +0000
commitc4efe533130e773127d8e5aa26be82d7891b2140 (patch)
tree92615e1993adfca1ddaf1a4b435ef00d40f4ddce /net-dns/unbound
parentwhitespace (diff)
downloadgentoo-2-c4efe533130e773127d8e5aa26be82d7891b2140.tar.gz
gentoo-2-c4efe533130e773127d8e5aa26be82d7891b2140.tar.bz2
gentoo-2-c4efe533130e773127d8e5aa26be82d7891b2140.zip
Version bumped. Removed *.la files.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/unbound')
-rw-r--r--net-dns/unbound/ChangeLog9
-rw-r--r--net-dns/unbound/metadata.xml1
-rw-r--r--net-dns/unbound/unbound-1.4.10.ebuild (renamed from net-dns/unbound/unbound-1.4.7-r1.ebuild)36
-rw-r--r--net-dns/unbound/unbound-1.4.3.ebuild72
-rw-r--r--net-dns/unbound/unbound-1.4.6.ebuild72
-rw-r--r--net-dns/unbound/unbound-1.4.7.ebuild71
6 files changed, 32 insertions, 229 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index 0dc443663d72..e3d66d434d4b 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.23 2011/05/11 19:37:25 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.24 2011/05/25 15:41:15 matsuu Exp $
+
+*unbound-1.4.10 (25 May 2011)
+
+ 25 May 2011; MATSUU Takuto <matsuu@gentoo.org> -unbound-1.4.3.ebuild,
+ -unbound-1.4.6.ebuild, -unbound-1.4.7.ebuild, -unbound-1.4.7-r1.ebuild,
+ +unbound-1.4.10.ebuild:
+ Version bumped. Removed *.la files. Removed old versions.
11 May 2011; Christoph Mende <angelos@gentoo.org> unbound-1.4.8.ebuild:
Stable on amd64 wrt bug #362015
diff --git a/net-dns/unbound/metadata.xml b/net-dns/unbound/metadata.xml
index 3df92ef0dcfe..fcea16afe957 100644
--- a/net-dns/unbound/metadata.xml
+++ b/net-dns/unbound/metadata.xml
@@ -24,7 +24,6 @@ DNSSEC (secure DNS) validation and stub-resolvers (that do not run
as a server, but are linked into an application) are easily possible.
</longdescription>
<use>
- <flag name='libevent'>Use <pkg>dev-libs/libevent</pkg> instead of internal select based events</flag>
<flag name='gost'>Enable GOST support</flag>
</use>
</pkgmetadata>
diff --git a/net-dns/unbound/unbound-1.4.7-r1.ebuild b/net-dns/unbound/unbound-1.4.10.ebuild
index ffbd1f255713..63d374321b37 100644
--- a/net-dns/unbound/unbound-1.4.7-r1.ebuild
+++ b/net-dns/unbound/unbound-1.4.10.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.7-r1.ebuild,v 1.1 2010/12/07 15:08:22 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.10.ebuild,v 1.1 2011/05/25 15:41:15 matsuu Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit eutils multilib python
+inherit eutils python
DESCRIPTION="A validating, recursive and caching DNS resolver"
HOMEPAGE="http://unbound.net/"
@@ -13,7 +13,7 @@ SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="debug gost python static test threads"
+IUSE="debug gost python static-libs test threads"
RDEPEND="dev-libs/expat
dev-libs/libevent
@@ -45,15 +45,18 @@ src_configure() {
--with-libevent="${EPREFIX}"/usr \
--with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
$(use_enable debug) \
- $(use_enable debug lock-checks) \
- $(use_enable debug alloc-checks) \
- $(use_enable debug alloc-lite) \
- $(use_enable debug alloc-nonregional) \
$(use_enable gost) \
- $(use_enable static static-exe) \
+ $(use_enable static-libs static) \
$(use_with threads pthreads) \
$(use_with python pyunbound) \
- $(use_with python pythonmodule) || die
+ $(use_with python pythonmodule) \
+ --disable-rpath || die
+
+ # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+ # $(use_enable debug lock-checks) \
+ # $(use_enable debug alloc-checks) \
+ # $(use_enable debug alloc-lite) \
+ # $(use_enable debug alloc-nonregional) \
}
src_install() {
@@ -61,16 +64,25 @@ src_install() {
# bug #299016
if use python ; then
- rm "${ED}/usr/$(get_libdir)"/python*/site-packages/_unbound.*a || die
+ find "${ED}$(python_get_sitedir)" "(" -name "*.a" -o -name "*.la" ")" -type f -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
fi
newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
+
# bug #315519
+ #exeinto /usr/libexec/munin/plugins
+ #doexe contrib/unbound_munin_ || die "doexe failed"
dodoc contrib/unbound_munin_ || die "dodoc failed"
+ docinto selinux
+ dodoc contrib/selinux/* || die "dodoc failed"
+
exeinto /usr/share/${PN}
- doexe contrib/{update-anchor,update-itar,split-itar}.sh || die "doexe failed"
+ doexe contrib/update-anchor.sh || die "doexe failed"
}
diff --git a/net-dns/unbound/unbound-1.4.3.ebuild b/net-dns/unbound/unbound-1.4.3.ebuild
deleted file mode 100644
index a8c754353a6e..000000000000
--- a/net-dns/unbound/unbound-1.4.3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.3.ebuild,v 1.4 2010/03/29 21:54:46 maekke Exp $
-
-EAPI="2"
-
-inherit autotools eutils multilib
-
-DESCRIPTION="A validating, recursive and caching DNS resolver"
-HOMEPAGE="http://unbound.net/"
-SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug libevent python static test threads"
-
-RDEPEND=">=dev-libs/openssl-0.9.8
- >=net-libs/ldns-1.4[ssl]
- libevent? ( dev-libs/libevent )"
-# gost? ( >=dev-libs/openssl-1 )
-
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- test? (
- net-dns/ldns-utils[examples]
- dev-util/splint
- app-text/wdiff
- )"
-
-pkg_setup() {
- enewgroup unbound
- enewuser unbound -1 -1 /etc/unbound unbound
-}
-
-src_prepare() {
- sed -i -e "s:\(withval\|thedir\)/lib:\1/$(get_libdir):" configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-pidfile=/var/run/unbound.pid \
- --with-ldns=/usr \
- $(use_enable debug) \
- $(use_enable debug lock-checks) \
- $(use_enable debug alloc-checks) \
- $(use_enable debug alloc-lite) \
- $(use_enable debug alloc-nonregional) \
- $(use_enable static static-exe) \
- $(use_with libevent) \
- $(use_with threads pthreads) \
- $(use_with python pyunbound) \
- $(use_with python pythonmodule) || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # bug #299016
- if use python ; then
- rm "${D}/usr/$(get_libdir)"/python*/site-packages/_unbound.*a || die
- fi
-
- newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
- newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
-
- dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
-
- exeinto /usr/share/${PN}
- doexe contrib/{update-anchor,update-itar,split-itar}.sh || die "doexe failed"
-}
diff --git a/net-dns/unbound/unbound-1.4.6.ebuild b/net-dns/unbound/unbound-1.4.6.ebuild
deleted file mode 100644
index 58c4fa2c2594..000000000000
--- a/net-dns/unbound/unbound-1.4.6.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.6.ebuild,v 1.2 2010/11/15 16:13:16 matsuu Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-inherit eutils multilib python
-
-DESCRIPTION="A validating, recursive and caching DNS resolver"
-HOMEPAGE="http://unbound.net/"
-SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-#IUSE="debug gost python static test threads"
-IUSE="debug python static test threads"
-
-RDEPEND="dev-libs/libevent
- >=dev-libs/openssl-0.9.8
- >=net-libs/ldns-1.6.5[ssl]"
-# gost? ( >=dev-libs/openssl-1 )
-
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- test? (
- net-dns/ldns-utils[examples]
- dev-util/splint
- app-text/wdiff
- )"
-
-pkg_setup() {
- python_set_active_version 2
- enewgroup unbound
- enewuser unbound -1 -1 /etc/unbound unbound
-}
-
-src_configure() {
- econf \
- --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
- --with-ldns="${EPREFIX}"/usr \
- --with-libevent="${EPREFIX}"/usr \
- $(use_enable debug) \
- $(use_enable debug lock-checks) \
- $(use_enable debug alloc-checks) \
- $(use_enable debug alloc-lite) \
- $(use_enable debug alloc-nonregional) \
- $(use_enable static static-exe) \
- $(use_with threads pthreads) \
- $(use_with python pyunbound) \
- $(use_with python pythonmodule) || die
-# $(use_enable gost) \
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # bug #299016
- if use python ; then
- rm "${ED}/usr/$(get_libdir)"/python*/site-packages/_unbound.*a || die
- fi
-
- newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
- newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
-
- dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
- # bug #315519
- dodoc contrib/unbound_munin_ || die "dodoc failed"
-
- exeinto /usr/share/${PN}
- doexe contrib/{update-anchor,update-itar,split-itar}.sh || die "doexe failed"
-}
diff --git a/net-dns/unbound/unbound-1.4.7.ebuild b/net-dns/unbound/unbound-1.4.7.ebuild
deleted file mode 100644
index b549ce80a08c..000000000000
--- a/net-dns/unbound/unbound-1.4.7.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.7.ebuild,v 1.2 2010/11/15 16:13:16 matsuu Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-inherit eutils multilib python
-
-DESCRIPTION="A validating, recursive and caching DNS resolver"
-HOMEPAGE="http://unbound.net/"
-SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="debug gost python static test threads"
-
-RDEPEND="dev-libs/expat
- dev-libs/libevent
- >=dev-libs/openssl-0.9.8
- >=net-libs/ldns-1.6.5[ssl,gost?]"
-
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- test? (
- net-dns/ldns-utils[examples]
- dev-util/splint
- app-text/wdiff
- )"
-
-pkg_setup() {
- python_set_active_version 2
- enewgroup unbound
- enewuser unbound -1 -1 /etc/unbound unbound
-}
-
-src_configure() {
- econf \
- --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
- --with-ldns="${EPREFIX}"/usr \
- --with-libevent="${EPREFIX}"/usr \
- $(use_enable debug) \
- $(use_enable debug lock-checks) \
- $(use_enable debug alloc-checks) \
- $(use_enable debug alloc-lite) \
- $(use_enable debug alloc-nonregional) \
- $(use_enable gost) \
- $(use_enable static static-exe) \
- $(use_with threads pthreads) \
- $(use_with python pyunbound) \
- $(use_with python pythonmodule) || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # bug #299016
- if use python ; then
- rm "${ED}/usr/$(get_libdir)"/python*/site-packages/_unbound.*a || die
- fi
-
- newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
- newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
-
- dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
- # bug #315519
- dodoc contrib/unbound_munin_ || die "dodoc failed"
-
- exeinto /usr/share/${PN}
- doexe contrib/{update-anchor,update-itar,split-itar}.sh || die "doexe failed"
-}