summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-02-22 08:20:03 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-02-22 08:20:03 +0000
commit0cb2e0579a17ec450b783084ccf3d368d20b40f8 (patch)
treefaca601be0abc2e6e996e5abe50186354680362a /net-dns
parentheader fix; arm needs deps first (Manifest recommit) (diff)
downloadgentoo-2-0cb2e0579a17ec450b783084ccf3d368d20b40f8.tar.gz
gentoo-2-0cb2e0579a17ec450b783084ccf3d368d20b40f8.tar.bz2
gentoo-2-0cb2e0579a17ec450b783084ccf3d368d20b40f8.zip
version bump. Avoid clobbering previous cache. Cache moved to /var/cache from /var/lib.
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdnsd/files/digest-pdnsd-1.1.101
-rw-r--r--net-dns/pdnsd/files/pdnsd.rc66
-rw-r--r--net-dns/pdnsd/pdnsd-1.1.10.ebuild100
3 files changed, 104 insertions, 3 deletions
diff --git a/net-dns/pdnsd/files/digest-pdnsd-1.1.10 b/net-dns/pdnsd/files/digest-pdnsd-1.1.10
new file mode 100644
index 000000000000..991de149e654
--- /dev/null
+++ b/net-dns/pdnsd/files/digest-pdnsd-1.1.10
@@ -0,0 +1 @@
+MD5 11c5bcc40590fc3bcf6256f8248d6536 pdnsd-1.1.10-par.tar.gz 287338
diff --git a/net-dns/pdnsd/files/pdnsd.rc6 b/net-dns/pdnsd/files/pdnsd.rc6
index 4c8e6b9a36e0..ddbf2f4a0a6f 100644
--- a/net-dns/pdnsd/files/pdnsd.rc6
+++ b/net-dns/pdnsd/files/pdnsd.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/files/pdnsd.rc6,v 1.7 2004/02/22 00:08:46 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/files/pdnsd.rc6,v 1.8 2004/02/22 08:20:03 dragonheart Exp $
depend() {
need net
@@ -11,7 +11,7 @@ depend() {
checkconfig() {
if [ ! -e /etc/pdnsd/pdnsd.conf ] ; then
eerror "You need an /etc/pdnsd/pdnsd.conf file first"
- eerror "There is a sample in /usr/share/doc/pdnsd and /etc/pdnsd/pdnsd.conf.sample"
+ eerror "There is a sample in /usr/share/doc/pdnsd"
return 1
fi
}
@@ -20,7 +20,7 @@ start() {
checkconfig || return 1
ebegin "Starting pdnsd"
start-stop-daemon --start --quiet --exec /usr/sbin/pdnsd \
- -- -s -t -d -p /var/run/pdnsd.pid
+ -- -s -t -d -p /var/run/pdnsd.pid ${PDNSDCONFIG}
eend $?
}
diff --git a/net-dns/pdnsd/pdnsd-1.1.10.ebuild b/net-dns/pdnsd/pdnsd-1.1.10.ebuild
new file mode 100644
index 000000000000..6b2e31e973b4
--- /dev/null
+++ b/net-dns/pdnsd/pdnsd-1.1.10.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.1.10.ebuild,v 1.1 2004/02/22 08:20:03 dragonheart Exp $
+
+DESCRIPTION="Proxy DNS server with permanent caching"
+
+MY_P=${PN}-${PV}-par
+
+SRC_URI="http://www.phys.uu.nl/%7Erombouts/pdnsd/${MY_P}.tar.gz"
+
+HOMEPAGE="http://www.phys.uu.nl/%7Erombouts/pdnsd.html http://home.t-online.de/home/Moestl"
+
+IUSE="ipv6 debug isdn"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4"
+
+RDEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="BSD | GPL-2"
+
+# Should work on alpha arm hppa i386 ia64 m68k mips mipsel powerpc s390 sparc
+# REF http://packages.debian.org/cgi-bin/search_packages.pl?searchon=names&version=all&exact=1&keywords=pdnsd
+
+KEYWORDS="~x86 ~ppc ~sparc"
+
+S=${WORKDIR}/${PN}-${PV}
+
+
+# for debugging use
+use debug && RESTRICT="${RESTRICT} nostrip"
+
+src_compile() {
+ cd ${S} || die
+ local myconf
+
+ if [ `use debug` ]; then
+ myconf="${myconf} --with-debug=3"
+ CFLAGS="${CFLAGS} -g"
+ fi
+ [ -c /dev/urandom ] && myconf="${myconf} --with-random-device=/dev/urandom"
+
+ econf \
+ --sysconfdir=/etc/pdnsd \
+ --with-cachedir=/var/cache/pdnsd \
+ --infodir=/usr/share/info --mandir=/usr/share/man \
+ `use_enable ipv6` `use_enable isdn` \
+ ${myconf} \
+ || die "bad configure"
+
+ emake all || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ enewgroup pdnsd
+ enewuser pdnsd -1 /bin/false /var/lib/pdnsd pdnsd
+
+ # Copy cache from prev versions
+ [ -f /var/lib/pdnsd/pdnsd.cache ] && cp /var/lib/pdnsd/pdnsd.cache ${D}/var/cache/pdnsd/pdnsd.cache
+
+ # Don't clobber existing cache
+ [ -f /var/cache/pdnsd/pdnsd.cache ] && rm ${D}/var/cache/pdnsd/pdnsd.cache
+
+ fowners pdnsd:pdnsd /var/cache/pdnsd
+
+ [ -f ${D}/var/cache/pdnsd/pdnsd.cache ] fowners pdnsd:pdnsd /var/cache/pdnsd/pdnsd.cache
+
+ sed -i 's/run_as=.*/run_as="pdnsd";/' ${D}/etc/pdnsd/pdnsd.conf.sample
+
+ dodoc AUTHORS COPYING* ChangeLog* NEWS README THANKS TODO README.par
+ docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
+ docinto html ; dohtml doc/html/*
+ docinto txt ; dodoc doc/txt/*
+ newdoc doc/pdnsd.conf pdnsd.conf.sample
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pdnsd.rc6 pdnsd
+ newexe ${FILESDIR}/pdnsd.online pdnsd-online
+
+ use ipv6 && \
+ ewarn "make sure your servers in /etc/pdnsd/pdnsd.conf are reachable with IPv6"
+
+ keepdir /etc/conf.d
+ local config=${D}/etc/conf.d/pdnsd-online
+ echo "# Enter the interface that connects you to the dns servers" > ${config}
+ echo "# This will correspond to /etc/init.d/net.${IFACE}" >> ${config}
+ echo "IFACE=ppp0" >> ${config}
+ use ipv6 && echo PDNSDCONFIG="-6" >> ${config} \
+ || echo PDNSDCONFIG="" >> ${config}
+
+ ${D}/usr/sbin/pdnsd --help | sed "s/^/# /g" >> ${config}
+
+ einfo "Add pdnsd to your default runlevel."
+ einfo ""
+ einfo "Add pdnsd-online to your online runlevel."
+ einfo "The online interface will be listed in /etc/conf.d/pdnsd-online"
+}