summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-03-12 21:43:01 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2015-03-12 21:43:01 +0000
commit5fe8063debcf203a43f4229dd81cea1fa58f466e (patch)
tree90584aedb003fdda913d1d39b0ff0f6cce1bafb3 /net-dns
parentEAPI=5 (diff)
downloadgentoo-2-5fe8063debcf203a43f4229dd81cea1fa58f466e.tar.gz
gentoo-2-5fe8063debcf203a43f4229dd81cea1fa58f466e.tar.bz2
gentoo-2-5fe8063debcf203a43f4229dd81cea1fa58f466e.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/openresolv/ChangeLog7
-rw-r--r--net-dns/openresolv/openresolv-3.6.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-dns/openresolv/ChangeLog b/net-dns/openresolv/ChangeLog
index cec5af97e2f6..959690d7b7d8 100644
--- a/net-dns/openresolv/ChangeLog
+++ b/net-dns/openresolv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/openresolv
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/ChangeLog,v 1.99 2015/02/28 22:03:04 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/ChangeLog,v 1.100 2015/03/12 21:43:01 alonbl Exp $
+
+*openresolv-3.6.2 (12 Mar 2015)
+
+ 12 Mar 2015; Alon Bar-Lev <alonbl@gentoo.org> +openresolv-3.6.2.ebuild:
+ Version bump
28 Feb 2015; Alon Bar-Lev <alonbl@gentoo.org> openresolv-3.6.1.ebuild:
Add selinux policy, bug#539688
diff --git a/net-dns/openresolv/openresolv-3.6.2.ebuild b/net-dns/openresolv/openresolv-3.6.2.ebuild
new file mode 100644
index 000000000000..2e8bb5f6ba78
--- /dev/null
+++ b/net-dns/openresolv/openresolv-3.6.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/openresolv-3.6.2.ebuild,v 1.1 2015/03/12 21:43:01 alonbl Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="http://roy.marples.name/projects/openresolv"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="!net-dns/resolvconf-gentoo
+ !<net-dns/dnsmasq-2.40-r1"
+RDEPEND="selinux? ( sec-policy/selinux-resolvconf )"
+
+src_configure() {
+ econf \
+ --prefix= \
+ --rundir=/var/run \
+ --libexecdir=/lib/resolvconf \
+ --restartcmd="/lib/resolvconf/helpers/restartcmd \1"
+}
+
+src_install() {
+ default
+ exeinto /lib/resolvconf/helpers
+ doexe "${FILESDIR}"/restartcmd
+}
+
+pkg_config() {
+ if [ "${ROOT}" != "/" ]; then
+ eerror "We cannot configure unless \$ROOT=/"
+ return 1
+ fi
+
+ if [ -n "$(resolvconf -l)" ]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}