summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-03-02 09:21:09 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-03-02 09:21:09 +0000
commitadc5766cb522bca6f744d253625707216f8232dd (patch)
tree4e2cb44fa74640f496546cd3d70b4a3d69daec07 /net-dns
parent+ urandom use for net-dns/bind (diff)
downloadgentoo-2-adc5766cb522bca6f744d253625707216f8232dd.tar.gz
gentoo-2-adc5766cb522bca6f744d253625707216f8232dd.tar.bz2
gentoo-2-adc5766cb522bca6f744d253625707216f8232dd.zip
+ /dev/urandom support; also closing bug #168888
(Portage version: 2.1.2-r12)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/ChangeLog10
-rw-r--r--net-dns/bind/bind-9.4.0-r1.ebuild (renamed from net-dns/bind/bind-9.4.0.ebuild)10
-rw-r--r--net-dns/bind/files/bind-9.4.0-dlzbdb-close_cursor.patch11
-rw-r--r--net-dns/bind/files/bind-9.4.0_rc2-missing_odbc_test.patch20
-rw-r--r--net-dns/bind/files/digest-bind-9.4.0-r1 (renamed from net-dns/bind/files/digest-bind-9.4.0)0
5 files changed, 28 insertions, 23 deletions
diff --git a/net-dns/bind/ChangeLog b/net-dns/bind/ChangeLog
index f6bd27dc6b40..f1f84c5a33ef 100644
--- a/net-dns/bind/ChangeLog
+++ b/net-dns/bind/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dns/bind
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.149 2007/02/28 15:02:18 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.150 2007/03/02 09:21:09 voxus Exp $
+
+*bind-9.4.0-r1 (02 Mar 2007)
+
+ 02 Mar 2007; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +files/bind-9.4.0-dlzbdb-close_cursor.patch,
+ -files/bind-9.4.0_rc2-missing_odbc_test.patch, -bind-9.4.0.ebuild,
+ +bind-9.4.0-r1.ebuild:
+ Support for /dev/urandom added, patch by Aurélien Requiem <bugs@menfin.net>.
*bind-9.4.0 (28 Feb 2007)
diff --git a/net-dns/bind/bind-9.4.0.ebuild b/net-dns/bind/bind-9.4.0-r1.ebuild
index 355d66283778..54797119020c 100644
--- a/net-dns/bind/bind-9.4.0.ebuild
+++ b/net-dns/bind/bind-9.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.4.0.ebuild,v 1.1 2007/02/28 15:02:18 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.4.0-r1.ebuild,v 1.1 2007/03/02 09:21:09 voxus Exp $
inherit eutils libtool autotools
@@ -14,7 +14,7 @@ SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV/_/}/${P/_/}.tar.gz
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="ssl ipv6 doc dlz postgres berkdb mysql odbc ldap selinux idn threads resolvconf"
+IUSE="ssl ipv6 doc dlz postgres berkdb mysql odbc ldap selinux idn threads resolvconf urandom"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
mysql? ( >=virtual/mysql-4.0 )
@@ -107,6 +107,12 @@ src_compile() {
myconf="${myconf} --disable-linux-caps --disable-threads"
fi
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
econf \
--sysconfdir=/etc/bind \
--localstatedir=/var \
diff --git a/net-dns/bind/files/bind-9.4.0-dlzbdb-close_cursor.patch b/net-dns/bind/files/bind-9.4.0-dlzbdb-close_cursor.patch
new file mode 100644
index 000000000000..ed71e16db188
--- /dev/null
+++ b/net-dns/bind/files/bind-9.4.0-dlzbdb-close_cursor.patch
@@ -0,0 +1,11 @@
+--- contrib/dlz/drivers/dlz_bdbhpt_driver.c 2007-03-02 12:02:12.000000000 +0300
++++ contrib/dlz/drivers/dlz_bdbhpt_driver.c 2007-03-02 12:02:18.000000000 +0300
+@@ -442,7 +442,7 @@
+ xfr_cursor->c_close(xfr_cursor);
+
+ if (dns_cursor != NULL)
+- dns_cursor->c_close(xfr_cursor);
++ dns_cursor->c_close(dns_cursor);
+
+ return result;
+ }
diff --git a/net-dns/bind/files/bind-9.4.0_rc2-missing_odbc_test.patch b/net-dns/bind/files/bind-9.4.0_rc2-missing_odbc_test.patch
deleted file mode 100644
index ead47527451a..000000000000
--- a/net-dns/bind/files/bind-9.4.0_rc2-missing_odbc_test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.in 2006-07-09 22:00:54.000000000 +0000
-+++ configure.in 2006-07-09 22:01:05.000000000 +0000
-@@ -686,17 +686,7 @@
- fi
- done
-
-- if test -z "`${CC} contrib/sdb/test//test.c -lodbc -o contrib/sdb/test/test.ok 2>&1`"; then
- DLZ_ODBC_LIB="-lodbc"
-- elif test -z "`${CC} contrib/sdb/test//test.c -liodbc -o contrib/sdb/test/test.ok 2>&1`"; then
-- DLZ_ODBC_LIB="-liodbc"
-- else
-- DLZ_ODBC_LIB=""
-- use_dlz_odbc="no"
-- AC_MSG_RESULT("no ODBC libraries found")
-- fi
-- rm -f contrib/sdb/test/test.ok
--
-
- if test "$use_dlz_odbc" = "yes"
- then
diff --git a/net-dns/bind/files/digest-bind-9.4.0 b/net-dns/bind/files/digest-bind-9.4.0-r1
index 5dce4389cdd3..5dce4389cdd3 100644
--- a/net-dns/bind/files/digest-bind-9.4.0
+++ b/net-dns/bind/files/digest-bind-9.4.0-r1