summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-10-11 15:18:36 +0000
committerJeroen Roovers <jer@gentoo.org>2011-10-11 15:18:36 +0000
commitb684f486a80c4d61b2d56ae1f823d37907e81a2b (patch)
tree83c7a9ce631e40948b6b4e83ab5eb0bef018c732 /net-dns
parentVersion bump mako to 0.5.0. (diff)
downloadgentoo-2-b684f486a80c4d61b2d56ae1f823d37907e81a2b.tar.gz
gentoo-2-b684f486a80c4d61b2d56ae1f823d37907e81a2b.tar.bz2
gentoo-2-b684f486a80c4d61b2d56ae1f823d37907e81a2b.zip
Introduce USE=static-libs thanks to Hans, patch by Ago (bug #386581).
(Portage version: 2.2.0_alpha66/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/idnkit/ChangeLog7
-rw-r--r--net-dns/idnkit/idnkit-1.0-r2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/net-dns/idnkit/ChangeLog b/net-dns/idnkit/ChangeLog
index 9567c9e3cace..e03f77be62bf 100644
--- a/net-dns/idnkit/ChangeLog
+++ b/net-dns/idnkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/idnkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/idnkit/ChangeLog,v 1.30 2011/01/22 17:44:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/idnkit/ChangeLog,v 1.31 2011/10/11 15:18:36 jer Exp $
+
+*idnkit-1.0-r2 (11 Oct 2011)
+
+ 11 Oct 2011; Jeroen Roovers <jer@gentoo.org> +idnkit-1.0-r2.ebuild:
+ Introduce USE=static-libs thanks to Hans, patch by Ago (bug #386581).
22 Jan 2011; Jeroen Roovers <jer@gentoo.org>
files/idnkit-1.0-autotools.patch:
diff --git a/net-dns/idnkit/idnkit-1.0-r2.ebuild b/net-dns/idnkit/idnkit-1.0-r2.ebuild
new file mode 100644
index 000000000000..80a45aae1d21
--- /dev/null
+++ b/net-dns/idnkit/idnkit-1.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/idnkit/idnkit-1.0-r2.ebuild,v 1.1 2011/10/11 15:18:36 jer Exp $
+
+EAPI="4"
+
+inherit autotools autotools-utils eutils fixheadtails
+
+DESCRIPTION="Toolkit for Internationalized Domain Names (IDN)"
+HOMEPAGE="http://www.nic.ad.jp/ja/idn/idnkit/download/"
+SRC_URI="http://www.nic.ad.jp/ja/idn/idnkit/download/sources/${P}-src.tar.gz"
+
+LICENSE="JNIC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-libs/glibc"
+# non gnu systems need libiconv
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ ht_fix_all
+ # Bug 263135, old broken libtool bundled
+ rm -f aclocal.m4 || die "rm failed"
+ epatch "${FILESDIR}/${P}-autotools.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || remove_libtool_files
+ dodoc ChangeLog DISTFILES NEWS README README.ja
+}