summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-02-22 11:12:46 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-02-22 11:12:46 +0000
commitd54a6f73b2869ac66c052e6a399bf10928b4665e (patch)
treed372a0962d32401cd641b1ac58a1024d9f5d8b2b /net-dns
parentstable x86; bug 158434 (diff)
downloadgentoo-2-d54a6f73b2869ac66c052e6a399bf10928b4665e.tar.gz
gentoo-2-d54a6f73b2869ac66c052e6a399bf10928b4665e.tar.bz2
gentoo-2-d54a6f73b2869ac66c052e6a399bf10928b4665e.zip
* closing bug #167605
(Portage version: 2.1.2-r10)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/ChangeLog10
-rw-r--r--net-dns/bind/bind-9.2.8-r1.ebuild275
-rw-r--r--net-dns/bind/bind-9.3.4-r1.ebuild273
-rw-r--r--net-dns/bind/files/bind-dlzbdb-close_cursor.patch11
-rw-r--r--net-dns/bind/files/digest-bind-9.2.8-r19
-rw-r--r--net-dns/bind/files/digest-bind-9.3.4-r19
6 files changed, 586 insertions, 1 deletions
diff --git a/net-dns/bind/ChangeLog b/net-dns/bind/ChangeLog
index 2cd4b648239e..7107bb1a4ad0 100644
--- a/net-dns/bind/ChangeLog
+++ b/net-dns/bind/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dns/bind
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.147 2007/02/14 13:41:39 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.148 2007/02/22 11:12:46 voxus Exp $
+
+*bind-9.3.4-r1 (22 Feb 2007)
+*bind-9.2.8-r1 (22 Feb 2007)
+
+ 22 Feb 2007; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +files/bind-dlzbdb-close_cursor.patch, +bind-9.2.8-r1.ebuild,
+ +bind-9.3.4-r1.ebuild:
+ Closing bug #167605.
14 Feb 2007; Bryan Østergaard <kloeri@gentoo.org> bind-9.2.8.ebuild,
bind-9.3.4.ebuild:
diff --git a/net-dns/bind/bind-9.2.8-r1.ebuild b/net-dns/bind/bind-9.2.8-r1.ebuild
new file mode 100644
index 000000000000..c57ed3dc493d
--- /dev/null
+++ b/net-dns/bind/bind-9.2.8-r1.ebuild
@@ -0,0 +1,275 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.8-r1.ebuild,v 1.1 2007/02/22 11:12:46 voxus Exp $
+
+inherit eutils libtool autotools
+
+DLZ_VERSION="9.2.7"
+
+DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz
+ doc? ( mirror://gentoo/dyndns-samples.tbz2 )
+ dlz? ( http://dev.gentoo.org/~voxus/dlz/dlz-${DLZ_VERSION}.patch.bz2 )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl ipv6 doc dlz postgres berkdb mysql odbc ldap selinux idn threads resolvconf"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
+ mysql? ( >=virtual/mysql-4.0 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/idnkit )
+ resolvconf? ( net-dns/resolvconf-gentoo )"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-bind )"
+
+pkg_setup() {
+ use threads && {
+ echo
+ ewarn "If you're in vserver enviroment, you're probably want to"
+ ewarn "disable threads support because of linux capabilities dependency"
+ echo
+ }
+
+ ebegin "Creating named group and user"
+ enewgroup named 40
+ enewuser named 40 -1 /etc/bind named
+ eend ${?}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Adjusting PATHs in manpages
+ for i in bin/{named/named.8,check/named-checkconf.8,rndc/rndc.8} ; do
+ sed -i \
+ -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
+ -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
+ "${i}"
+ done
+
+ use dlz && {
+ epatch ${DISTDIR}/dlz-${DLZ_VERSION}.patch.bz2
+ epatch ${FILESDIR}/bind-9.2.5-berkdb_fix.patch
+ epatch ${FILESDIR}/${PN}-dlzbdb-includes.patch
+ epatch ${FILESDIR}/${PN}-dlzbdb-close_cursor.patch
+
+ # use odbc && epatch ${FILESDIR}/${P}-missing_odbc_test.patch
+ }
+
+ # should be installed by bind-tools
+ sed -e "s:nsupdate ::g" -i ${S}/bin/Makefile.in
+
+ WANT_AUTOCONF=2.5 AT_NO_RECURSIVE=1 eautoreconf || die "eautoreconf failed"
+
+ # bug #151839
+ sed \
+ -e 's:<config.h>:<config.h>\n\n#undef SO_BSDCOMPAT:' \
+ -i lib/isc/unix/socket.c
+}
+
+src_compile() {
+ local myconf=""
+
+ use ssl && myconf="${myconf} --with-openssl"
+ use idn && myconf="${myconf} --with-idn"
+
+ use dlz && {
+ myconf="${myconf} --with-dlz-filesystem --with-dlz-stub"
+ use postgres && myconf="${myconf} --with-dlz-postgres"
+ use mysql && myconf="${myconf} --with-dlz-mysql"
+ use berkdb && myconf="${myconf} --with-dlz-bdb"
+ use ldap && myconf="${myconf} --with-dlz-ldap"
+ use odbc && myconf="${myconf} --with-dlz-odbc"
+ }
+
+ if use threads; then
+ if use dlz && use mysql; then
+ echo
+ ewarn ""
+ einfo "MySQL uses thread local storage in its C api. Thus MySQL"
+ einfo "requires that each thread of an application execute a MySQL"
+ einfo "\"thread initialization\" to setup the thread local storage."
+ einfo "This is impossible to do safely while staying within the DLZ"
+ einfo "driver API. This is a limitation caused by MySQL, and not"
+ einfo "the DLZ API."
+ ewarn "Because of this BIND MUST only run with a single thread when"
+ ewarn "using the MySQL driver."
+ echo
+ myconf="${myconf} --disable-linux-caps --disable-threads"
+ einfo "Threading support disabled"
+ epause 10
+ else
+ myconf="${myconf} --enable-linux-caps --enable-threads"
+ einfo "Threading support enabled"
+ fi
+ else
+ myconf="${myconf} --disable-linux-caps --disable-threads"
+ fi
+
+ econf \
+ --sysconfdir=/etc/bind \
+ --localstatedir=/var \
+ --with-libtool \
+ `use_enable ipv6` \
+ ${myconf} || die "econf failed"
+
+ emake -j1 || die "failed to compile bind"
+}
+
+src_install() {
+ einstall || die "failed to install bind"
+
+ dodoc CHANGES COPYRIGHT FAQ README
+
+ use doc && {
+ docinto misc
+ dodoc doc/misc/*
+
+ docinto html
+ dohtml doc/arm/*
+
+ docinto draft
+ dodoc doc/draft/*
+
+ docinto rfc
+ dodoc doc/rfc/*
+
+ docinto contrib
+ dodoc contrib/named-bootconf/named-bootconf.sh \
+ contrib/nanny/nanny.pl
+
+ # some handy-dandy dynamic dns examples
+ cd ${D}/usr/share/doc/${PF}
+ tar pjxf ${DISTFILES}/dyndns-samples.tbz2
+ }
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/10bind.env 10bind
+
+ dodir /etc/bind /var/bind/{pri,sec}
+ keepdir /var/bind/sec
+
+ insinto /etc/bind ; newins ${FILESDIR}/named.conf-r3 named.conf
+
+ # ftp://ftp.rs.internic.net/domain/named.ca:
+ insinto /var/bind ; doins ${FILESDIR}/named.ca
+
+ insinto /var/bind/pri
+ doins ${FILESDIR}/127.zone
+ newins ${FILESDIR}/localhost.zone-r2 localhost.zone
+
+ cp ${FILESDIR}/named.init-r4 ${T}/named && doinitd ${T}/named
+ cp ${FILESDIR}/named.confd-r1 ${T}/named && doconfd ${T}/named
+
+ dosym ../../var/bind/named.ca /var/bind/root.cache
+ dosym ../../var/bind/pri /etc/bind/pri
+ dosym ../../var/bind/sec /etc/bind/sec
+
+ # Let's get rid of those tools and their manpages since they're provided by bind-tools
+ rm -f ${D}/usr/share/man/man1/{dig.1,host.1,nslookup.1}
+ rm -f ${D}/usr/bin/{dig,host,nslookup}
+
+ use resolvconf && {
+ exeinto /etc/resolvconf/update.d
+ newexe ${FILESDIR}/resolvconf.bind bind
+ }
+}
+
+pkg_postinst() {
+ if [ ! -f '/etc/bind/rndc.key' ]; then
+ if [ -c /dev/urandom ]; then
+ einfo "Using /dev/urandom for generating rndc.key"
+ /usr/sbin/rndc-confgen -r /dev/urandom -a -u named
+ echo
+ else
+ einfo "Using /dev/random for generating rndc.key"
+ /usr/sbin/rndc-confgen -a -u named
+ echo
+ fi
+ fi
+
+ install -d -o named -g named ${ROOT}/var/run/named \
+ ${ROOT}/var/bind/pri ${ROOT}/var/bind/sec
+ chown -R named:named ${ROOT}/var/bind
+
+ einfo "The default zone files are now installed as *.zone,"
+ einfo "be careful merging config files if you have modified"
+ einfo "/var/bind/pri/127 or /var/bind/pri/localhost"
+ einfo
+ einfo "You can edit /etc/conf.d/named to customize named settings"
+ einfo
+ einfo "The BIND ebuild now includes chroot support."
+ einfo "If you like to run bind in chroot AND this is a new install OR"
+ einfo "your bind doesn't already run in chroot, simply run:"
+ einfo "\`emerge --config '=${CATEGORY}/${PF}'\`"
+ einfo "Before running the above command you might want to change the chroot"
+ einfo "dir in /etc/conf.d/named. Otherwise /chroot/dns will be used."
+ echo
+ einfo "Recently verisign added a wildcard A record to the .COM and .NET TLD"
+ einfo "zones making all .com and .net domains appear to be registered"
+ einfo "This causes many problems such as breaking important anti-spam checks"
+ einfo "which verify source domains exist. ISC released a patch for BIND which"
+ einfo "adds 'delegation-only' zones to allow admins to return the .com and .net"
+ einfo "domain resolution to their normal function."
+ echo
+ einfo "There is no need to create a com or net data file. Just the"
+ einfo "entries to the named.conf file is enough."
+ echo
+ einfo " zone "com" IN { type delegation-only; };"
+ einfo " zone "net" IN { type delegation-only; };"
+
+ echo
+ ewarn "BIND >=9.2.5 makes the priority argument to MX records mandatory"
+ ewarn "when it was previously optional. If the priority is missing, BIND"
+ ewarn "won't load the zone file at all."
+ echo
+}
+
+pkg_config() {
+ CHROOT=`sed -n 's/^[[:blank:]]\?CHROOT="\([^"]\+\)"/\1/p' /etc/conf.d/named 2>/dev/null`
+ EXISTS="no"
+
+ if [ -z "${CHROOT}" -a ! -d "/chroot/dns" ]; then
+ CHROOT="/chroot/dns"
+ elif [ -d ${CHROOT} ]; then
+ eerror; eerror "${CHROOT:-/chroot/dns} already exists. Quitting."; eerror; EXISTS="yes"
+ fi
+
+ if [ ! "$EXISTS" = yes ]; then
+ einfo ; einfon "Setting up the chroot directory..."
+ mkdir -m 700 -p ${CHROOT}
+ mkdir -p ${CHROOT}/{dev,etc,var/run/named}
+ chown -R named:named ${CHROOT}/var/run/named
+ cp -R /etc/bind ${CHROOT}/etc/
+ cp /etc/localtime ${CHROOT}/etc/localtime
+ chown named:named ${CHROOT}/etc/bind/rndc.key
+ cp -R /var/bind ${CHROOT}/var/
+ chown -R named:named ${CHROOT}/var/
+ mknod ${CHROOT}/dev/zero c 1 5
+ mknod ${CHROOT}/dev/random c 1 8
+ chmod 666 ${CHROOT}/dev/{random,zero}
+ chown root:named ${CHROOT}
+ chmod 0750 ${CHROOT}
+
+ grep -q "^#[[:blank:]]\?CHROOT" /etc/conf.d/named ; RETVAL=$?
+ if [ $RETVAL = 0 ]; then
+ sed 's/^# \?\(CHROOT.*\)$/\1/' /etc/conf.d/named > /etc/conf.d/named.orig 2>/dev/null
+ mv --force /etc/conf.d/named.orig /etc/conf.d/named
+ fi
+
+ sleep 1; echo " Done."; sleep 1
+ einfo
+ einfo "Add the following to your root .bashrc or .bash_profile: "
+ einfo " alias rndc='rndc -k ${CHROOT}/etc/bind/rndc.key'"
+ einfo "Then do the following: "
+ einfo " source /root/.bashrc or .bash_profile"
+ einfo
+ fi
+}
diff --git a/net-dns/bind/bind-9.3.4-r1.ebuild b/net-dns/bind/bind-9.3.4-r1.ebuild
new file mode 100644
index 000000000000..140390f981d7
--- /dev/null
+++ b/net-dns/bind/bind-9.3.4-r1.ebuild
@@ -0,0 +1,273 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.4-r1.ebuild,v 1.1 2007/02/22 11:12:46 voxus Exp $
+
+inherit eutils libtool autotools
+
+DLZ_VERSION="9.3.3"
+
+DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz
+ doc? ( mirror://gentoo/dyndns-samples.tbz2 )
+ dlz? ( http://dev.gentoo.org/~voxus/bind/ctrix_dlz_${DLZ_VERSION}.patch.bz2 )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ssl ipv6 doc dlz postgres berkdb mysql odbc ldap selinux idn threads resolvconf"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
+ mysql? ( >=virtual/mysql-4.0 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/idnkit )
+ resolvconf? ( net-dns/resolvconf-gentoo )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-bind )"
+
+pkg_setup() {
+ use threads && {
+ echo
+ ewarn "If you're in vserver enviroment, you're probably want to"
+ ewarn "disable threads support because of linux capabilities dependency"
+ echo
+ }
+
+ ebegin "Creating named group and user"
+ enewgroup named 40
+ enewuser named 40 -1 /etc/bind named
+ eend ${?}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Adjusting PATHs in manpages
+ for i in bin/{named/named.8,check/named-checkconf.8,rndc/rndc.8} ; do
+ sed -i \
+ -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
+ -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
+ "${i}"
+ done
+
+ use dlz && {
+ epatch ${DISTDIR}/ctrix_dlz_${DLZ_VERSION}.patch.bz2
+ epatch ${FILESDIR}/${PN}-dlzbdb-includes.patch
+ epatch ${FILESDIR}/${PN}-dlzbdb-close_cursor.patch
+
+ use odbc && epatch ${FILESDIR}/${P}-missing_odbc_test.patch
+ }
+
+ # should be installed by bind-tools
+ sed -e "s:nsupdate ::g" -i ${S}/bin/Makefile.in
+
+ WANT_AUTOCONF=2.5 AT_NO_RECURSIVE=1 eautoreconf || die "eautoreconf failed"
+
+ # bug #151839
+ sed \
+ -e 's:<config.h>:<config.h>\n\n#undef SO_BSDCOMPAT:' \
+ -i lib/isc/unix/socket.c
+}
+
+src_compile() {
+ local myconf=""
+
+ use ssl && myconf="${myconf} --with-openssl"
+ use idn && myconf="${myconf} --with-idn"
+
+ use dlz && {
+ myconf="${myconf} --with-dlz-filesystem --with-dlz-stub"
+ use postgres && myconf="${myconf} --with-dlz-postgres"
+ use mysql && myconf="${myconf} --with-dlz-mysql"
+ use berkdb && myconf="${myconf} --with-dlz-bdb"
+ use ldap && myconf="${myconf} --with-dlz-ldap"
+ use odbc && myconf="${myconf} --with-dlz-odbc"
+ }
+
+ if use threads; then
+ if use dlz && use mysql; then
+ echo
+ ewarn ""
+ einfo "MySQL uses thread local storage in its C api. Thus MySQL"
+ einfo "requires that each thread of an application execute a MySQL"
+ einfo "\"thread initialization\" to setup the thread local storage."
+ einfo "This is impossible to do safely while staying within the DLZ"
+ einfo "driver API. This is a limitation caused by MySQL, and not"
+ einfo "the DLZ API."
+ ewarn "Because of this BIND MUST only run with a single thread when"
+ ewarn "using the MySQL driver."
+ echo
+ myconf="${myconf} --disable-linux-caps --disable-threads"
+ einfo "Threading support disabled"
+ epause 10
+ else
+ myconf="${myconf} --enable-linux-caps --enable-threads"
+ einfo "Threading support enabled"
+ fi
+ else
+ myconf="${myconf} --disable-linux-caps --disable-threads"
+ fi
+
+ econf \
+ --sysconfdir=/etc/bind \
+ --localstatedir=/var \
+ --with-libtool \
+ `use_enable ipv6` \
+ ${myconf} || die "econf failed"
+
+ emake -j1 || die "failed to compile bind"
+}
+
+src_install() {
+ einstall || die "failed to install bind"
+
+ dodoc CHANGES COPYRIGHT FAQ README
+
+ use doc && {
+ docinto misc
+ dodoc doc/misc/*
+
+ docinto html
+ dohtml doc/arm/*
+
+ docinto draft
+ dodoc doc/draft/*
+
+ docinto rfc
+ dodoc doc/rfc/*
+
+ docinto contrib
+ dodoc contrib/named-bootconf/named-bootconf.sh \
+ contrib/nanny/nanny.pl
+
+ # some handy-dandy dynamic dns examples
+ cd ${D}/usr/share/doc/${PF}
+ tar pjxf ${DISTFILES}/dyndns-samples.tbz2
+ }
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/10bind.env 10bind
+
+ dodir /etc/bind /var/bind/{pri,sec}
+ keepdir /var/bind/sec
+
+ insinto /etc/bind ; newins ${FILESDIR}/named.conf-r3 named.conf
+
+ # ftp://ftp.rs.internic.net/domain/named.ca:
+ insinto /var/bind ; doins ${FILESDIR}/named.ca
+
+ insinto /var/bind/pri
+ doins ${FILESDIR}/127.zone
+ newins ${FILESDIR}/localhost.zone-r2 localhost.zone
+
+ cp ${FILESDIR}/named.init-r4 ${T}/named && doinitd ${T}/named
+ cp ${FILESDIR}/named.confd-r1 ${T}/named && doconfd ${T}/named
+
+ dosym ../../var/bind/named.ca /var/bind/root.cache
+ dosym ../../var/bind/pri /etc/bind/pri
+ dosym ../../var/bind/sec /etc/bind/sec
+
+ # Let's get rid of those tools and their manpages since they're provided by bind-tools
+ rm -f ${D}/usr/share/man/man1/{dig.1,host.1,nslookup.1}
+ rm -f ${D}/usr/bin/{dig,host,nslookup}
+
+ use resolvconf && {
+ exeinto /etc/resolvconf/update.d
+ newexe ${FILESDIR}/resolvconf.bind bind
+ }
+}
+
+pkg_postinst() {
+ if [ ! -f '/etc/bind/rndc.key' ]; then
+ if [ -c /dev/urandom ]; then
+ einfo "Using /dev/urandom for generating rndc.key"
+ /usr/sbin/rndc-confgen -r /dev/urandom -a -u named
+ echo
+ else
+ einfo "Using /dev/random for generating rndc.key"
+ /usr/sbin/rndc-confgen -a -u named
+ echo
+ fi
+ fi
+
+ install -d -o named -g named ${ROOT}/var/run/named \
+ ${ROOT}/var/bind/pri ${ROOT}/var/bind/sec
+ chown -R named:named ${ROOT}/var/bind
+
+ einfo "The default zone files are now installed as *.zone,"
+ einfo "be careful merging config files if you have modified"
+ einfo "/var/bind/pri/127 or /var/bind/pri/localhost"
+ einfo
+ einfo "You can edit /etc/conf.d/named to customize named settings"
+ einfo
+ einfo "The BIND ebuild now includes chroot support."
+ einfo "If you like to run bind in chroot AND this is a new install OR"
+ einfo "your bind doesn't already run in chroot, simply run:"
+ einfo "\`emerge --config '=${CATEGORY}/${PF}'\`"
+ einfo "Before running the above command you might want to change the chroot"
+ einfo "dir in /etc/conf.d/named. Otherwise /chroot/dns will be used."
+ echo
+ einfo "Recently verisign added a wildcard A record to the .COM and .NET TLD"
+ einfo "zones making all .com and .net domains appear to be registered"
+ einfo "This causes many problems such as breaking important anti-spam checks"
+ einfo "which verify source domains exist. ISC released a patch for BIND which"
+ einfo "adds 'delegation-only' zones to allow admins to return the .com and .net"
+ einfo "domain resolution to their normal function."
+ echo
+ einfo "There is no need to create a com or net data file. Just the"
+ einfo "entries to the named.conf file is enough."
+ echo
+ einfo " zone "com" IN { type delegation-only; };"
+ einfo " zone "net" IN { type delegation-only; };"
+
+ echo
+ ewarn "BIND >=9.2.5 makes the priority argument to MX records mandatory"
+ ewarn "when it was previously optional. If the priority is missing, BIND"
+ ewarn "won't load the zone file at all."
+ echo
+}
+
+pkg_config() {
+ CHROOT=`sed -n 's/^[[:blank:]]\?CHROOT="\([^"]\+\)"/\1/p' /etc/conf.d/named 2>/dev/null`
+ EXISTS="no"
+
+ if [ -z "${CHROOT}" -a ! -d "/chroot/dns" ]; then
+ CHROOT="/chroot/dns"
+ elif [ -d ${CHROOT} ]; then
+ eerror; eerror "${CHROOT:-/chroot/dns} already exists. Quitting."; eerror; EXISTS="yes"
+ fi
+
+ if [ ! "$EXISTS" = yes ]; then
+ einfo ; einfon "Setting up the chroot directory..."
+ mkdir -m 700 -p ${CHROOT}
+ mkdir -p ${CHROOT}/{dev,etc,var/run/named}
+ chown -R named:named ${CHROOT}/var/run/named
+ cp -R /etc/bind ${CHROOT}/etc/
+ cp /etc/localtime ${CHROOT}/etc/localtime
+ chown named:named ${CHROOT}/etc/bind/rndc.key
+ cp -R /var/bind ${CHROOT}/var/
+ chown -R named:named ${CHROOT}/var/
+ mknod ${CHROOT}/dev/zero c 1 5
+ mknod ${CHROOT}/dev/random c 1 8
+ chmod 666 ${CHROOT}/dev/{random,zero}
+ chown root:named ${CHROOT}
+ chmod 0750 ${CHROOT}
+
+ grep -q "^#[[:blank:]]\?CHROOT" /etc/conf.d/named ; RETVAL=$?
+ if [ $RETVAL = 0 ]; then
+ sed 's/^# \?\(CHROOT.*\)$/\1/' /etc/conf.d/named > /etc/conf.d/named.orig 2>/dev/null
+ mv --force /etc/conf.d/named.orig /etc/conf.d/named
+ fi
+
+ sleep 1; echo " Done."; sleep 1
+ einfo
+ einfo "Add the following to your root .bashrc or .bash_profile: "
+ einfo " alias rndc='rndc -k ${CHROOT}/etc/bind/rndc.key'"
+ einfo "Then do the following: "
+ einfo " source /root/.bashrc or .bash_profile"
+ einfo
+ fi
+}
diff --git a/net-dns/bind/files/bind-dlzbdb-close_cursor.patch b/net-dns/bind/files/bind-dlzbdb-close_cursor.patch
new file mode 100644
index 000000000000..5eb8c122290d
--- /dev/null
+++ b/net-dns/bind/files/bind-dlzbdb-close_cursor.patch
@@ -0,0 +1,11 @@
+--- bin/named/dlz_bdbhpt_driver.c Thu May 4 13:13:20 2006
++++ bin/named/dlz_bdbhpt_driver.c Thu May 4 13:27:05 2006
+@@ -462,7 +462,7 @@
+ xfr_cursor->c_close(xfr_cursor);
+
+ if(dns_cursor != NULL)
+- dns_cursor->c_close(xfr_cursor);
++ dns_cursor->c_close(dns_cursor);
+
+ return result;
+ }
diff --git a/net-dns/bind/files/digest-bind-9.2.8-r1 b/net-dns/bind/files/digest-bind-9.2.8-r1
new file mode 100644
index 000000000000..6d73dad89748
--- /dev/null
+++ b/net-dns/bind/files/digest-bind-9.2.8-r1
@@ -0,0 +1,9 @@
+MD5 55455401e8b45b79cea89d3d79118ced bind-9.2.8.tar.gz 5208805
+RMD160 4bdba3e75a9d188d05787ca553aa656a416d4534 bind-9.2.8.tar.gz 5208805
+SHA256 4c037a1ffe71f8baa8b416589faa0a3c312b2afe7b79bde9ebf9bbde5af5a11d bind-9.2.8.tar.gz 5208805
+MD5 10b9cf6eeb8f1a63ad49bef6d4739a66 dlz-9.2.7.patch.bz2 100068
+RMD160 d53b00b27e43b645e96d25c3a7bdbc8e0d2ebade dlz-9.2.7.patch.bz2 100068
+SHA256 db255c43cdee05c05ac8f240e1d75dcbee3f010e41e9f08b133c14b209363e8c dlz-9.2.7.patch.bz2 100068
+MD5 2bb12cfcd70284e72fbf9e70e5e2974d dyndns-samples.tbz2 22866
+RMD160 27d5b2d0edb8e1ff16b3f980c38d7af33ccf0c7d dyndns-samples.tbz2 22866
+SHA256 92fb06a92ca99cbbe96b90bcca229ef9c12397db57ae17e199dad9f1218fdbe8 dyndns-samples.tbz2 22866
diff --git a/net-dns/bind/files/digest-bind-9.3.4-r1 b/net-dns/bind/files/digest-bind-9.3.4-r1
new file mode 100644
index 000000000000..52fae07ad51b
--- /dev/null
+++ b/net-dns/bind/files/digest-bind-9.3.4-r1
@@ -0,0 +1,9 @@
+MD5 df5417e7e7cf017fa28b65d0a3d6e999 bind-9.3.4.tar.gz 5405022
+RMD160 8b5fda9542f6afbe7ffb857d72f7e545237d7826 bind-9.3.4.tar.gz 5405022
+SHA256 40152026af715b15ac958f374394e5189a099b562eb913470ccc43f6fbd19c21 bind-9.3.4.tar.gz 5405022
+MD5 00419378bdf3691c7d2fe7737f25007d ctrix_dlz_9.3.3.patch.bz2 66143
+RMD160 ee3a7ef8e1b3167ff572ca8a7836a8d4d64a834d ctrix_dlz_9.3.3.patch.bz2 66143
+SHA256 6550455ba37f5f25f047078bedf825d05eab45bbc4a3d8b7bf23a716749423cf ctrix_dlz_9.3.3.patch.bz2 66143
+MD5 2bb12cfcd70284e72fbf9e70e5e2974d dyndns-samples.tbz2 22866
+RMD160 27d5b2d0edb8e1ff16b3f980c38d7af33ccf0c7d dyndns-samples.tbz2 22866
+SHA256 92fb06a92ca99cbbe96b90bcca229ef9c12397db57ae17e199dad9f1218fdbe8 dyndns-samples.tbz2 22866