summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-12-14 15:52:59 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-12-14 15:52:59 +0000
commitdd7b6e37f6c5fd37e3b0e2d7c8f07c9b7a903c21 (patch)
tree644679d4cf3595ae432f87cb2d857aeaabf69cba /net-dns
parentstable amd64, bug 250793 (diff)
downloadgentoo-2-dd7b6e37f6c5fd37e3b0e2d7c8f07c9b7a903c21.tar.gz
gentoo-2-dd7b6e37f6c5fd37e3b0e2d7c8f07c9b7a903c21.tar.bz2
gentoo-2-dd7b6e37f6c5fd37e3b0e2d7c8f07c9b7a903c21.zip
Bump to 2.1.9 for security bug #248709 and bug #248758.
(Portage version: 2.2_rc17/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/noip-updater/ChangeLog9
-rw-r--r--net-dns/noip-updater/files/noip-2.1.9-daemon.patch21
-rw-r--r--net-dns/noip-updater/files/noip-2.1.9-flags.patch11
-rw-r--r--net-dns/noip-updater/noip-updater-2.1.9.ebuild57
4 files changed, 97 insertions, 1 deletions
diff --git a/net-dns/noip-updater/ChangeLog b/net-dns/noip-updater/ChangeLog
index 5308d61c1ea9..0d0c9652937d 100644
--- a/net-dns/noip-updater/ChangeLog
+++ b/net-dns/noip-updater/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/noip-updater
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/ChangeLog,v 1.32 2008/05/01 21:19:04 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/ChangeLog,v 1.33 2008/12/14 15:52:59 eva Exp $
+
+*noip-updater-2.1.9 (14 Dec 2008)
+
+ 14 Dec 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/noip-2.1.9-daemon.patch, +files/noip-2.1.9-flags.patch,
+ +noip-updater-2.1.9.ebuild:
+ Bump to 2.1.9 for security bug #248709 and bug #248758.
*noip-updater-2.1.7-r1 (02 May 2008)
diff --git a/net-dns/noip-updater/files/noip-2.1.9-daemon.patch b/net-dns/noip-updater/files/noip-2.1.9-daemon.patch
new file mode 100644
index 000000000000..b2fb4e66d0c7
--- /dev/null
+++ b/net-dns/noip-updater/files/noip-2.1.9-daemon.patch
@@ -0,0 +1,21 @@
+diff -ur a/noip2.c b/noip2.c
+--- a/noip2.c 2004-01-09 14:18:39.000000000 +0000
++++ b/noip2.c 2007-07-20 14:02:41.100377515 +0100
+@@ -895,16 +895,13 @@
+ char *err_string;
+ static int startup = 1;
+
+- x = fork();
++ x = daemon (0, 0);
+ switch (x) {
+ case -1: // error
+ err_string = strerror(errno);
+ Msg( "Can't fork!! (%s) Ending!\n", err_string);
+ return FATALERR;
+- default: // parent
+- exit(0);
+ case 0: //child
+- setsid();
+ if (get_shm_info() == FATALERR)
+ return FATALERR;
+ log2syslog++;
diff --git a/net-dns/noip-updater/files/noip-2.1.9-flags.patch b/net-dns/noip-updater/files/noip-2.1.9-flags.patch
new file mode 100644
index 000000000000..9fe05f36ac2d
--- /dev/null
+++ b/net-dns/noip-updater/files/noip-2.1.9-flags.patch
@@ -0,0 +1,11 @@
+--- a/Makefile 2006-09-07 09:52:55.000000000 +0200
++++ b/Makefile 2006-09-07 09:54:54.000000000 +0200
+@@ -21,7 +21,7 @@
+ # ARCH=sun
+
+ ${TGT}: Makefile ${TGT}.c
+- ${CC} -Wall -g -D${ARCH} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
++ ${CC} ${CFLAGS} -D${ARCH} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS} ${LDFLAGS}
+
+ install: ${TGT}
+ if [ ! -d ${BINDIR} ]; then mkdir -p ${BINDIR};fi
diff --git a/net-dns/noip-updater/noip-updater-2.1.9.ebuild b/net-dns/noip-updater/noip-updater-2.1.9.ebuild
new file mode 100644
index 000000000000..b30492144d6c
--- /dev/null
+++ b/net-dns/noip-updater/noip-updater-2.1.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/noip-updater-2.1.9.ebuild,v 1.1 2008/12/14 15:52:59 eva Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-updater/}
+DESCRIPTION="no-ip.com dynamic DNS updater"
+HOMEPAGE="http://www.no-ip.com"
+SRC_URI="http://www.no-ip.com/client/linux/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gcc"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/noip-2.1.9-flags.patch
+ epatch "${FILESDIR}"/noip-2.1.9-daemon.patch
+ sed -i \
+ -e "s:\(#define CONFIG_FILEPATH\).*:\1 \"/etc\":" \
+ -e "s:\(#define CONFIG_FILENAME\).*:\1 \"/etc/no-ip2.conf\":" \
+ noip2.c || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ PREFIX=/usr \
+ CONFDIR=/etc || die "emake failed"
+}
+
+src_install() {
+ dosbin noip2
+ dodoc README.FIRST
+ newinitd "${FILESDIR}"/noip2.start noip
+}
+
+pkg_postinst() {
+ elog "Configuration can be done manually via:"
+ elog "/usr/sbin/noip2 -C or "
+ elog "first time you use the /etc/init.d/noip script; or"
+ elog "by using this ebuild's config option."
+}
+
+pkg_config() {
+ cd /tmp
+ einfo "Answer the following questions."
+ noip2 -C || die
+}