summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-08-07 17:32:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-08-07 17:32:34 +0000
commitcd00ed20476f3738de7125a1f5298a2c81ae741a (patch)
tree5849c1ba5ce38c5a03cd1ff3154462c216f28b16 /net-firewall/ipp2p
parentstable on alpha (diff)
downloadgentoo-2-cd00ed20476f3738de7125a1f5298a2c81ae741a.tar.gz
gentoo-2-cd00ed20476f3738de7125a1f5298a2c81ae741a.tar.bz2
gentoo-2-cd00ed20476f3738de7125a1f5298a2c81ae741a.zip
Fix bug #101635.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-firewall/ipp2p')
-rw-r--r--net-firewall/ipp2p/ChangeLog6
-rw-r--r--net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild11
-rw-r--r--net-firewall/ipp2p/ipp2p-0.8.0_rc3.ebuild11
3 files changed, 19 insertions, 9 deletions
diff --git a/net-firewall/ipp2p/ChangeLog b/net-firewall/ipp2p/ChangeLog
index c82e9ffef3f8..5f4be4d8388f 100644
--- a/net-firewall/ipp2p/ChangeLog
+++ b/net-firewall/ipp2p/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/ipp2p
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.11 2005/08/06 03:21:31 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.12 2005/08/07 17:32:34 eradicator Exp $
+
+ 07 Aug 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ ipp2p-0.7.4-r2.ebuild, ipp2p-0.8.0_rc3.ebuild:
+ Fix bug #101635.
06 Aug 2005; Jeremy Huddleston <eradicator@gentoo.org>
-files/ipp2p-0.7-Makefile.patch, -ipp2p-0.7.1-r1.ebuild,
diff --git a/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild b/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild
index 1348dfad347a..fe984101d15d 100644
--- a/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild
+++ b/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild,v 1.2 2005/08/06 03:21:31 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.7.4-r2.ebuild,v 1.3 2005/08/07 17:32:34 eradicator Exp $
IUSE=""
@@ -33,14 +33,17 @@ src_unpack() {
cd ${S}
convert_to_m ${S}/Makefile
+
+ sed -i -e 's/^IPTABLES_VERSION/#IPTABLES_VERSION/' ${S}/Makefile
}
src_compile() {
- emake CFLAGS="${CFLAGS}" libipt_ipp2p.so || die "Failed to build iptables module"
+ local IPTABLES_VERSION="$(${ROOT}/sbin/iptables --version | cut -f2 -dv)"
+ emake CFLAGS="${CFLAGS}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" libipt_ipp2p.so || die "Failed to build iptables module"
- xarch="${ARCH}"
+ local xarch="${ARCH}"
unset ARCH
- emake KERNEL_SRC="${KV_DIR}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="$(${ROOT}/sbin/iptables --version | cut -f2 -dv)" IPTABLES_BIN="${ROOT}/sbin/iptables" || die "Failed to build kernel modle."
+ emake KERNEL_SRC="${KV_DIR}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" || die "Failed to build kernel modle."
ARCH="${xarch}"
}
diff --git a/net-firewall/ipp2p/ipp2p-0.8.0_rc3.ebuild b/net-firewall/ipp2p/ipp2p-0.8.0_rc3.ebuild
index 264166ef1b98..51374c015027 100644
--- a/net-firewall/ipp2p/ipp2p-0.8.0_rc3.ebuild
+++ b/net-firewall/ipp2p/ipp2p-0.8.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.8.0_rc3.ebuild,v 1.1 2005/08/06 03:17:54 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.8.0_rc3.ebuild,v 1.2 2005/08/07 17:32:34 eradicator Exp $
IUSE=""
@@ -33,14 +33,17 @@ src_unpack() {
cd ${S}
convert_to_m ${S}/Makefile
+
+ sed -i -e 's/^IPTABLES_VERSION/#IPTABLES_VERSION/' ${S}/Makefile
}
src_compile() {
- emake CFLAGS="${CFLAGS}" libipt_ipp2p.so || die "Failed to build iptables module"
+ local IPTABLES_VERSION="$(${ROOT}/sbin/iptables --version | cut -f2 -dv)"
+ emake CFLAGS="${CFLAGS}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" libipt_ipp2p.so || die "Failed to build iptables module"
- xarch="${ARCH}"
+ local xarch="${ARCH}"
unset ARCH
- emake KERNEL_SRC="${KV_DIR}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="$(${ROOT}/sbin/iptables --version | cut -f2 -dv)" IPTABLES_BIN="${ROOT}/sbin/iptables" || die "Failed to build kernel modle."
+ emake KERNEL_SRC="${KV_DIR}" IPTABLES_SRC="${ROOT}/usr" IPTABLES_VERSION="${IPTABLES_VERSION}" || die "Failed to build kernel modle."
ARCH="${xarch}"
}