summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-03-24 08:12:32 +0000
committerPeter Volkov <pva@gentoo.org>2009-03-24 08:12:32 +0000
commitf3d4a8727d699a71b5dec57a73b806d2e50437ea (patch)
treec77f25ebc98a44d1df9e60bc2293dc16f2c4c03c /net-firewall/iptables
parent2.2_rc27 bump. This includes the same fixes as 2.1.6.10. There are also (diff)
downloadgentoo-2-f3d4a8727d699a71b5dec57a73b806d2e50437ea.tar.gz
gentoo-2-f3d4a8727d699a71b5dec57a73b806d2e50437ea.tar.bz2
gentoo-2-f3d4a8727d699a71b5dec57a73b806d2e50437ea.zip
Version bump.
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog8
-rw-r--r--net-firewall/iptables/files/iptables-1.4.3-as-needed.patch38
-rw-r--r--net-firewall/iptables/iptables-1.4.3.ebuild97
3 files changed, 142 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 3162f04a5731..45d7f6656617 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.193 2009/02/16 16:57:34 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.194 2009/03/24 08:12:31 pva Exp $
+
+*iptables-1.4.3 (24 Mar 2009)
+
+ 24 Mar 2009; Peter Volkov <pva@gentoo.org>
+ +files/iptables-1.4.3-as-needed.patch, +iptables-1.4.3.ebuild:
+ Version bump.
16 Feb 2009; Brent Baude <ranger@gentoo.org> iptables-1.4.2-r2.ebuild:
stable ppc64, bug 255786
diff --git a/net-firewall/iptables/files/iptables-1.4.3-as-needed.patch b/net-firewall/iptables/files/iptables-1.4.3-as-needed.patch
new file mode 100644
index 000000000000..e44d6577038a
--- /dev/null
+++ b/net-firewall/iptables/files/iptables-1.4.3-as-needed.patch
@@ -0,0 +1,38 @@
+=== modified file 'Makefile.in'
+--- Makefile.in 2009-03-23 20:36:12 +0000
++++ Makefile.in 2009-03-23 20:38:14 +0000
+@@ -354,7 +354,7 @@
+ # iptables, dynamic
+ iptables_SOURCES = iptables-standalone.c iptables.c
+ iptables_LDFLAGS = -rdynamic
+-iptables_LDADD = -lm libiptc/libiptc.la extensions/libext4.a libxtables.la
++iptables_LDADD = libiptc/libiptc.la extensions/libext4.a libxtables.la -lm
+ iptables_xml_LDADD = libxtables.la
+ iptables_multi_SOURCES = iptables-multi.c iptables-save.c \
+ iptables-restore.c iptables-xml.c \
+@@ -373,13 +373,13 @@
+ # iptables-multi, semi-static
+ iptables_static_SOURCES = ${iptables_multi_SOURCES} xtables.c
+ iptables_static_CFLAGS = ${iptables_multi_CFLAGS} -DNO_SHARED_LIBS=1
+-iptables_static_LDADD = -lm libiptc/libiptc.la extensions/libext4.a
++iptables_static_LDADD = libiptc/libiptc.la extensions/libext4.a -lm
+ iptables_xml_SOURCES = iptables-xml.c
+
+ # ip6tables, dynamic
+ ip6tables_SOURCES = ip6tables-standalone.c ip6tables.c
+ ip6tables_LDFLAGS = -rdynamic
+-ip6tables_LDADD = -lm libiptc/libiptc.la extensions/libext6.a libxtables.la
++ip6tables_LDADD = libiptc/libiptc.la extensions/libext6.a libxtables.la -lm
+ ip6tables_multi_SOURCES = ip6tables-multi.c ip6tables-save.c \
+ ip6tables-restore.c ip6tables-standalone.c \
+ ip6tables.c
+@@ -397,7 +397,7 @@
+ # iptables-multi, semi-static
+ ip6tables_static_SOURCES = ${ip6tables_multi_SOURCES} xtables.c
+ ip6tables_static_CFLAGS = ${ip6tables_multi_CFLAGS} -DNO_SHARED_LIBS=1
+-ip6tables_static_LDADD = -lm libiptc/libiptc.la extensions/libext6.a
++ip6tables_static_LDADD = libiptc/libiptc.la extensions/libext6.a -lm
+ man_MANS = iptables.8 iptables-restore.8 iptables-save.8 \
+ iptables-xml.8 ip6tables.8 ip6tables-restore.8 \
+ ip6tables-save.8
+
diff --git a/net-firewall/iptables/iptables-1.4.3.ebuild b/net-firewall/iptables/iptables-1.4.3.ebuild
new file mode 100644
index 000000000000..10dc2ea3422f
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.3.ebuild,v 1.1 2009/03/24 08:12:31 pva Exp $
+
+inherit eutils toolchain-funcs linux-info
+
+L7_PV=2.21
+L7_P=netfilter-layer7-v${L7_PV}
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2
+ l7filter? ( mirror://sourceforge/l7-filter/${L7_P}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="l7filter"
+
+DEPEND="virtual/os-headers"
+RDEPEND=""
+
+pkg_setup() {
+ if use l7filter ; then
+ ewarn "WARNING: 3rd party extensions has been enabled."
+ ewarn "This means that iptables will use your currently installed"
+ ewarn "kernel in ${KERNEL_DIR} as headers for iptables."
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 20 ; then
+ eerror "Currently there is no l7-filter patch available for iptables-1.4.x"
+ eerror "and kernel version before 2.6.20."
+ eerror "If you need to compile iptables 1.4.x against Linux 2.6.19.x"
+ eerror "or earlier, with l7-filter patch, please, report upstream."
+ die "No patch available."
+ fi
+
+ [[ ! -f ${KERNEL_DIR}/include/linux/netfilter/xt_layer7.h ]] && \
+ die "For layer 7 support emerge net-misc/l7-filter-${L7_PV} before this."
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use l7filter && unpack ${L7_P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.4.2-no-ldconfig.patch
+ epatch "${FILESDIR}"/${PN}-1.4.2-hashlimit.patch #254496
+ sed -e 's:\<\(LOAD_MUST_SUCCEED\)\>:XTF_\1:' -i xtables.c
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+
+ local check base=${PORTAGE_CONFIGROOT}/etc/portage/patches
+ for check in {${CATEGORY}/${PF},${CATEGORY}/${P},${CATEGORY}/${PN}}; do
+ EPATCH_SOURCE=${base}/${CTARGET}/${check}
+ [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${CHOST}/${check}
+ [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${check}
+ if [[ -d ${EPATCH_SOURCE} ]] ; then
+ EPATCH_SUFFIX="patch"
+ EPATCH_FORCE="yes" \
+ EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
+ epatch
+ break
+ fi
+ done
+
+ if use l7filter ; then
+ cp "${WORKDIR}/${L7_P}/iptables-1.4.1.1-for-kernel-2.6.20forward"/* extensions \
+ || die "Failed to copy l7filter sources"
+ fi
+}
+
+src_compile() {
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_with l7filter kernel ${KERNEL_DIR})
+ emake V=1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ insinto /usr/include
+ doins include/iptables.h include/ip6tables.h || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+}