summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2013-06-02 10:45:09 +0000
committerConstanze Hausner <constanze@gentoo.org>2013-06-02 10:45:09 +0000
commiteb681589fbf84132c1a31461238d1afac509fae2 (patch)
tree3e5c3884c23d597c6404cd88ff43f8595f25780b /net-firewall/shorewall-core
parentNew dep to django-tastypie, ebuild written by me (diff)
downloadgentoo-2-eb681589fbf84132c1a31461238d1afac509fae2.tar.gz
gentoo-2-eb681589fbf84132c1a31461238d1afac509fae2.tar.bz2
gentoo-2-eb681589fbf84132c1a31461238d1afac509fae2.zip
Cleanup; Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key BB80F419010E3EC3)
Diffstat (limited to 'net-firewall/shorewall-core')
-rw-r--r--net-firewall/shorewall-core/ChangeLog8
-rw-r--r--net-firewall/shorewall-core/files/shorewallrc21
-rw-r--r--net-firewall/shorewall-core/shorewall-core-4.5.17.ebuild41
3 files changed, 48 insertions, 22 deletions
diff --git a/net-firewall/shorewall-core/ChangeLog b/net-firewall/shorewall-core/ChangeLog
index 41efcb0b7ce5..568180d9bbc0 100644
--- a/net-firewall/shorewall-core/ChangeLog
+++ b/net-firewall/shorewall-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.25 2013/05/29 15:24:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.26 2013/06/02 10:45:09 constanze Exp $
+
+*shorewall-core-4.5.17 (02 Jun 2013)
+
+ 02 Jun 2013; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-core-4.5.17.ebuild, -files/shorewallrc:
+ Cleanup; Version bump
29 May 2013; Jeroen Roovers <jer@gentoo.org> shorewall-core-4.5.15.ebuild:
Stable for HPPA (bug #470544).
diff --git a/net-firewall/shorewall-core/files/shorewallrc b/net-firewall/shorewall-core/files/shorewallrc
deleted file mode 100644
index 4f13769114a4..000000000000
--- a/net-firewall/shorewall-core/files/shorewallrc
+++ /dev/null
@@ -1,21 +0,0 @@
-#
-# Gentoo Shorewall 4.5 rc file
-#
-HOST=linux #Generic Linux
-BUILD= #Default is to detect the build system
-PREFIX=/usr #Top-level directory for shared files, libraries, etc.
-SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
-LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
-PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
-CONFDIR=/etc #Directory where subsystem configurations are installed
-SBINDIR=/sbin #Directory where system administration programs are installed
-MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
-INITDIR=etc/init.d #Directory where SysV init scripts are installed.
-INITFILE=$PRODUCT #Name of the product's installed SysV init script
-INITSOURCE=init.sh #Name of the distributed file to be installed as the SysV init script
-ANNOTATED= #If non-zero, annotated configuration files are installed
-SYSTEMD= #Directory where .service files are installed (systems running systemd only)
-SYSCONFFILE= #Name of the distributed file to be installed in $SYSCONFDIR
-SYSCONFDIR= #Directory where SysV init parameter files are installed
-SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
-VARDIR=/var/lib #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall-core/shorewall-core-4.5.17.ebuild b/net-firewall/shorewall-core/shorewall-core-4.5.17.ebuild
new file mode 100644
index 000000000000..d0c18081db18
--- /dev/null
+++ b/net-firewall/shorewall-core/shorewall-core-4.5.17.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/shorewall-core-4.5.17.ebuild,v 1.1 2013/06/02 10:45:09 constanze Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="shorewall-${MY_PV_BASE}"
+
+DESCRIPTION="Core libraries of shorewall / shorewall(6)-lite"
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ !<net-firewall/shorewall-4.5.0.1
+ selinux? ( sec-policy/selinux-shorewall )"
+RDEPEND="${DEPEND}"
+
+DOCS=( changelog.txt releasenotes.txt )
+
+src_configure() {
+ :;
+}
+
+src_install() {
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc_new || die "install.sh failed"
+ default
+}