summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-09-13 06:35:49 +0000
committerPeter Volkov <pva@gentoo.org>2011-09-13 06:35:49 +0000
commit6228bee1065a3681b07252f396fc1b874c1e5ab6 (patch)
treeb6af974dcb6a7b4d8ef9d725e7c38ebe309db27c /net-firewall/ufw
parentVersion bump. (diff)
downloadgentoo-2-6228bee1065a3681b07252f396fc1b874c1e5ab6.tar.gz
gentoo-2-6228bee1065a3681b07252f396fc1b874c1e5ab6.tar.bz2
gentoo-2-6228bee1065a3681b07252f396fc1b874c1e5ab6.zip
Update to bash-completion-r1 eclass, thank Sławomir Nizio for this job.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/ufw')
-rw-r--r--net-firewall/ufw/ChangeLog6
-rw-r--r--net-firewall/ufw/ufw-0.30.1-r2.ebuild8
-rw-r--r--net-firewall/ufw/ufw-0.30.1-r3.ebuild8
3 files changed, 11 insertions, 11 deletions
diff --git a/net-firewall/ufw/ChangeLog b/net-firewall/ufw/ChangeLog
index 68bb93381ea3..a472dccd9265 100644
--- a/net-firewall/ufw/ChangeLog
+++ b/net-firewall/ufw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/ufw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ChangeLog,v 1.3 2011/09/03 12:17:52 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ChangeLog,v 1.4 2011/09/13 06:35:49 pva Exp $
+
+ 13 Sep 2011; Peter Volkov <pva@gentoo.org> ufw-0.30.1-r2.ebuild,
+ ufw-0.30.1-r3.ebuild:
+ Update to bash-completion-r1 eclass, thank Sławomir Nizio for this job.
*ufw-0.30.1-r3 (03 Sep 2011)
diff --git a/net-firewall/ufw/ufw-0.30.1-r2.ebuild b/net-firewall/ufw/ufw-0.30.1-r2.ebuild
index 8167341af708..64b37228008a 100644
--- a/net-firewall/ufw/ufw-0.30.1-r2.ebuild
+++ b/net-firewall/ufw/ufw-0.30.1-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.30.1-r2.ebuild,v 1.2 2011/07/28 07:22:42 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.30.1-r2.ebuild,v 1.3 2011/09/13 06:35:49 pva Exp $
EAPI=3
PYTHON_DEPEND="2:2.5"
-inherit versionator bash-completion eutils linux-info distutils
+inherit versionator bash-completion-r1 eutils linux-info distutils
MY_PV_12=$(get_version_component_range 1-2)
DESCRIPTION="A program used to manage a netfilter firewall"
@@ -60,7 +60,7 @@ src_install() {
doins examples/* || die "inserting example files failed"
fi
distutils_src_install
- dobashcompletion shell-completion/bash
+ newbashcomp shell-completion/bash ${PN} || die "newbashcomp failed"
}
pkg_postinst() {
@@ -75,6 +75,4 @@ pkg_postinst() {
elog "Remember to enable ufw add it to your boot sequence:"
elog "-- # ufw enable"
elog "-- # rc-update add ufw boot"
- echo
- bash-completion_pkg_postinst
}
diff --git a/net-firewall/ufw/ufw-0.30.1-r3.ebuild b/net-firewall/ufw/ufw-0.30.1-r3.ebuild
index 3c8607fe2a6d..d05d12ece1e6 100644
--- a/net-firewall/ufw/ufw-0.30.1-r3.ebuild
+++ b/net-firewall/ufw/ufw-0.30.1-r3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.30.1-r3.ebuild,v 1.1 2011/09/03 12:17:52 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.30.1-r3.ebuild,v 1.2 2011/09/13 06:35:49 pva Exp $
EAPI=3
PYTHON_DEPEND="2:2.5"
-inherit versionator bash-completion eutils linux-info distutils
+inherit versionator bash-completion-r1 eutils linux-info distutils
MY_PV_12=$(get_version_component_range 1-2)
DESCRIPTION="A program used to manage a netfilter firewall"
@@ -68,7 +68,7 @@ src_install() {
doins examples/* || die "inserting example files failed"
fi
distutils_src_install
- dobashcompletion shell-completion/bash
+ newbashcomp shell-completion/bash ${PN} || die "newbashcomp failed"
}
pkg_postinst() {
@@ -84,8 +84,6 @@ pkg_postinst() {
elog "-- # ufw enable"
elog "-- # rc-update add ufw boot"
echo
- bash-completion_pkg_postinst
- echo
elog "If you want to keep ufw logs in a separate file, take a look at"
elog "/usr/share/doc/${PF}/logging."
}