summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-08-11 07:58:32 +0000
committerPeter Volkov <pva@gentoo.org>2010-08-11 07:58:32 +0000
commit54fb6ce00c00cab12e15fda4a833369401da2241 (patch)
tree321c8e9879a350a530c60e173109fba3148ce0fe /net-firewall
parentCleanup (diff)
downloadgentoo-2-54fb6ce00c00cab12e15fda4a833369401da2241.tar.gz
gentoo-2-54fb6ce00c00cab12e15fda4a833369401da2241.tar.bz2
gentoo-2-54fb6ce00c00cab12e15fda4a833369401da2241.zip
Instal libraries into /lib since binaries are in /sbin, bug #332175, thank Eray Aslan for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog8
-rw-r--r--net-firewall/iptables/iptables-1.4.9.1-r1.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 14391f71d21a..ef21b19ad255 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.220 2010/08/09 08:01:56 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.221 2010/08/11 07:58:32 pva Exp $
+
+*iptables-1.4.9.1-r1 (11 Aug 2010)
+
+ 11 Aug 2010; Peter Volkov <pva@gentoo.org> +iptables-1.4.9.1-r1.ebuild:
+ Instal libraries into /lib since binaries are in /sbin, bug #332175, thank
+ Eray Aslan for report.
*iptables-1.4.9.1 (09 Aug 2010)
diff --git a/net-firewall/iptables/iptables-1.4.9.1-r1.ebuild b/net-firewall/iptables/iptables-1.4.9.1-r1.ebuild
new file mode 100644
index 000000000000..1a17beb1974c
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.9.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.9.1-r1.ebuild,v 1.1 2010/08/11 07:58:32 pva Exp $
+
+EAPI="2"
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/os-headers"
+RDEPEND=""
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sbindir=/sbin \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake V=1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dosbin iptables-apply || die
+ doman iptables-apply.8 || die
+ dodoc INCOMPATIBILITIES iptables.xslt || die
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ fi
+
+ # Remove .la from /lib, keep static archives in /usr/lib
+ find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+ dodir /usr/$(get_libdir)/
+ mv "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/ || die "failed to mv static libs"
+ gen_usr_ldscript libip4tc.so libip6tc.so libipq.so libiptc.so libxtables.so
+}