summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-11-14 09:01:20 +0000
committerPeter Volkov <pva@gentoo.org>2009-11-14 09:01:20 +0000
commita13dc97d5fed20be2c078dcd5e608f043a3c8595 (patch)
tree26146a4956f0ca8334291ead25dc3666c1e1b8c6 /net-firewall
parentAdd alternatives support for >=dev-lang/perl-5.8.8-r8 (diff)
downloadgentoo-2-a13dc97d5fed20be2c078dcd5e608f043a3c8595.tar.gz
gentoo-2-a13dc97d5fed20be2c078dcd5e608f043a3c8595.tar.bz2
gentoo-2-a13dc97d5fed20be2c078dcd5e608f043a3c8595.zip
Do not build modules in case kernel is patched and modules are built in, bug #274577 thank Brendan Pike report.
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipset/ChangeLog6
-rw-r--r--net-firewall/ipset/ipset-4.1.ebuild20
2 files changed, 16 insertions, 10 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index 766a31555242..ca392d426146 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.31 2009/11/14 08:20:30 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.32 2009/11/14 09:01:20 pva Exp $
+
+ 14 Nov 2009; Peter Volkov <pva@gentoo.org> ipset-4.1.ebuild:
+ Do not build modules in case kernel is patched and modules are built in,
+ bug #274577 thank Brendan Pike report.
*ipset-4.1 (14 Nov 2009)
diff --git a/net-firewall/ipset/ipset-4.1.ebuild b/net-firewall/ipset/ipset-4.1.ebuild
index d2083e6ee172..3070633e292f 100644
--- a/net-firewall/ipset/ipset-4.1.ebuild
+++ b/net-firewall/ipset/ipset-4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-4.1.ebuild,v 1.1 2009/11/14 08:20:30 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-4.1.ebuild,v 1.2 2009/11/14 09:01:20 pva Exp $
EAPI="2"
@@ -38,16 +38,18 @@ pkg_setup() {
get_version
modules=0
- msg=''
if linux_chkconfig_builtin "MODULES" ; then
- modules=1
- msg="Modular kernel detected, will build kernel modules"
+ if linux_chkconfig_builtin "IP_NF_SET"; then #274577
+ einfo "Modular kernel detected but IP_NF_SET=y, will not build kernel modules"
+ else
+ modules=1
+ einfo "Modular kernel detected, will build kernel modules"
+ fi
else
- msg="Nonmodular kernel detected, will not build kernel modules"
+ einfo "Nonmodular kernel detected, will not build kernel modules"
fi
- einfo "${msg}"
- [[ $modules -eq 1 ]] && \
+ [[ ${modules} -eq 1 ]] && \
linux-mod_pkg_setup
myconf="${myconf} PREFIX="
myconf="${myconf} LIBDIR=/$(get_libdir)"
@@ -72,7 +74,7 @@ src_compile() {
einfo "Building userspace"
emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} binaries || die "failed to build"
- if [[ $modules -eq 1 ]]; then
+ if [[ ${modules} -eq 1 ]]; then
einfo "Building kernel modules"
cd "${S}/kernel"
export KERNELDIR="${KERNEL_DIR}"
@@ -84,7 +86,7 @@ src_install() {
einfo "Installing userspace"
emake DESTDIR="${D}" ${myconf} binaries_install || die "failed to package"
- if [[ $modules -eq 1 ]]; then
+ if [[ ${modules} -eq 1 ]]; then
einfo "Installing kernel modules"
cd "${S}/kernel"
export KERNELDIR="${KERNEL_DIR}"