summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-06-12 13:59:29 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-06-12 13:59:29 +0000
commitb299f9d75d2e9d2d2c4b133f2b799e665aac9f23 (patch)
treeef2dc635a28012019090732177ef68e29f2ebcf2 /net-firewall
parentCleanup old. (diff)
downloadgentoo-2-b299f9d75d2e9d2d2c4b133f2b799e665aac9f23.tar.gz
gentoo-2-b299f9d75d2e9d2d2c4b133f2b799e665aac9f23.tar.bz2
gentoo-2-b299f9d75d2e9d2d2c4b133f2b799e665aac9f23.zip
Version bump to 4.5.21.10; fixes bug #509258 and bug #509258, proxied commit for Thomas D. (whissi).
(Portage version: 2.2.10_p125/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-core/ChangeLog9
-rw-r--r--net-firewall/shorewall-core/files/4.5.21.10/shorewallrc23
-rw-r--r--net-firewall/shorewall-core/shorewall-core-4.5.21.10.ebuild74
3 files changed, 105 insertions, 1 deletions
diff --git a/net-firewall/shorewall-core/ChangeLog b/net-firewall/shorewall-core/ChangeLog
index 4ca9d866ecfe..f0217ec5b980 100644
--- a/net-firewall/shorewall-core/ChangeLog
+++ b/net-firewall/shorewall-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/shorewall-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.56 2014/06/04 00:44:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/ChangeLog,v 1.57 2014/06/12 13:59:29 tomwij Exp $
+
+*shorewall-core-4.5.21.10 (12 Jun 2014)
+
+ 12 Jun 2014; Tom Wijsman <TomWij@gentoo.org> +files/4.5.21.10/shorewallrc,
+ +shorewall-core-4.5.21.10.ebuild:
+ Version bump to 4.5.21.10; fixes bug #509258 and bug #509258, proxied commit
+ for Thomas D. (whissi).
04 Jun 2014; Jeroen Roovers <jer@gentoo.org> shorewall-core-4.5.21.9.ebuild:
Stable for HPPA (bug #511620).
diff --git a/net-firewall/shorewall-core/files/4.5.21.10/shorewallrc b/net-firewall/shorewall-core/files/4.5.21.10/shorewallrc
new file mode 100644
index 000000000000..46f5eb9a3603
--- /dev/null
+++ b/net-firewall/shorewall-core/files/4.5.21.10/shorewallrc
@@ -0,0 +1,23 @@
+#
+# Gentoo Shorewall 4.5 rc file
+#
+BUILD= #Default is to detect the build system
+HOST=gentoo #Gentoo GNU Linux
+PREFIX=@GENTOO_PORTAGE_EPREFIX@/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=@GENTOO_PORTAGE_EPREFIX@/etc #Directory where subsystem configurations are installed
+SBINDIR=@GENTOO_PORTAGE_EPREFIX@/sbin #Directory where system administration programs are installed
+MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
+INITDIR=${CONFDIR}/init.d #Directory where SysV init scripts are installed.
+INITFILE=${PRODUCT} #Name of the product's installed SysV init script
+INITSOURCE=init.gentoo.sh #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD=@GENTOO_PORTAGE_EPREFIX@/usr/lib/systemd/system #Directory where .service files are installed (systems running systemd only)
+SERVICEFILE=gentoo.service #Name of the distributed file to be installed as systemd service file
+SYSCONFFILE=default.gentoo #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR=${CONFDIR}/conf.d #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARLIB=@GENTOO_PORTAGE_EPREFIX@/var/lib #Directory where product variable data is stored.
+VARDIR=${VARLIB}/${PRODUCT} #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall-core/shorewall-core-4.5.21.10.ebuild b/net-firewall/shorewall-core/shorewall-core-4.5.21.10.ebuild
new file mode 100644
index 000000000000..8093a85d3de2
--- /dev/null
+++ b/net-firewall/shorewall-core/shorewall-core-4.5.21.10.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-core/shorewall-core-4.5.21.10.ebuild,v 1.1 2014/06/12 13:59:29 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils prefix versionator
+
+MY_URL_PREFIX=
+case ${P} in
+ *_beta* | \
+ *_rc*)
+ MY_URL_PREFIX='development/'
+ ;;
+esac
+
+MY_PV=${PV/_rc/-RC}
+MY_PV=${MY_PV/_beta/-Beta}
+MY_P=${PN}-${MY_PV}
+
+MY_MAJOR_RELEASE_NUMBER=$(get_version_component_range 1-2)
+MY_MAJORMINOR_RELEASE_NUMBER=$(get_version_component_range 1-3)
+
+DESCRIPTION="Core libraries of shorewall / shorewall(6)-lite"
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_URL_PREFIX}${MY_MAJOR_RELEASE_NUMBER}/shorewall-${MY_MAJORMINOR_RELEASE_NUMBER}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="
+ >=dev-lang/perl-5.10
+ virtual/perl-Digest-SHA
+ !<net-firewall/shorewall-4.5.0.1
+ selinux? ( >=sec-policy/selinux-shorewall-2.20130424-r2 )
+"
+RDEPEND="
+ ${DEPEND}
+ >=net-firewall/iptables-1.4.20
+ >=sys-apps/iproute2-3.8.0[-minimal]
+ >=sys-devel/bc-1.06.95
+ >=sys-apps/coreutils-8.20
+"
+
+DOCS=( changelog.txt releasenotes.txt )
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ cp "${FILESDIR}"/${PVR}/shorewallrc "${S}"/shorewallrc.gentoo || die "Copying shorewallrc failed"
+ eprefixify "${S}"/shorewallrc.gentoo
+
+ epatch_user
+}
+
+src_configure() {
+ :;
+}
+
+src_install() {
+ DESTDIR="${D}" ./install.sh shorewallrc.gentoo || die "install.sh failed"
+ default
+}
+
+pkg_postinst() {
+ if ! has_version sys-apps/net-tools; then
+ elog "It is recommended to install sys-apps/net-tools which will provide the"
+ elog "the 'arp' utility which will give you a better 'shorewall-lite dump' output:"
+ elog ""
+ elog " # emerge sys-apps/net-tools"
+ fi
+}