summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-17 23:32:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-17 23:32:50 +0000
commite0de1cda330200085fd53ed6c9b64c449cc76f69 (patch)
treef6e8cfb20f7b2c2f681fc8d1e12bc02736392ba5 /net-firewall
parentAdd metadata.xml, bump to version 8.12.10 and mark stable. (diff)
downloadgentoo-2-e0de1cda330200085fd53ed6c9b64c449cc76f69.tar.gz
gentoo-2-e0de1cda330200085fd53ed6c9b64c449cc76f69.tar.bz2
gentoo-2-e0de1cda330200085fd53ed6c9b64c449cc76f69.zip
port scan and attack detection daemon
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/psad/ChangeLog11
-rw-r--r--net-firewall/psad/Manifest3
-rw-r--r--net-firewall/psad/metadata.xml10
-rw-r--r--net-firewall/psad/psad-1.2.1.ebuild94
4 files changed, 118 insertions, 0 deletions
diff --git a/net-firewall/psad/ChangeLog b/net-firewall/psad/ChangeLog
new file mode 100644
index 000000000000..26e7cc1dc70d
--- /dev/null
+++ b/net-firewall/psad/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-firewall/psad
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/ChangeLog,v 1.1 2003/09/17 23:32:46 seemant Exp $
+
+*psad-1.2.1 (17 Sep 2003)
+
+ 17 Sep 2003; Seemant Kulleen <seemant@gentoo.org> psad-1.2.1.ebuild:
+ Port Scanning Attack Detection daemon. This is a dependency of Bastille, and
+ probably can be used standalone as well. Much thanks to Battoussai (Bryan
+ Stine <admin@kentonet.net>) for this.
+
diff --git a/net-firewall/psad/Manifest b/net-firewall/psad/Manifest
new file mode 100644
index 000000000000..2c727862b6c5
--- /dev/null
+++ b/net-firewall/psad/Manifest
@@ -0,0 +1,3 @@
+MD5 2856a24c42cbcc36c566f33176ff1e0d psad-1.2.1.ebuild 2181
+MD5 f2b3c9d267411358904b006c5c78e859 ChangeLog 511
+MD5 624441f5e21afa19251eedc583e0c4e7 metadata.xml 433
diff --git a/net-firewall/psad/metadata.xml b/net-firewall/psad/metadata.xml
new file mode 100644
index 000000000000..cefbc16f77a9
--- /dev/null
+++ b/net-firewall/psad/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>hardened</herd>
+ <maintainer>
+ <email>hardened@gentoo.org</email>
+ <description>Bastille Currently Has No Primary Gentoo Maintainer</description>
+ </maintainer>
+ <longdescription>The Bastille Hardening System attempts to "harden" or "tighten" Unix operating systems.</longdescription>
+</pkgmetadata>
diff --git a/net-firewall/psad/psad-1.2.1.ebuild b/net-firewall/psad/psad-1.2.1.ebuild
new file mode 100644
index 000000000000..cfd94538fe2a
--- /dev/null
+++ b/net-firewall/psad/psad-1.2.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.2.1.ebuild,v 1.1 2003/09/17 23:32:46 seemant Exp $
+
+inherit eutils
+inherit perl-module
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Port Scannning Attack Detection daemon"
+SRC_URI="http://www.cipherdyne.org/psad/download/psad-1.2.1.tar.gz"
+HOMEPAGE="http://www.cipherdyne.org/psad"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc ~hppa ~mips ~arm"
+
+DEPEND="${DEPEND}
+ dev-lang/perl"
+
+RDEPEND="virtual/logger
+ dev-perl/Unix-Syslog
+ dev-perl/Date-Calc
+ net-mail/mailx
+ net-firewall/iptables"
+
+src_compile() {
+ cd ${S}/Psad
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/Net-IPv4Addr
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/IPTables/Parse
+ SRC_PREP="no" perl-module_src_compile
+ emake test
+
+ cd ${S}/whois
+ emake || die
+
+ cd ${S}
+ # We'll use the C binaries until we see them break
+ emake || die
+}
+
+src_install() {
+ keepdir /var/lib/psad /var/log/psad /var/run/psad /var/lock/subsys/${PN}
+ dodir /etc/psad
+ cd ${S}/Psad
+ perl-module_src_install
+
+ cd ${S}/Net-IPv4Addr
+ perl-module_src_install
+
+ cd ${S}/IPTables/Parse
+ perl-module_src_install
+
+ cd ${S}/whois
+ # Makefile seems borken, do install by hand...
+ insinto /usr
+ newbin whois whois_psad
+ newman whois.1 whois_psad.1
+
+ cd ${S}
+ insinto /usr
+ dosbin diskmond kmsgsd psad psadwatchd
+ dobin pscan
+
+ cd ${S}
+ insinto /etc/psad
+ doins *.conf
+
+ dodoc BENCHMARK CREDITS Change* FW_EXAMPLE_RULES README LICENSE SCAN_LOG
+}
+
+pkg_postinst() {
+ if [ ! -p ${ROOT}/var/lib/psad/psadfifo ]
+ then
+ ebegin "Creating syslog FIFO for PSAD"
+ mknod -m 600 ${ROOT}/var/lib/psad/psadfifo p
+ eend $?
+ fi
+ echo
+ einfo "Several programs in the PSAD package are in the process of being"
+ einfo "converted to compiled C from PERL. If you have any problems,"
+ einfo "please notify the PSAD maintainers. Please do not take PSAD"
+ einfo "issues to the Bastille-Linux team."
+ echo
+ ewarn "Please be sure to edit /etc/psad/psad.conf to reflect your"
+ ewarn "system's configuration or it may not work correctly or start up."
+}