summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-10 22:06:51 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-10 22:06:51 +0000
commit76112ebf54d1051265f3f05da628328289624ba8 (patch)
tree93b992ea14cfb70b46de530d735f648e94e78ee3 /net-fs/am-utils
parentinitial ebuild for am-utils (diff)
downloadgentoo-2-76112ebf54d1051265f3f05da628328289624ba8.tar.gz
gentoo-2-76112ebf54d1051265f3f05da628328289624ba8.tar.bz2
gentoo-2-76112ebf54d1051265f3f05da628328289624ba8.zip
initial ebuild for am-utils
Diffstat (limited to 'net-fs/am-utils')
-rw-r--r--net-fs/am-utils/ChangeLog10
-rw-r--r--net-fs/am-utils/Manifest9
-rw-r--r--net-fs/am-utils/am-utils-6.0.9.ebuild40
-rw-r--r--net-fs/am-utils/files/amd.conf30
-rw-r--r--net-fs/am-utils/files/amd.net4
-rw-r--r--net-fs/am-utils/files/amd.rc21
-rw-r--r--net-fs/am-utils/files/digest-am-utils-6.0.91
7 files changed, 111 insertions, 4 deletions
diff --git a/net-fs/am-utils/ChangeLog b/net-fs/am-utils/ChangeLog
new file mode 100644
index 000000000000..825e7c0099ae
--- /dev/null
+++ b/net-fs/am-utils/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-fs/am-utils
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/ChangeLog,v 1.1 2003/04/10 22:06:42 liquidx Exp $
+
+*am-utils-6.0.9 (10 Apr 2003)
+
+ 10 Apr 2003; Alastair Tse <liquidx@gentoo.org> Manifest,
+ am-utils-6.0.9.ebuild, files/amd.conf, files/amd.net, files/amd.rc:
+ new ebuild. thanks to Miles Egan <miles+gentoo@caddr.com>. #17773
+
diff --git a/net-fs/am-utils/Manifest b/net-fs/am-utils/Manifest
index 8b0e96424c2f..62ae61269704 100644
--- a/net-fs/am-utils/Manifest
+++ b/net-fs/am-utils/Manifest
@@ -1,5 +1,6 @@
-MD5 041da59af4769fe8268594c278d902e0 am-utils-6.0.9.ebuild 823
-MD5 b1b2ce0f9c933214685edae69899ee5b files/amd.rc 558
-MD5 63f9d2152f8f2ed9fd2388e5f2006e61 files/amd.net 112
-MD5 0a035e52aafb8f56894a03429aab1312 files/amd.conf 721
+MD5 70a842b859c8e09753cc1266cc8324b8 am-utils-6.0.9.ebuild 948
+MD5 bbf6273f1c8447981e5ad0663daf0265 ChangeLog 442
+MD5 a1fdc04f98d4c0a4970581af4144926f files/amd.rc 552
+MD5 f08163d2626b71a6c983fc1d0b9383ab files/amd.net 160
+MD5 04ee491d48ffa52a449c447af3c8fbce files/amd.conf 770
MD5 74f5c331bf7692293e5eb8b1d69310de files/digest-am-utils-6.0.9 67
diff --git a/net-fs/am-utils/am-utils-6.0.9.ebuild b/net-fs/am-utils/am-utils-6.0.9.ebuild
new file mode 100644
index 000000000000..8dcb19d51e44
--- /dev/null
+++ b/net-fs/am-utils/am-utils-6.0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9.ebuild,v 1.1 2003/04/10 22:06:42 liquidx Exp $
+
+IUSE="ldap"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="amd automounter and utilities"
+HOMEPAGE="http://www.am-utils.org"
+SRC_URI="ftp://ftp.am-utils.org/pub/am-utils/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ldap? ( >=net-nds/openldap-1.2 )"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+src_compile() {
+ local myconf
+
+ use ldap \
+ && myconf="${myconf} --without-ldap" \
+ || myconf="${myconf} --with-ldap"
+
+ myconf="${myconf} --sysconfdir=/etc/amd"
+
+ cd ${S}
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ cp ${FILESDIR}/amd.conf ${D}/etc/amd
+ cp ${FILESDIR}/amd.net ${D}/etc/amd
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/amd.rc amd
+}
diff --git a/net-fs/am-utils/files/amd.conf b/net-fs/am-utils/files/amd.conf
new file mode 100644
index 000000000000..85dfd15bcbb7
--- /dev/null
+++ b/net-fs/am-utils/files/amd.conf
@@ -0,0 +1,30 @@
+#
+# amd default config file
+#
+# check amd.conf(5) man page for details about options in this file
+#
+# $Id: amd.conf,v 1.1 2003/04/10 22:06:42 liquidx Exp $
+
+# GLOBAL OPTIONS SECTION
+[ global ]
+normalize_hostnames = no
+print_pid = yes
+pid_file = /var/run/amd.pid
+restart_mounts = yes
+auto_dir = /.automount
+log_file = syslog
+log_options = all
+plock = no
+selectors_on_default = yes
+print_version = no
+map_type = file
+search_path = /etc/amd
+browsable_dirs = no
+show_statfs_entries = no
+fully_qualified_hosts = no
+cache_duration = 300
+
+# DEFINE AN AMD MOUNT POINT
+[ /net ]
+map_name = amd.net
+map_type = file
diff --git a/net-fs/am-utils/files/amd.net b/net-fs/am-utils/files/amd.net
new file mode 100644
index 000000000000..d8d885f90150
--- /dev/null
+++ b/net-fs/am-utils/files/amd.net
@@ -0,0 +1,4 @@
+# $Id: amd.net,v 1.1 2003/04/10 22:06:42 liquidx Exp $
+
+/defaults fs:=${autodir}/${rhost}/root/${rfs};opts:=nodev
+* rhost:=${key};type:=host;rfs:=/
diff --git a/net-fs/am-utils/files/amd.rc b/net-fs/am-utils/files/amd.rc
new file mode 100644
index 000000000000..3bfc71962e07
--- /dev/null
+++ b/net-fs/am-utils/files/amd.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/files/amd.rc,v 1.1 2003/04/10 22:06:42 liquidx Exp $
+
+depend() {
+ need localmount
+ use ypbind nfs
+}
+
+start() {
+ ebegin "Starting amd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/amd -- -F /etc/amd/amd.conf
+ eend $? "Failed to start amd"
+}
+
+stop() {
+ ebegin "Stopping amd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/amd
+ eend $? "Failed to stop amd"
+}
diff --git a/net-fs/am-utils/files/digest-am-utils-6.0.9 b/net-fs/am-utils/files/digest-am-utils-6.0.9
new file mode 100644
index 000000000000..1c7c1b77e2ce
--- /dev/null
+++ b/net-fs/am-utils/files/digest-am-utils-6.0.9
@@ -0,0 +1 @@
+MD5 1e288b8485c09a126e2bea4029602265 am-utils-6.0.9.tar.gz 1471542