summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-06-02 20:41:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-06-02 20:41:49 +0000
commitfbccd995d5448759fcd1bfaa494ed759142f6f81 (patch)
tree418e4529d1cd9d2fb0352662ed889e3436177e0d /net-fs/autofs/autofs-4.1.3-r7.ebuild
parentFixed parisc asm to build on linux. (diff)
downloadgentoo-2-fbccd995d5448759fcd1bfaa494ed759142f6f81.tar.gz
gentoo-2-fbccd995d5448759fcd1bfaa494ed759142f6f81.tar.bz2
gentoo-2-fbccd995d5448759fcd1bfaa494ed759142f6f81.zip
Bug #135023, fix a parallel make bug.
(Portage version: 2.1_rc3-r3)
Diffstat (limited to 'net-fs/autofs/autofs-4.1.3-r7.ebuild')
-rw-r--r--net-fs/autofs/autofs-4.1.3-r7.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-fs/autofs/autofs-4.1.3-r7.ebuild b/net-fs/autofs/autofs-4.1.3-r7.ebuild
index 78b9f9dce3b2..0737fc39753b 100644
--- a/net-fs/autofs/autofs-4.1.3-r7.ebuild
+++ b/net-fs/autofs/autofs-4.1.3-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-4.1.3-r7.ebuild,v 1.1 2006/05/30 17:12:35 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-4.1.3-r7.ebuild,v 1.2 2006/06/02 20:41:49 robbat2 Exp $
inherit eutils multilib
@@ -36,7 +36,12 @@ src_unpack() {
autoconf || die "Autoconf failed"
cd ${S}/daemon
- sed -i 's/LIBS \= \-ldl/LIBS \= \-ldl \-lnsl \$\{LIBLDAP\}/' Makefile || die "LIBLDAP change failed"
+ sed -i 's/LIBS \= \-ldl/LIBS \= \-ldl \-lnsl \$\{LIBLDAP\}/' Makefile \
+ || die "LIBLDAP change failed"
+
+ cd ${S}/lib
+ sed -i '/^listmount.o:/s,$, mount.h,g' Makefile \
+ || die "Failed to fix dependancies"
}
src_compile() {