summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-09-26 17:32:43 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-09-26 17:32:43 +0000
commit3ae4b63e9de0fc58ea115eb68e1b62bf484c7a34 (patch)
treea78253e7bbe184960e786df4dcd58b10ad630364 /net-fs/cifs-utils
parentMarked ~x86-freebsd (diff)
downloadgentoo-2-3ae4b63e9de0fc58ea115eb68e1b62bf484c7a34.tar.gz
gentoo-2-3ae4b63e9de0fc58ea115eb68e1b62bf484c7a34.tar.bz2
gentoo-2-3ae4b63e9de0fc58ea115eb68e1b62bf484c7a34.zip
Moving to EAPI 4, adding upcall use flag, which enable cifsidmap, forcing user to choice either caps or caps-ng support
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'net-fs/cifs-utils')
-rw-r--r--net-fs/cifs-utils/ChangeLog8
-rw-r--r--net-fs/cifs-utils/cifs-utils-5.1.ebuild77
-rw-r--r--net-fs/cifs-utils/metadata.xml1
3 files changed, 85 insertions, 1 deletions
diff --git a/net-fs/cifs-utils/ChangeLog b/net-fs/cifs-utils/ChangeLog
index 97a1678bb69a..953b2aacca0c 100644
--- a/net-fs/cifs-utils/ChangeLog
+++ b/net-fs/cifs-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/cifs-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.14 2011/08/09 13:42:37 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.15 2011/09/26 17:32:43 vostorga Exp $
+
+*cifs-utils-5.1 (26 Sep 2011)
+
+ 26 Sep 2011; Víctor Ostorga <vostorga@gentoo.org> +cifs-utils-5.1.ebuild:
+ Moving to EAPI 4, adding upcall use flag, which enable cifsidmap, forcing
+ user to choice either caps or caps-ng support
09 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> cifs-utils-5.0.ebuild:
Marked ~ppc64 wrt #358401
diff --git a/net-fs/cifs-utils/cifs-utils-5.1.ebuild b/net-fs/cifs-utils/cifs-utils-5.1.ebuild
new file mode 100644
index 000000000000..cc4283abcb10
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-5.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-5.1.ebuild,v 1.1 2011/09/26 17:32:43 vostorga Exp $
+
+EAPI=4
+
+inherit eutils confutils linux-info
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="http://www.samba.org/linux-cifs/cifs-utils/"
+SRC_URI="ftp://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ads +caps caps-ng creds setuid upcall"
+
+DEPEND="!net-fs/mount-cifs
+ !<net-fs/samba-3.6_rc1
+ ads? ( sys-libs/talloc virtual/krb5 sys-apps/keyutils )
+ caps? ( sys-libs/libcap )
+ caps-ng? ( sys-libs/libcap-ng )
+ creds? ( sys-apps/keyutils )
+ upcall? ( sys-apps/keyutils sys-libs/talloc virtual/krb5 )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="^^ ( caps caps-ng )"
+
+pkg_setup() {
+ confutils_use_conflict caps caps-ng
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable ads cifsupcall) \
+ $(use_with caps libcap) \
+ $(use_with caps-ng libcap-ng) \
+ $(use_enable creds cifscreds) \
+ $(use_enable upcall cifsupcall)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ # Set set-user-ID bit of mount.cifs
+ if use setuid ; then
+ chmod u+s "${D}"/sbin/mount.cifs
+ fi
+ dodoc doc/linux-cifs-client-guide.odt
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ if use setuid ; then
+ ewarn "Setting SETUID bit for mount.cifs."
+ ewarn "However, there may be severe security implications. Also see:"
+ ewarn "http://samba.org/samba/security/CVE-2009-2948.html"
+ fi
+
+ # Inform about upcall usage
+ if use ads ; then
+ ewarn "Using mount.cifs in combination with keyutils"
+ ewarn "in order to mount DFS shares, you need to add"
+ ewarn "the following line to /etc/request-key.conf:"
+ ewarn " create dns_resolver * * /usr/sbin/cifs.upcall %k"
+ ewarn "Otherwise, your DFS shares will not work properly."
+ fi
+}
diff --git a/net-fs/cifs-utils/metadata.xml b/net-fs/cifs-utils/metadata.xml
index f5b753cac313..5b4290260c48 100644
--- a/net-fs/cifs-utils/metadata.xml
+++ b/net-fs/cifs-utils/metadata.xml
@@ -13,5 +13,6 @@
<flag name="caps-ng">libcap-ng support</flag>
<flag name="creds">cifs credentials support</flag>
<flag name="setuid">Seting SETUID bit for mount.cifs</flag>
+ <flag name="upcall">Create cifs.idmap binary; idmap support</flag>
</use>
</pkgmetadata>