summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-12-10 22:07:32 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-12-10 22:07:32 +0000
commit63029566f206e9160956b818811d09261f8b1e94 (patch)
tree6a3b8ce2a2c1f2ae96442bdf3e38e0c88bc05188 /net-fs/curlftpfs
parentDrop KDE SC-4.3.1. (diff)
downloadgentoo-2-63029566f206e9160956b818811d09261f8b1e94.tar.gz
gentoo-2-63029566f206e9160956b818811d09261f8b1e94.tar.bz2
gentoo-2-63029566f206e9160956b818811d09261f8b1e94.zip
fix net write problems on 64bit architectures. Patch found by Semen Maryasin <marsoft AT ya DOT ru> and reported in bug 294960
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-fs/curlftpfs')
-rw-r--r--net-fs/curlftpfs/ChangeLog9
-rw-r--r--net-fs/curlftpfs/curlftpfs-0.9.2-r1.ebuild31
-rw-r--r--net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch11
3 files changed, 50 insertions, 1 deletions
diff --git a/net-fs/curlftpfs/ChangeLog b/net-fs/curlftpfs/ChangeLog
index f5b4660ee69a..be9b6981f4db 100644
--- a/net-fs/curlftpfs/ChangeLog
+++ b/net-fs/curlftpfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/curlftpfs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/curlftpfs/ChangeLog,v 1.15 2009/03/07 09:13:36 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/curlftpfs/ChangeLog,v 1.16 2009/12/10 22:07:32 fauli Exp $
+
+*curlftpfs-0.9.2-r1 (10 Dec 2009)
+
+ 10 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
+ +curlftpfs-0.9.2-r1.ebuild, +files/curlftpfs-0.9.2-64bit_filesize.patch:
+ fix net write problems on 64bit architectures. Patch found by Semen
+ Maryasin <marsoft AT ya DOT ru> and reported in bug 294960
07 Mar 2009; Christian Faulhammer <fauli@gentoo.org>
-curlftpfs-0.9.1.ebuild:
diff --git a/net-fs/curlftpfs/curlftpfs-0.9.2-r1.ebuild b/net-fs/curlftpfs/curlftpfs-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..5fcf4266e787
--- /dev/null
+++ b/net-fs/curlftpfs/curlftpfs-0.9.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/curlftpfs/curlftpfs-0.9.2-r1.ebuild,v 1.1 2009/12/10 22:07:32 fauli Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="File system for accessing ftp hosts based on FUSE"
+HOMEPAGE="http://curlftpfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" # bug 258460
+
+DEPEND=">=net-misc/curl-7.17.0
+ >=sys-fs/fuse-2.2
+ >=dev-libs/glib-2.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-64bit_filesize.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README
+}
diff --git a/net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch b/net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch
new file mode 100644
index 000000000000..38b6f33a2ba5
--- /dev/null
+++ b/net-fs/curlftpfs/files/curlftpfs-0.9.2-64bit_filesize.patch
@@ -0,0 +1,11 @@
+--- ftpfs.c.old 2009-11-28 14:28:05.000000000 +0300
++++ ftpfs.c 2009-11-28 14:28:19.000000000 +0300
+@@ -503,7 +503,7 @@
+
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_URL, fh->full_path);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_UPLOAD, 1);
+- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, -1);
++ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, (curl_off_t)-1);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READFUNCTION, write_data_bg);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READDATA, fh);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_LOW_SPEED_LIMIT, 1);