summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2004-11-23 15:28:22 +0000
committerChristian Andreetta <satya@gentoo.org>2004-11-23 15:28:22 +0000
commit5969334edee5ccd0fb61aaa699cdc75c86d6de98 (patch)
tree63779c0067ba430b1bc7ef56c19349abff638232 /net-fs/samba/samba-3.0.8-r1.ebuild
parentQA: missing "inherit eutils" (Manifest recommit) (diff)
downloadgentoo-2-5969334edee5ccd0fb61aaa699cdc75c86d6de98.tar.gz
gentoo-2-5969334edee5ccd0fb61aaa699cdc75c86d6de98.tar.bz2
gentoo-2-5969334edee5ccd0fb61aaa699cdc75c86d6de98.zip
old private config saved in pkg_setup (no more post_install: bug #72235)
Diffstat (limited to 'net-fs/samba/samba-3.0.8-r1.ebuild')
-rw-r--r--net-fs/samba/samba-3.0.8-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-fs/samba/samba-3.0.8-r1.ebuild b/net-fs/samba/samba-3.0.8-r1.ebuild
index 18b330f5ae16..446b0827280e 100644
--- a/net-fs/samba/samba-3.0.8-r1.ebuild
+++ b/net-fs/samba/samba-3.0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.8-r1.ebuild,v 1.3 2004/11/20 15:11:07 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.8-r1.ebuild,v 1.4 2004/11/23 15:28:22 satya Exp $
inherit eutils flag-o-matic
#---------------------------------------------------------------------------
@@ -57,6 +57,12 @@ pkg_setup() {
ewarn "/etc/samba/private moved to /var/lib/samba/private"
ebeep
epause
+ local PRIVATEDIR=/var/lib/samba/private
+ local PRIVATE_SRC=/etc/samba/private
+ if [[ ! -r ${PRIVATEDIR}/secrets.tdb && -r ${PRIVATE_SRC}/secrets.tdb ]]; then
+ einfo "Copying ${PRIVATE_SRC}/* to ${PRIVATEDIR}/"
+ cp -af ${PRIVATE_SRC}/* ${D}${PRIVATEDIR}/
+ fi
}
#===========================================================================
src_unpack() {