summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-06-09 23:23:45 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-06-09 23:23:45 +0000
commit3e2a13e9c825b06a5819bf89bffe9a6a61b0b2d8 (patch)
tree534dbf345aee56a6ec9b99f89ca0cfd50a11f012 /net-fs/shfs
parentpyparted-1.6.9-r1 can go since python 2.4+ isn't masked any more (diff)
downloadgentoo-2-3e2a13e9c825b06a5819bf89bffe9a6a61b0b2d8.tar.gz
gentoo-2-3e2a13e9c825b06a5819bf89bffe9a6a61b0b2d8.tar.bz2
gentoo-2-3e2a13e9c825b06a5819bf89bffe9a6a61b0b2d8.zip
gcc4 patch
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-fs/shfs')
-rw-r--r--net-fs/shfs/ChangeLog6
-rw-r--r--net-fs/shfs/Manifest1
-rw-r--r--net-fs/shfs/files/0.35/shfs-0.35-gcc4.patch23
3 files changed, 29 insertions, 1 deletions
diff --git a/net-fs/shfs/ChangeLog b/net-fs/shfs/ChangeLog
index 0be0f0513684..616555413c44 100644
--- a/net-fs/shfs/ChangeLog
+++ b/net-fs/shfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/shfs
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.18 2005/04/07 16:05:24 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.19 2005/06/09 23:23:45 halcy0n Exp $
+
+ 09 Jun 2005; Mark Loeser <halcy0n@gentoo.org>
+ +files/0.35/shfs-0.35-gcc4.patch:
+ Adding patch to fix compilation with GCC4
07 Apr 2005; Simon Stelling <blubb@gentoo.org> shfs-0.35-r1.ebuild:
stable on amd64
diff --git a/net-fs/shfs/Manifest b/net-fs/shfs/Manifest
index 0c5325a0c24f..83421cc55c02 100644
--- a/net-fs/shfs/Manifest
+++ b/net-fs/shfs/Manifest
@@ -24,3 +24,4 @@ MD5 bdf9a4a620ff5bcd7828251c144ec02b files/shfs.mount 1346
MD5 29b3f063e5feb8c259abc86d07f92f85 files/0.35/df.patch 1652
MD5 e5f37f793e95acdfd8e89affe9949160 files/0.35/space_chars.patch 1276
MD5 29e5b080a1744f8283b8f55d5b904a60 files/0.35/uidgid32.patch 940
+MD5 aa8bade7210ab4840af4a009378a96c3 files/0.35/shfs-0.35-gcc4.patch 1008
diff --git a/net-fs/shfs/files/0.35/shfs-0.35-gcc4.patch b/net-fs/shfs/files/0.35/shfs-0.35-gcc4.patch
new file mode 100644
index 000000000000..c4fd36629b51
--- /dev/null
+++ b/net-fs/shfs/files/0.35/shfs-0.35-gcc4.patch
@@ -0,0 +1,23 @@
+diff -ur shfs-0.35/shfs/Linux-2.6/dir.c shfs-0.35-new/shfs/Linux-2.6/dir.c
+--- shfs-0.35/shfs/Linux-2.6/dir.c 2004-06-01 09:16:19.000000000 -0400
++++ shfs-0.35-new/shfs/Linux-2.6/dir.c 2005-02-11 18:12:00.000000000 -0500
+@@ -19,6 +19,8 @@
+ #include "shfs_debug.h"
+ #include "proc.h"
+
++static struct dentry_operations shfs_dentry_operations;
++
+ static int
+ shfs_dir_open(struct inode *inode, struct file *filp)
+ {
+diff -ur shfs-0.35/shfs/Linux-2.6/shfs_fs.h shfs-0.35-new/shfs/Linux-2.6/shfs_fs.h
+--- shfs-0.35/shfs/Linux-2.6/shfs_fs.h 2004-06-01 09:16:19.000000000 -0400
++++ shfs-0.35-new/shfs/Linux-2.6/shfs_fs.h 2005-02-11 18:12:03.000000000 -0500
+@@ -50,7 +50,6 @@
+ #define ROUND_TO_MINS(x) do { (x).tv_sec = ((x).tv_sec / 60) * 60; (x).tv_nsec = 0; } while (0)
+
+ /* shfs/dir.c */
+-extern struct dentry_operations shfs_dentry_operations;
+ extern struct file_operations shfs_dir_operations;
+ extern struct inode_operations shfs_dir_inode_operations;
+ extern void shfs_new_dentry(struct dentry *dentry);