summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-08-27 08:07:30 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-08-27 08:07:30 +0000
commit01f7dd214abdb6db59b51ee439ecc10bcc6cdbc6 (patch)
tree568dd8bf15c4775c989ce6d6b415068508857ac5 /net-fs
parentRemove old. (diff)
downloadgentoo-2-01f7dd214abdb6db59b51ee439ecc10bcc6cdbc6.tar.gz
gentoo-2-01f7dd214abdb6db59b51ee439ecc10bcc6cdbc6.tar.bz2
gentoo-2-01f7dd214abdb6db59b51ee439ecc10bcc6cdbc6.zip
Version bump to 1.6.5. Fixes bug #478498 which fixes security bug #478296, security bug #478282, bug #472184, bug #469992, bug #463477 and bug #460494. Proxied commit for Andrej Filipcic.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs-kernel/ChangeLog9
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.6.5.ebuild88
2 files changed, 96 insertions, 1 deletions
diff --git a/net-fs/openafs-kernel/ChangeLog b/net-fs/openafs-kernel/ChangeLog
index 59a7b2bd051a..6c92d0e52000 100644
--- a/net-fs/openafs-kernel/ChangeLog
+++ b/net-fs/openafs-kernel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/openafs-kernel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.151 2013/04/13 14:21:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.152 2013/08/27 08:07:30 tomwij Exp $
+
+*openafs-kernel-1.6.5 (27 Aug 2013)
+
+ 27 Aug 2013; Tom Wijsman <TomWij@gentoo.org> +openafs-kernel-1.6.5.ebuild:
+ Version bump to 1.6.5. Fixes bug #478498 which fixes security bug #478296,
+ security bug #478282, bug #472184, bug #469992, bug #463477 and bug #460494.
+ Proxied commit for Andrej Filipcic.
13 Apr 2013; Agostino Sarubbo <ago@gentoo.org>
-openafs-kernel-1.4.14.1.ebuild, -openafs-kernel-1.6.1-r2.ebuild,
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.6.5.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.6.5.ebuild
new file mode 100644
index 000000000000..dbae089eb24d
--- /dev/null
+++ b/net-fs/openafs-kernel/openafs-kernel-1.6.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.6.5.ebuild,v 1.1 2013/08/27 08:07:30 tomwij Exp $
+
+EAPI="4"
+
+inherit eutils autotools multilib linux-mod versionator toolchain-funcs
+
+MY_PV=$(delete_version_separator '_')
+MY_PN=${PN/-kernel}
+MY_P2="${MY_PN}-${PV}"
+MY_P="${MY_PN}-${MY_PV}"
+PVER="1"
+DESCRIPTION="The OpenAFS distributed file system kernel module"
+HOMEPAGE="http://www.openafs.org/"
+# We always d/l the doc tarball as man pages are not USE=doc material
+SRC_URI="http://openafs.org/dl/openafs/${MY_PV}/${MY_P}-src.tar.bz2
+ mirror://gentoo/${MY_P2}-patches-${PVER}.tar.bz2"
+
+LICENSE="IBM BSD openafs-krb5-a APSL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS KEYS"
+ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
+ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
+ERROR_KEYS="OpenAFS needs CONFIG_KEYS option enabled"
+
+QA_TEXTRELS_x86_fbsd="/boot/modules/libafs.ko"
+QA_TEXTRELS_amd64_fbsd="/boot/modules/libafs.ko"
+
+pkg_setup() {
+ if use kernel_linux; then
+ linux-mod_pkg_setup
+ fi
+}
+
+src_prepare() {
+ EPATCH_EXCLUDE="012_all_kbuild.patch" \
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/gentoo/patches
+
+ # packaging is f-ed up, so we can't run automake (i.e. eautoreconf)
+ sed -i 's/^\(\s*\)a/\1ea/' regen.sh
+ : # this line makes repoman ok with not calling eautoconf etc. directly
+ skipman=1
+ . regen.sh
+}
+
+src_configure() {
+ ARCH="$(tc-arch-kernel)" \
+ econf \
+ --with-linux-kernel-headers=${KV_DIR} \
+ --with-linux-kernel-build=${KV_OUT_DIR}
+}
+
+src_compile() {
+ ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die
+}
+
+src_install() {
+ if use kernel_linux; then
+ local srcdir=$(expr "${S}"/src/libafs/MODLOAD-*)
+ [[ -f ${srcdir}/libafs.${KV_OBJ} ]] || die "Couldn't find compiled kernel module"
+
+ MODULE_NAMES="libafs(fs/openafs:${srcdir})"
+
+ linux-mod_src_install
+ elif use kernel_FreeBSD; then
+ insinto /boot/modules
+ doins "${S}"/src/libafs/MODLOAD/libafs.ko
+ fi
+}
+
+pkg_postinst() {
+ # Update linker.hints file
+ use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
+ use linux_kernel && linux-mod_pkg_postinst
+}
+
+pkg_postrm() {
+ # Update linker.hints file
+ use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
+ use linux_kernel && linux-mod_pkg_postrm
+}