summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-10-18 16:48:59 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-10-18 16:48:59 +0000
commit080ff5b0656e365857ac5eea413f8a79a5eadd8f (patch)
treea169186948043138bd2674cadddfdac38b4f7c7c /net-fs
parentStable on amd64 wrt bug #341345 (diff)
downloadgentoo-2-080ff5b0656e365857ac5eea413f8a79a5eadd8f.tar.gz
gentoo-2-080ff5b0656e365857ac5eea413f8a79a5eadd8f.tar.bz2
gentoo-2-080ff5b0656e365857ac5eea413f8a79a5eadd8f.zip
--without-mask
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog9
-rw-r--r--net-fs/samba/samba-3.5.6.ebuild (renamed from net-fs/samba/samba-3.4.6.ebuild)76
2 files changed, 64 insertions, 21 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index d534cd2d05da..a0a2f0b93305 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.449 2010/09/27 16:40:37 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.450 2010/10/18 16:48:59 vostorga Exp $
+
+*samba-3.5.6 (18 Oct 2010)
+
+ 18 Oct 2010; Víctor Ostorga <vostorga@gentoo.org> -samba-3.4.6.ebuild,
+ +samba-3.5.6.ebuild:
+ Version bump to 3.5.6 bug #341581 . Fixing dependency version on
+ dev-db/ctdb bug #339283
27 Sep 2010; Mart Raudsepp <leio@gentoo.org> samba-3.5.5.ebuild:
Re-keyword ~mips for bug #285952 and to fix a lot of deptrees
diff --git a/net-fs/samba/samba-3.4.6.ebuild b/net-fs/samba/samba-3.5.6.ebuild
index ebf171dc4b55..adb3637e48ba 100644
--- a/net-fs/samba/samba-3.4.6.ebuild
+++ b/net-fs/samba/samba-3.5.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.4.6.ebuild,v 1.10 2010/08/12 01:28:14 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.5.6.ebuild,v 1.1 2010/10/18 16:48:59 vostorga Exp $
EAPI="2"
-inherit pam confutils versionator multilib
+inherit pam confutils versionator multilib eutils
MY_PV=${PV/_/}
MY_P="${PN}-${MY_PV}"
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.samba.org/"
SRC_URI="mirror://samba/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="acl addns ads aio avahi caps +client cluster cups debug doc examples fam
ldap ldb +netapi pam quota +readline +server +smbclient smbsharemodes swat
syslog winbind "
@@ -32,7 +32,7 @@ DEPEND="dev-libs/popt
caps? ( sys-libs/libcap )
client? ( !net-fs/mount-cifs
dev-libs/iniparser )
- cluster? ( dev-db/ctdb )
+ cluster? ( >=dev-db/ctdb-1.0.114_p1 )
cups? ( net-print/cups )
debug? ( dev-libs/dmalloc )
fam? ( virtual/fam )
@@ -49,6 +49,9 @@ RESTRICT="test"
SBINPROGS=""
BINPROGS=""
+KRBPLUGIN=""
+PLUGINEXT=".so"
+SHAREDMODS=""
if use server ; then
SBINPROGS="${SBINPROGS} bin/smbd bin/nmbd"
@@ -57,7 +60,7 @@ if use server ; then
use swat && SBINPROGS="${SBINPROGS} bin/swat"
use winbind && SBINPROGS="${SBINPROGS} bin/winbindd"
- use ads && use winbind && SBIN_PROGS="${SBINPROGS} bin/winbind_krb5_locator"
+ use ads && use winbind && KRBPLUGIN="${KRBPLUGIN} bin/winbind_krb5_locator"
fi
if use client ; then
@@ -70,7 +73,13 @@ fi
use cups && BINPROGS="${BINPROGS} bin/smbspool"
use ldb && BINPROGS="${BINPROGS} bin/ldbedit bin/ldbsearch bin/ldbadd bin/ldbdel bin/ldbmodify bin/ldbrename";
-use winbind && BINPROGS="${BINPROGS} bin/wbinfo"
+
+if use winbind ; then
+ BINPROGS="${BINPROGS} bin/wbinfo"
+ SHAREDMODS="${SHAREDMODS}idmap_rid"
+ use ads && SHAREDMODS="${SHAREDMODS},idmap_ad"
+ use ldap && SHAREDMODS="${SHAREDMODS},idmap_ldap"
+fi
S="${WORKDIR}/${MY_P}/source3"
@@ -82,7 +91,6 @@ S="${WORKDIR}/${MY_P}/source3"
CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
pkg_setup() {
-
if use winbind &&
[[ $(tc-getCC)$ == *gcc* ]] &&
[[ $(gcc-major-version)$(gcc-minor-version) -lt 43 ]]
@@ -95,7 +103,6 @@ pkg_setup() {
confutils_use_depend_all ads ldap
confutils_use_depend_all swat server
- confutils_use_depend_all client netapi
}
src_prepare() {
@@ -160,6 +167,7 @@ src_configure() {
$(use_with ads dnsupdate) \
--without-automount \
$(use_with client cifsmount) \
+ $(use_with client cifsumount) \
$(use_with pam) \
$(use_with pam pam_smbpass) \
$(use_with syslog) \
@@ -177,6 +185,7 @@ src_configure() {
$(use_with aio aio-support) \
--with-sendfile-support \
$(use_with winbind) \
+ --with-shared-modules=${SHAREDMODS} \
--without-included-popt \
--without-included-iniparser
}
@@ -225,6 +234,11 @@ src_compile() {
emake ${SBINPROGS} || die "emake sbinprogs failed";
fi
+ if [ -n "${KRBPLUGIN}" ] ; then
+ einfo "make krbplugin"
+ emake ${KRBPLUGIN}${PLUGINEXT} || die "emake krbplugin failed";
+ fi
+
if use client ; then
einfo "make {,u}mount.cifs"
emake bin/{,u}mount.cifs || die "emake {,u}mount.cifs failed"
@@ -288,6 +302,23 @@ src_install() {
doman ../docs/manpages/${prog/bin\/}* || die "doman failed"
done
+ # install krbplugin
+ if [ -n "${KRBPLUGIN}" ] ; then
+ if has_version app-crypt/mit-krb5 ; then
+ insinto /usr/$(get_libdir)/krb5/plugins/libkrb5
+ doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
+ ${KRBPLUGIN}${PLUGINEXT} failed"
+ elif has_version app-crypt/heimdal ; then
+ insinto /usr/$(get_libdir)/plugin/krb5
+ doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
+ ${KRBPLUGIN}${PLUGINEXT} failed"
+ fi
+ insinto /usr
+ for prog in ${KRBPLUGIN} ; do
+ doman ../docs/manpages/${prog/bin\/}* || die "doman failed"
+ done
+ fi
+
# install server components
if use server ; then
doman ../docs/manpages/vfs* ../docs/manpages/samba.7
@@ -333,7 +364,9 @@ src_install() {
fi
# install the spooler to cups
- use cups && dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
+ if use cups ; then
+ dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
+ fi
# install misc files
insinto /etc/samba
@@ -351,7 +384,6 @@ src_install() {
# install examples
if use examples ; then
- einfo "install examples"
insinto /usr/share/doc/${PF}/examples
if use smbclient ; then
@@ -363,9 +395,10 @@ src_install() {
fi
if use server ; then
- doins -r \
- auth autofs dce-dfs LDAP logon misc pdb perfcounter \
- printer-accounting printing scripts tridge validchars VFS
+ cd ../examples
+ doins -r auth autofs dce-dfs LDAP logon misc pdb \
+ perfcounter printer-accounting printing scripts tridge \
+ validchars VFS
fi
fi
@@ -379,13 +412,16 @@ src_install() {
}
pkg_postinst() {
- elog "The default passdb backend has been changed to 'tdbsam' in samba 3.4!"
- elog "That breaks existing setups using the 'smbpasswd' backend without"
- elog "explicit declaration!"
- elog "Please use 'passdb backend = smbpasswd' if you would like to stick to the"
- elog "'smbpasswd' backend or convert your smbpasswd entries using e.g. "
- elog "'pdbedit -i smbpasswd -e tdbsam'."
+ elog "The default value of 'wide links' has been changed to 'no' in samba 3.5"
+ elog "to avoid an insecure default configuration"
+ elog "('wide links = yes' and 'unix extensions = yes'). For more details,"
+ elog "please see http://www.samba.org/samba/news/symlink_attack.html ."
+ elog ""
+ elog "An EXPERIMENTAL implementation of the SMB2 protocol has been added."
+ elog "SMB2 can be enabled by setting 'max protocol = smb2'. SMB2 is a new "
+ elog "implementation of the SMB protocol used by Windows Vista and higher"
+ elog ""
elog "For further information make sure to read the release notes at"
elog "http://samba.org/samba/history/${P}.html and "
- elog "http://samba.org/samba/history/${PN}-3.4.0.html"
+ elog "http://samba.org/samba/history/${PN}-3.5.0.html"
}