summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-10-02 11:00:35 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-10-02 11:00:35 +0000
commit318046a6dd9e2b70161b0e3d631b6a14d558a43b (patch)
tree80cb00fff42e1809bdb6ab45cca73000c725475f /net-fs
parentcheck for video_dev to be present in the kernel thanks to Nathan Caldwell <sa... (diff)
downloadgentoo-2-318046a6dd9e2b70161b0e3d631b6a14d558a43b.tar.gz
gentoo-2-318046a6dd9e2b70161b0e3d631b6a14d558a43b.tar.bz2
gentoo-2-318046a6dd9e2b70161b0e3d631b6a14d558a43b.zip
Add patch to compile with new fuse thanks to Elias Probst <elias.probst@gmx.de> in bug 149003
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/curlftpfs/ChangeLog7
-rw-r--r--net-fs/curlftpfs/curlftpfs-0.8.ebuild12
-rw-r--r--net-fs/curlftpfs/files/fuse-2.6.diff11
3 files changed, 27 insertions, 3 deletions
diff --git a/net-fs/curlftpfs/ChangeLog b/net-fs/curlftpfs/ChangeLog
index 93c0ea635bfd..8bf632ae61d0 100644
--- a/net-fs/curlftpfs/ChangeLog
+++ b/net-fs/curlftpfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/curlftpfs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/curlftpfs/ChangeLog,v 1.3 2006/08/30 08:12:44 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/curlftpfs/ChangeLog,v 1.4 2006/10/02 11:00:35 genstef Exp $
+
+ 02 Oct 2006; Stefan Schweizer <genstef@gentoo.org> +files/fuse-2.6.diff,
+ curlftpfs-0.8.ebuild:
+ Add patch to compile with new fuse thanks to Elias Probst
+ <elias.probst@gmx.de> in bug 149003
30 Aug 2006; <blubb@gentoo.org> curlftpfs-0.8.ebuild:
marked ~amd64
diff --git a/net-fs/curlftpfs/curlftpfs-0.8.ebuild b/net-fs/curlftpfs/curlftpfs-0.8.ebuild
index 4ba3d40f267b..2057810b4992 100644
--- a/net-fs/curlftpfs/curlftpfs-0.8.ebuild
+++ b/net-fs/curlftpfs/curlftpfs-0.8.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/curlftpfs/curlftpfs-0.8.ebuild,v 1.2 2006/08/30 08:12:44 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/curlftpfs/curlftpfs-0.8.ebuild,v 1.3 2006/10/02 11:00:35 genstef Exp $
+
+inherit eutils
DESCRIPTION="CurlFtpFS is a filesystem for acessing ftp hosts based on FUSE"
HOMEPAGE="http://curlftpfs.sourceforge.net"
@@ -14,7 +16,13 @@ IUSE=""
RDEPEND=">=net-misc/curl-7.15.2
>=sys-fs/fuse-2.2"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fuse-2.6.diff
+}
+
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR=${D} install || die "emake install failed"
dodoc README
}
diff --git a/net-fs/curlftpfs/files/fuse-2.6.diff b/net-fs/curlftpfs/files/fuse-2.6.diff
new file mode 100644
index 000000000000..61824e135f0e
--- /dev/null
+++ b/net-fs/curlftpfs/files/fuse-2.6.diff
@@ -0,0 +1,11 @@
+--- ftpfs-ls.c 2006/05/20 18:09:42 1.6
++++ ftpfs-ls.c 2006/09/29 18:37:56 1.7
+@@ -6,7 +6,7 @@
+ See the file COPYING.
+ */
+
+-#define _XOPEN_SOURCE
++#define _XOPEN_SOURCE 600
+ #include <time.h>
+ #include <string.h>
+ #include <sys/types.h>