summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-06 08:45:14 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-06 08:45:14 +0000
commit3e90474e50d9606e244d42d30280b315c37f7b9a (patch)
tree464567a2a62c4e06bfd5c998de03187ccfc095fa /net-fs
parentUpdate init script for redis-2.6.13 (thanks to jbergstroem). (diff)
downloadgentoo-2-3e90474e50d9606e244d42d30280b315c37f7b9a.tar.gz
gentoo-2-3e90474e50d9606e244d42d30280b315c37f7b9a.tar.bz2
gentoo-2-3e90474e50d9606e244d42d30280b315c37f7b9a.zip
net-fs/autofs: Add missing if statements for non-sasl ldap, #468606
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog7
-rw-r--r--net-fs/autofs/autofs-5.0.7-r1.ebuild4
-rw-r--r--net-fs/autofs/files/autofs-5.0.7-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch45
3 files changed, 53 insertions, 3 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 40ec10056938..31e8b6a4096b 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.150 2013/05/05 12:50:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.151 2013/05/06 08:45:14 jlec Exp $
+
+ 06 May 2013; Justin Lecher <jlec@gentoo.org> autofs-5.0.7-r1.ebuild,
+ +files/autofs-5.0.7-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patc
+ h:
+ Add missing if statements for non-sasl ldap, #468606
05 May 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Update e-mail address
diff --git a/net-fs/autofs/autofs-5.0.7-r1.ebuild b/net-fs/autofs/autofs-5.0.7-r1.ebuild
index c611f6d6a778..e0aad1ee793e 100644
--- a/net-fs/autofs/autofs-5.0.7-r1.ebuild
+++ b/net-fs/autofs/autofs-5.0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.7-r1.ebuild,v 1.2 2013/05/04 17:18:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.7-r1.ebuild,v 1.3 2013/05/06 08:45:14 jlec Exp $
EAPI=5
@@ -55,7 +55,7 @@ PATCHES=(
# Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/5371
"${FILESDIR}"/${PN}-5.0.5-fix-install-deadlink.patch
- "${FILESDIR}"/${PN}-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch #361899
+ "${FILESDIR}"/${P}-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch #361899, #468606
"${FILESDIR}"/${PN}-5.0.6-revert-ldap.patch #381315
"${FILESDIR}"/${PN}-5.0.7-mount-sloppy.patch #453778
)
diff --git a/net-fs/autofs/files/autofs-5.0.7-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch b/net-fs/autofs/files/autofs-5.0.7-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
new file mode 100644
index 000000000000..366b1eaaba3b
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.7-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
@@ -0,0 +1,45 @@
+--- ./modules/lookup_ldap.c
++++ ./modules/lookup_ldap.c
+@@ -591,10 +591,12 @@ static LDAP *do_connect(unsigned logopt, const char *uri, struct lookup_context
+ {
+ LDAP *ldap;
+
++#ifdef HAVE_SASL
+ if (ctxt->extern_cert && ctxt->extern_key) {
+ set_env(logopt, ENV_LDAPTLS_CERT, ctxt->extern_cert);
+ set_env(logopt, ENV_LDAPTLS_KEY, ctxt->extern_key);
+ }
++#endif
+
+ ldap = init_ldap_connection(logopt, uri, ctxt);
+ if (ldap) {
+@@ -1372,10 +1374,12 @@ static void free_context(struct lookup_context *ctxt)
+ defaults_free_searchdns(ctxt->sdns);
+ if (ctxt->dclist)
+ free_dclist(ctxt->dclist);
++#ifdef HAVE_SASL
+ if (ctxt->extern_cert)
+ free(ctxt->extern_cert);
+ if (ctxt->extern_key)
+ free(ctxt->extern_key);
++#endif
+ free(ctxt);
+
+ return;
+ modules/lookup_ldap.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/modules/lookup_ldap.c b/modules/lookup_ldap.c
+index dbec753..ce1e2e5 100644
+--- a/modules/lookup_ldap.c
++++ b/modules/lookup_ldap.c
+@@ -28,7 +28,9 @@
+ #include <arpa/nameser.h>
+ #include <resolv.h>
+ #include <lber.h>
++#ifdef HAVE_SASL
+ #include <libxml/tree.h>
++#endif
+
+ #define MODULE_LOOKUP
+ #include "automount.h"