summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-02-23 17:45:05 +0000
committerDonny Davies <woodchip@gentoo.org>2003-02-23 17:45:05 +0000
commit51b5b4dcd700133beb935c7843eea84bbde19491 (patch)
tree455fe397f2478ebe6a864da200a852c2f5beb0d8 /net-fs
parentadd samba-3.0_alpha (diff)
downloadgentoo-2-51b5b4dcd700133beb935c7843eea84bbde19491.tar.gz
gentoo-2-51b5b4dcd700133beb935c7843eea84bbde19491.tar.bz2
gentoo-2-51b5b4dcd700133beb935c7843eea84bbde19491.zip
samba-2.2.8_pre1 + samba-3.0_alpha21
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog14
-rw-r--r--net-fs/samba/files/digest-samba-2.2.8_pre13
-rw-r--r--net-fs/samba/files/digest-samba-3.0_alpha213
-rw-r--r--net-fs/samba/samba-2.2.8_pre1.ebuild397
-rw-r--r--net-fs/samba/samba-3.0_alpha21.ebuild335
5 files changed, 751 insertions, 1 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 56275dde76a0..797af88d0c05 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-fs/samba
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.27 2003/02/12 07:57:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.28 2003/02/23 17:45:05 woodchip Exp $
+
+*samba-3.0_alpha21 (22 Feb 2003)
+
+ 22 Feb 2003; Donny Davies <woodchip@gentoo.org> : Initial import.
+ Added to package.mask for now.
+
+*samba-2.2.8_pre1 (22 Feb 2003)
+
+ 22 Feb 2003; Donny Davies <woodchip@gentoo.org> : This _pre update fixes
+ about 30 bugs; see WHATSNEW.txt. Updated to samba-vscan-0.3.2. Install
+ libsmbclient.h #15357. Added --with-winbind-auth-challenge #15748. Add
+ --with-winbind-ldap-hack if USE=ldap. Re-org some stuff.
27 Jan 2003; Donny Davies <woodchip@gentoo.org> : #14644 adds reload().
diff --git a/net-fs/samba/files/digest-samba-2.2.8_pre1 b/net-fs/samba/files/digest-samba-2.2.8_pre1
new file mode 100644
index 000000000000..b077f40c863c
--- /dev/null
+++ b/net-fs/samba/files/digest-samba-2.2.8_pre1
@@ -0,0 +1,3 @@
+MD5 a1399b9e297f51bd18cb21339a3f8f67 samba-vscan-0.3.2.tar.bz2 68127
+MD5 8db28b53c27f8cbd564382d2f5f1787c samba-2.2.7a.tar.bz2 4370869
+MD5 1b1c58ed1961a9e49ecdd7caba7bd9b7 patch-2.2.7a-2.2.8pre1.diffs.gz 80462
diff --git a/net-fs/samba/files/digest-samba-3.0_alpha21 b/net-fs/samba/files/digest-samba-3.0_alpha21
new file mode 100644
index 000000000000..3e030b50d5f3
--- /dev/null
+++ b/net-fs/samba/files/digest-samba-3.0_alpha21
@@ -0,0 +1,3 @@
+MD5 a1399b9e297f51bd18cb21339a3f8f67 samba-vscan-0.3.2.tar.bz2 68127
+MD5 241e897062ead54ec8c6ca0a3a6f45f6 samba-3.0alpha21.tar.bz2 4375333
+MD5 f1b2141449bc7409e7edc7f78e6b98fd samba-3.0alpha21-patches-1.tar.bz2 5618
diff --git a/net-fs/samba/samba-2.2.8_pre1.ebuild b/net-fs/samba/samba-2.2.8_pre1.ebuild
new file mode 100644
index 000000000000..ab9205a95f56
--- /dev/null
+++ b/net-fs/samba/samba-2.2.8_pre1.ebuild
@@ -0,0 +1,397 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.8_pre1.ebuild,v 1.1 2003/02/23 17:45:05 woodchip Exp $
+
+inherit eutils
+
+IUSE="pam acl cups ldap ssl tcpd"
+IUSE="${IUSE} oav"
+
+VSCAN_VER=0.3.2
+VSCAN_MODS=${VSCAN_MODS:=fprot mks openantivirus sophos trend icap} #kapersky
+# To build the "kapersky" plugin, the kapersky lib must be installed.
+
+DESCRIPTION="SAMBA is a suite of SMB and CIFS client/server programs for UNIX"
+HOMEPAGE="http://www.samba.org"
+
+S=${WORKDIR}/samba-2.2.7a
+SRC_URI="oav? mirror://sourceforge/openantivirus/${PN}-vscan-${VSCAN_VER}.tar.bz2
+ http://us3.samba.org/samba/ftp/samba-2.2.7a.tar.bz2
+ http://us3.samba.org/samba/ftp/pre/patch-2.2.7a-2.2.8pre1.diffs.gz"
+DEPEND="pam? >=sys-libs/pam-0.72
+ acl? sys-apps/acl
+ cups? net-print/cups
+ ldap? =net-nds/openldap-2*
+ ssl? >=dev-libs/openssl-0.9.6
+ tcpd? >=sys-apps/tcp-wrappers-7.6
+ oav? >=dev-libs/popt-1.6.3"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ local i
+ unpack ${A} || die
+ cd ${S} || die
+
+ epatch ../patch-2.2.7a-2.2.8pre1.diffs
+
+ epatch ${FILESDIR}/samba-2.2.2-smbmount.diff
+ epatch ${FILESDIR}/samba-2.2.5-gp-reloc-fix.patch
+
+ if use portldap; then
+ cd ${S}/source
+ epatch $FILESDIR/nonroot-bind.diff
+ fi
+
+ if use ldap; then
+ cd ${S}
+ epatch ${FILESDIR}/samba-2.2.6-libresolv.patch
+ fi
+
+ # fix kerberos include file collision..
+ # --still an issue? :/
+ cd ${S}/source/include
+ mv profile.h smbprofile.h
+ sed -e "s:profile\.h:smbprofile.h:" includes.h > includes.h.new
+ mv includes.h.new includes.h
+
+ # for clean docs packaging sake, make a copy..
+ cp -a ${S}/examples ${S}/examples.bin
+ # prep the samba-vscan source
+ use oav && \
+ cp -a ${WORKDIR}/${PN}-vscan-${VSCAN_VER} ${S}/examples.bin/VFS
+
+ cd ${S}/source
+ autoconf || die
+}
+
+src_compile() {
+ local i myconf
+ use acl && myconf="--with-acl-support" \
+ || myconf="--without-acl-support"
+
+ use ssl && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use pam && myconf="${myconf} --with-pam --with-pam_smbpass" \
+ || myconf="${myconf} --without-pam --without-pam_smbpass"
+
+ use cups && myconf="${myconf} --enable-cups" \
+ || myconf="${myconf} --disable-cups"
+
+ use ldap && myconf="${myconf} --with-ldapsam --with-winbind-ldap-hack" \
+ || myconf="${myconf} --without-ldapsam"
+
+ cd ${S}/source
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/sbin \
+ --libdir=/etc/samba \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var/log \
+ --with-configdir=/etc/samba \
+ --with-mandir=/usr/share/man \
+ --with-piddir=/var/run/samba \
+ --with-swatdir=/usr/share/swat \
+ --with-lockdir=/var/cache/samba \
+ --with-privatedir=/etc/samba/private \
+ --with-codepagedir=/var/lib/samba/codepages \
+ --with-winbind-auth-challenge \
+ --with-sendfile-support \
+ --without-sambabook \
+ --without-automount \
+ --without-spinlocks \
+ --with-libsmbclient \
+ --with-smbwrapper \
+ --with-netatalk \
+ --with-smbmount \
+ --with-profile \
+ --with-quotas \
+ --with-syslog \
+ --with-msdfs \
+ --with-utmp \
+ --with-vfs \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ # compile samba..
+ make all smbfilter smbwrapper smbcacls \
+ nsswitch nsswitch/libnss_wins.so debug2html
+ assert "samba compile problem"
+ if use pam; then
+ make pam_smbpass || die "pam_smbpass compile problem"
+ fi
+
+ # compile the bundled vfs modules..
+ cd ${S}/examples.bin/VFS
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die "bad ./configure"
+ make || die "VFS modules compile problem"
+
+ # compile the selected antivirus vfs plugins..
+ if use oav; then
+ for i in ${VSCAN_MODS}
+ do
+ cd ${S}/examples.bin/VFS/${PN}-vscan-${VSCAN_VER}/$i
+ make USE_INCLMKSDLIB=1 #needed for the mks build
+ assert "problem building $i vscan module"
+ done
+ fi
+
+ # compile mkntpasswd in examples/LDAP/ for smbldaptools..
+ if use ldap; then
+ cd ${S}/examples.bin/LDAP/smbldap-tools/mkntpwd
+ VISUAL="" make || die "mkntpwd compile problem"
+ fi
+}
+
+src_install() {
+ local i
+
+ # we may as well do this all manually since it was starting
+ # to get out of control and samba _does_ have some rather
+ # silly installation quirks ;) much of this was adapted
+ # from mandrake's .spec file.. // woodchip - 5 May 2002
+
+ # install standard binary files..
+ for i in nmblookup smbclient smbpasswd smbstatus testparm testprns \
+ make_smbcodepage make_unicodemap make_printerdef rpcclient \
+ smbspool smbcacls smbclient smbmount smbumount smbsh wbinfo
+ do
+ exeinto /usr/bin
+ doexe source/bin/${i}
+ done
+ # make users lives easier..
+ fperms 4755 /usr/bin/smbumount
+
+
+ # secure binary files..
+ for i in smbd nmbd swat smbfilter debug2html smbmnt smbcontrol winbindd
+ do
+ exeinto /usr/sbin
+ doexe source/bin/${i}
+ done
+ # make users lives easier..
+ fperms 4755 /usr/sbin/smbmnt
+
+
+ # some utility scripts..
+ for i in mksmbpasswd.sh smbtar convert_smbpasswd
+ do
+ exeinto /usr/bin
+ doexe source/script/${i}
+ done
+ # and this handy one..
+ doexe packaging/Mandrake/findsmb
+
+
+ # utilities from LDAP/smbldap-tools
+ if use ldap; then
+ exeinto /usr/share/samba/smbldap-tools
+ doexe examples/LDAP/smbldap-tools/*.pl
+ doexe examples/LDAP/smbldap-tools/smbldap_tools.pm
+ doexe examples/LDAP/{import,export}_smbpasswd.pl
+ chmod 0700 ${D}/usr/share/samba/smbldap-tools/{import,export}_smbpasswd.pl
+ exeinto /usr/sbin
+ doexe examples.bin/LDAP/smbldap-tools/mkntpwd/mkntpwd
+ #dodir /usr/lib/perl5/site_perl/5.6.1
+ eval `perl '-V:installarchlib'`
+ dodir ${installarchlib}
+ dosym /etc/samba/smbldap_conf.pm ${installarchlib}
+ dosym /usr/share/samba/smbldap-tools/smbldap_tools.pm ${installarchlib}
+ fi
+
+
+ # libraries..
+ exeinto /usr/lib
+ doexe source/bin/smbwrapper.so
+ doexe source/bin/libsmbclient.so
+ insinto /usr/lib
+ doins source/bin/libsmbclient.a
+ insinto /usr/include
+ doins source/include/libsmbclient.h
+ exeinto /lib/security
+ doexe source/nsswitch/pam_winbind.so
+ use pam && doexe source/bin/pam_smbpass.so
+
+
+ # nsswitch library extension files..
+ for i in wins winbind
+ do
+ exeinto /lib
+ doexe source/nsswitch/libnss_${i}.so
+ done
+ # make link for wins and winbind resolvers..
+ ( cd ${D}/lib ; ln -s libnss_wins.so libnss_wins.so.2 )
+ ( cd ${D}/lib ; ln -s libnss_winbind.so libnss_winbind.so.2 )
+
+
+ # vfs modules..
+ exeinto /usr/lib/samba/vfs
+ doexe examples.bin/VFS/audit.so
+ doexe examples.bin/VFS/block/block.so
+ doexe examples.bin/VFS/recycle/recycle.so
+ use oav && \
+ doexe examples.bin/VFS/${PN}-vscan-${VSCAN_VER}/*/vscan-*.so
+
+
+ # codepage source files..
+ for i in 437 737 775 850 852 857 861 862 866 932 936 949 950 1125 1251
+ do
+ insinto /var/lib/samba/codepages/src
+ doins source/codepages/codepage_def.${i}
+ done
+ for i in 437 737 775 850 852 857 861 862 866 932 936 949 950 1125 1251 \
+ ISO8859-1 ISO8859-2 ISO8859-5 ISO8859-7 \
+ ISO8859-9 ISO8859-13 ISO8859-15 KOI8-R KOI8-U
+ do
+ insinto /var/lib/samba/codepages/src
+ doins source/codepages/CP${i}.TXT
+ done
+
+
+ # build codepage load files..
+ for i in 437 737 775 850 852 857 861 862 866 932 936 949 950 1125 1251
+ do
+ ${D}/usr/bin/make_smbcodepage c ${i} \
+ ${D}/var/lib/samba/codepages/src/codepage_def.${i} \
+ ${D}/var/lib/samba/codepages/codepage.${i}
+ done
+ # build unicode load files..
+ for i in 437 737 775 850 852 857 861 862 866 932 936 949 950 1125 1251 \
+ ISO8859-1 ISO8859-2 ISO8859-5 ISO8859-7 \
+ ISO8859-9 ISO8859-13 ISO8859-15 KOI8-R KOI8-U
+ do
+ ${D}/usr/bin/make_unicodemap ${i} \
+ ${D}/var/lib/samba/codepages/src/CP${i}.TXT \
+ ${D}/var/lib/samba/codepages/unicode_map.${i}
+ done
+ rm -rf ${D}/var/lib/samba/codepages/src
+
+
+ # install SWAT helper files..
+ for i in swat/help/*.html docs/htmldocs/*.html
+ do
+ insinto /usr/share/swat/help
+ doins ${i}
+ done
+ for i in swat/images/*.gif
+ do
+ insinto /usr/share/swat/images
+ doins ${i}
+ done
+ for i in swat/include/*.html
+ do
+ insinto /usr/share/swat/include
+ doins ${i}
+ done
+
+
+ # install the O'Reilly "Using Samba" book..
+ for i in docs/htmldocs/using_samba/*.html
+ do
+ insinto /usr/share/swat/using_samba
+ doins ${i}
+ done
+ for i in docs/htmldocs/using_samba/gifs/*.gif
+ do
+ insinto /usr/share/swat/using_samba/gifs
+ doins ${i}
+ done
+ for i in docs/htmldocs/using_samba/figs/*.gif
+ do
+ insinto /usr/share/swat/using_samba/figs
+ doins ${i}
+ done
+
+
+ # man pages..
+ doman docs/manpages/*
+
+
+ # attempt to install all the docs as easily as possible :/
+ # we don't want two copies of the book or manpages
+ rm -rf docs/htmldocs/using_samba docs/manpages
+ dodoc COPYING Manifest README Roadmap WHATSNEW.txt
+ docinto full_docs
+ cp -a docs/* ${D}/usr/share/doc/${PF}/full_docs
+ docinto examples
+ cp -a examples/* ${D}/usr/share/doc/${PF}/examples
+ prepalldocs
+ # keep this next line *after* prepalldocs!
+ dosym /usr/share/swat/using_samba /usr/share/doc/${PF}/using_samba
+ # and we should unzip the html docs..
+ gunzip ${D}/usr/share/doc/${PF}/full_docs/faq/*
+ gunzip ${D}/usr/share/doc/${PF}/full_docs/htmldocs/*
+ if use oav; then
+ docinto ${PN}-vscan-${VSCAN_VER}
+ cd ${WORKDIR}/${PN}-vscan-${VSCAN_VER}
+ dodoc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
+ dodoc */*.conf
+ fi
+
+
+ # link /usr/bin/smbmount to /sbin/mount.smbfs which allows it
+ # to work transparently with the standard 'mount' command..
+ dodir /sbin
+ dosym /usr/bin/smbmount /sbin/mount.smbfs
+
+
+ # make the smb backend symlink for cups printing support..
+ if use cups; then
+ dodir /usr/lib/cups/backend
+ dosym /usr/bin/smbspool /usr/lib/cups/backend/smb
+ fi
+
+
+ # make a symlink on /usr/lib/smbwrapper.so in /usr/sbin
+ # to fix smbsh problem. #6936
+ dosym /usr/lib/smbwrapper.so /usr/bin/smbwrapper.so
+
+
+ # now the config files..
+ insinto /etc
+ doins ${FILESDIR}/nsswitch.conf-winbind
+ doins ${FILESDIR}/nsswitch.conf-wins
+
+ insinto /etc/samba
+ doins ${FILESDIR}/smbusers
+ doins ${FILESDIR}/smb.conf.example
+ doins ${FILESDIR}/lmhosts
+ doins ${FILESDIR}/recycle.conf
+ if use ldap; then
+ doins ${FILESDIR}/smbldap_conf.pm
+ doins ${FILESDIR}/samba-slapd-include.conf
+ fi
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/samba.pam samba
+ doins ${FILESDIR}/system-auth-winbind
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/samba-init samba
+ newexe ${FILESDIR}/winbind-init winbind
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/swat.xinetd swat
+}
+
+pkg_postinst() {
+ # touch /etc/samba/smb.conf so that people installing samba just
+ # to mount smb shares don't get annoying warnings all the time..
+ if [ ! -e ${ROOT}/etc/samba/smb.conf ] ; then
+ touch ${ROOT}/etc/samba/smb.conf
+ fi
+
+ # empty dirs..
+ install -m0700 -o root -g root -d ${ROOT}/etc/samba/private
+ install -m1777 -o root -g root -d ${ROOT}/var/spool/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/log/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/run/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/cache/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/samba/{netlogon,profiles}
+ install -m0755 -o root -g root -d \
+ ${ROOT}/var/lib/samba/printers/{W32X86,WIN40,W32ALPHA,W32MIPS,W32PPC}
+}
diff --git a/net-fs/samba/samba-3.0_alpha21.ebuild b/net-fs/samba/samba-3.0_alpha21.ebuild
new file mode 100644
index 000000000000..0d778a79837d
--- /dev/null
+++ b/net-fs/samba/samba-3.0_alpha21.ebuild
@@ -0,0 +1,335 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0_alpha21.ebuild,v 1.1 2003/02/23 17:45:05 woodchip Exp $
+
+inherit eutils
+
+IUSE="kerberos mysql xml acl cups ldap pam python"
+IUSE="${IUSE} oav"
+
+DESCRIPTION="SAMBA is a suite of SMB and CIFS client/server programs for UNIX"
+HOMEPAGE="http://www.samba.org"
+
+VSCAN_VER=0.3.2
+VSCAN_MODS=${VSCAN_MODS:=fprot mks openantivirus sophos trend icap} #kapersky
+# To build the "kapersky" plugin, the kapersky lib must be installed.
+
+S=${WORKDIR}/${PN}-${PV/_/}
+PATCHBALL=1
+SRC_URI="oav? mirror://sourceforge/openantivirus/${PN}-vscan-${VSCAN_VER}.tar.bz2
+ http://us3.samba.org/samba/ftp/alpha/${PN}-${PV/_/}.tar.bz2
+ mirror://gentoo/${PN}-${PV/_/}-patches-${PATCHBALL}.tar.bz2"
+
+DEPEND="sys-devel/autoconf sys-libs/readline dev-libs/popt
+ kerberos? app-crypt/krb5
+ mysql? ( dev-db/mysql sys-libs/zlib )
+ xml? ( dev-libs/libxml2 sys-libs/zlib )
+ acl? sys-apps/acl
+ cups? net-print/cups
+ ldap? =net-nds/openldap-2*
+ pam? >=sys-libs/pam-0.72
+ python? dev-lang/python"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ local i
+ unpack ${A} || die
+ cd ${S} || die
+
+ # Apply patches.
+ for i in ${WORKDIR}/${PN}-${PV/_/}-patches-${PATCHBALL}/*.patch
+ do
+ epatch $i
+ done
+
+ # For clean docs packaging sake.
+ cp -a ${S}/examples ${S}/examples.bin
+
+ # Prep samba-vscan source.
+ if use oav; then
+ cp -a ${WORKDIR}/${PN}-vscan-${VSCAN_VER} examples.bin/VFS
+ cd examples.bin/VFS/${PN}-vscan-${VSCAN_VER}/include
+
+ sed -e "s%^\(# define SAMBA_VERSION_MAJOR\).*%\1 3%" \
+ vscan-global.h >vscan-global.h.3
+ mv -f vscan-global.h.3 vscan-global.h
+ fi
+
+ cd ${S}/source
+ autoconf || die
+}
+
+src_compile() {
+ local i myconf
+ use acl && myconf="--with-acl-support" \
+ || myconf="--without-acl-support"
+
+ use pam && myconf="${myconf} --with-pam --with-pam_smbpass" \
+ || myconf="${myconf} --without-pam --without-pam_smbpass"
+
+ use cups && myconf="${myconf} --enable-cups" \
+ || myconf="${myconf} --disable-cups"
+
+ use ldap && myconf="${myconf} --with-ldap" \
+ || myconf="${myconf} --without-ldap"
+ #myconf="${myconf} --with-ldapsam" #this is for old samba 2.x compat
+ myconf="${myconf} --without-ldapsam"
+
+ use kerberos && myconf="${myconf} --with-ads" \
+ || myconf="${myconf} --without-ads"
+
+ #this isnt building at the moment.. not for me anyhow :\
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+
+ einfo "\$myconf is: $myconf"
+ cd ${S}/source
+ ./configure \
+ --with-fhs \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-manpages-langs=en \
+ --with-privatedir=/etc/samba/private \
+ --with-sendfile-support \
+ --without-spinlocks \
+ --with-libsmbclient \
+ --with-automount \
+ --with-smbmount \
+ --with-winbind \
+ --with-quotas \
+ --with-tdbsam \
+ --with-syslog \
+ --with-utmp \
+ --host=${CHOST} ${myconf} || die
+
+ # Compile main SAMBA pieces.
+ make everything wins || die
+ make torture rpctorture
+ # rpctorture didnt build
+
+ if use mysql
+ then
+ make bin/pdb_mysql.so || die
+ fi
+ if use xml
+ then
+ make bin/pdb_xml.so || die
+ fi
+ if use python
+ then
+ # this seems to be in-flux atm or something...
+ make python_ext
+ fi
+
+ # Build selected samba-vscan plugins.
+ use oav && \
+ for i in ${VSCAN_MODS}
+ do
+ cd ${S}/examples.bin/VFS/${PN}-vscan-${VSCAN_VER}/$i
+ make USE_INCLMKSDLIB=1 #needed for the mks build
+ assert "problem building $i vscan module"
+ done
+}
+
+#the python stuff isnt installed yet..
+src_install() {
+ # Install standard binary files.
+ for i in smbclient net smbspool testparm testprns smbstatus \
+ smbcontrol smbtree tdbbackup wbinfo smbpasswd rpcclient \
+ smbcacls smbmount smbmnt smbumount nmblookup pdbedit \
+ smbgroupedit \
+ debug2html smbfilter talloctort #smbsh
+ do
+ exeinto /usr/bin
+ doexe source/bin/${i}
+ done
+
+ # TORTURE_PROGS / Testing stuff, if they built they will come.
+ for i in smbtorture msgtest masktest locktest locktest2 \
+ nsstest vfstest rpctorture
+ do
+ if [ -x source/bin/${i} ]
+ then
+ exeinto /usr/bin
+ doexe source/bin/${i}
+ fi
+ done
+
+ # Installing these two setuid-root allows users to (un)mount smbfs.
+ fperms 4755 /usr/bin/smbumount
+ fperms 4755 /usr/bin/smbmnt
+
+ # Install server binaries.
+ for i in smbd nmbd swat wrepld winbindd
+ do
+ exeinto /usr/sbin
+ doexe source/bin/${i}
+ done
+
+ # Libraries.
+ exeinto /usr/lib
+ #broken for a while now with some wacky glibc issue
+ #doexe source/bin/smbwrapper.so
+ doexe source/bin/libsmbclient.so
+ insinto /usr/lib
+ doins source/bin/libsmbclient.a
+ insinto /usr/include
+ doins source/include/libsmbclient.h
+ exeinto /lib/security
+ doexe source/nsswitch/pam_winbind.so
+ use pam && doexe source/bin/pam_smbpass.so
+
+ # nsswitch library extension files.
+ for i in wins winbind
+ do
+ exeinto /lib
+ doexe source/nsswitch/libnss_${i}.so
+ done
+ # make link for wins and winbind resolvers..
+ ( cd ${D}/lib ; ln -s libnss_wins.so libnss_wins.so.2 )
+ ( cd ${D}/lib ; ln -s libnss_winbind.so libnss_winbind.so.2 )
+
+ # VFS plugin modules.
+ exeinto /usr/lib/samba/vfs
+ doexe source/bin/vfs_audit.so
+ doexe source/bin/vfs_netatalk.so
+ doexe source/bin/vfs_recycle.so
+ use oav && \
+ doexe examples.bin/VFS/${PN}-vscan-${VSCAN_VER}/*/vscan-*.so
+
+ # Install passdb modules.
+ exeinto /usr/lib/samba
+ use mysql && doexe source/bin/pdb_mysql.so
+ use xml && doexe source/bin/pdb_xml.so
+
+ # Install codepage data files.
+ insinto /usr/share/samba
+ doins source/codepages/*.dat
+
+
+ # Install SWAT helper files.
+ for i in swat/help/*.html docs/htmldocs/*.html
+ do
+ insinto /usr/share/swat/help
+ doins ${i}
+ done
+ for i in swat/images/*.gif
+ do
+ insinto /usr/share/swat/images
+ doins ${i}
+ done
+ for i in swat/include/*.html
+ do
+ insinto /usr/share/swat/include
+ doins ${i}
+ done
+
+
+ # Install the O'Reilly "Using Samba" book.
+ for i in docs/htmldocs/using_samba/*.html
+ do
+ insinto /usr/share/swat/using_samba
+ doins ${i}
+ done
+ for i in docs/htmldocs/using_samba/gifs/*.gif
+ do
+ insinto /usr/share/swat/using_samba/gifs
+ doins ${i}
+ done
+ for i in docs/htmldocs/using_samba/figs/*.gif
+ do
+ insinto /usr/share/swat/using_samba/figs
+ doins ${i}
+ done
+
+
+ # Install man pages.
+ doman docs/manpages/*
+
+ # SAMBA has a lot of docs, so this just basically
+ # installs them all! We don't want two copies of
+ # the book or manpages though, so:
+ rm -rf docs/htmldocs/using_samba docs/manpages
+
+ dodoc COPYING Manifest README Roadmap WHATSNEW.txt
+ docinto full_docs
+ cp -a docs/* ${D}/usr/share/doc/${PF}/full_docs
+ docinto examples
+ cp -a examples/* ${D}/usr/share/doc/${PF}/examples
+ prepalldocs
+ # keep this next line *after* prepalldocs!
+ dosym /usr/share/swat/using_samba /usr/share/doc/${PF}/using_samba
+ # and we should unzip the html docs..
+ gunzip ${D}/usr/share/doc/${PF}/full_docs/faq/*
+ gunzip ${D}/usr/share/doc/${PF}/full_docs/htmldocs/*
+ if use oav; then
+ docinto ${PN}-vscan-${VSCAN_VER}
+ cd ${WORKDIR}/${PN}-vscan-${VSCAN_VER}
+ dodoc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
+ dodoc */*.conf
+ fi
+ # I guess this isnt really a userpriv buglet... the 'dodoc'
+ # script really needs a recursive feature...
+ chown -R root.root ${D}/usr/share/doc/${PF}
+
+ # link /usr/bin/smbmount to /sbin/mount.smbfs which allows it
+ # to work transparently with the standard 'mount' command..
+ dodir /sbin
+ dosym /usr/bin/smbmount /sbin/mount.smbfs
+
+ # make the smb backend symlink for cups printing support..
+ if use cups; then
+ dodir /usr/lib/cups/backend
+ dosym /usr/bin/smbspool /usr/lib/cups/backend/smb
+ fi
+
+
+ # Now the config files.
+ insinto /etc/openldap/schema
+ doins examples/LDAP/samba.schema
+
+ insinto /etc
+ dodoc ${FILESDIR}/nsswitch.conf-winbind
+ doins ${FILESDIR}/nsswitch.conf-wins
+
+ insinto /etc/samba
+ doins ${FILESDIR}/smbusers
+# need to update this one! :)
+ doins ${FILESDIR}/smb.conf.example
+ doins ${FILESDIR}/lmhosts
+ doins ${FILESDIR}/recycle.conf
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/samba.pam samba
+ doins ${FILESDIR}/system-auth-winbind
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/samba-init samba
+# this one looks funny
+ newexe ${FILESDIR}/winbind-init winbind
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/swat.xinetd swat
+}
+
+pkg_postinst() {
+ # touch /etc/samba/smb.conf so that people installing samba just
+ # to mount smb shares don't get annoying warnings all the time..
+ if [ ! -e ${ROOT}/etc/samba/smb.conf ] ; then
+ touch ${ROOT}/etc/samba/smb.conf
+ fi
+
+ # empty dirs..
+ install -m0700 -o root -g root -d ${ROOT}/etc/samba/private
+ install -m1777 -o root -g root -d ${ROOT}/var/spool/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/log/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/run/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/cache/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/samba/{netlogon,profiles}
+ install -m0755 -o root -g root -d \
+ ${ROOT}/var/lib/samba/printers/{W32X86,WIN40,W32ALPHA,W32MIPS,W32PPC}
+}