summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-18 02:46:08 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-18 02:46:08 +0000
commit6e6581388bda78cfd1f62b65a8d11e0ebf025ef8 (patch)
tree1bcd6907374e924d40cb3b8dd994484e3d0bac7e /net-fs
parentadded mask for new build of autofs. Please test for proper OpenLDAP (diff)
downloadgentoo-2-6e6581388bda78cfd1f62b65a8d11e0ebf025ef8.tar.gz
gentoo-2-6e6581388bda78cfd1f62b65a8d11e0ebf025ef8.tar.bz2
gentoo-2-6e6581388bda78cfd1f62b65a8d11e0ebf025ef8.zip
New ebuild of autofs with OpenLDAP 2.x support. Also proper setting of
OPEN_MAX from linux/limits.h instead of a manual setting of variable as in previous ebuild. Please report your success/failure on bug report #2285
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog11
-rw-r--r--net-fs/autofs/autofs-3.1.7-r3.ebuild7
-rw-r--r--net-fs/autofs/files/ldap.diff14
-rw-r--r--net-fs/autofs/files/open_max.diff12
4 files changed, 41 insertions, 3 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index ead1ffb18841..950f434afa94 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-fsautofsChangeLog/
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.8 2002/07/17 03:11:56 lamer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.9 2002/07/18 02:46:08 raker Exp $
+
+*autofs-3.1.7-r4 (17 Jul 2002)
+
+ 17 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ autofs-3.1.7-r4, files/digest-autofs-3.1.7-r4 :
+
+ Patched autofs to correctly pull OPEN_MAX from linux/limits.h instead
+ of a manual setting of OPEN_MAX. Also patched for ldap 2.x support
+ setting ldap related variables that configure fails to do.
16 Jul 2002; Ben Lutgens <lamer@gentoo.org> files/autofs.rc6 :
diff --git a/net-fs/autofs/autofs-3.1.7-r3.ebuild b/net-fs/autofs/autofs-3.1.7-r3.ebuild
index f1a2cb2624d8..2e23099a899d 100644
--- a/net-fs/autofs/autofs-3.1.7-r3.ebuild
+++ b/net-fs/autofs/autofs-3.1.7-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-3.1.7-r3.ebuild,v 1.4 2002/07/17 09:52:23 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-3.1.7-r3.ebuild,v 1.5 2002/07/18 02:46:08 raker Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Kernel based automounter"
@@ -9,7 +9,7 @@ SRC_URI="ftp://ftp.kernel.org/pub/linux/daemons/autofs/${P}.tar.bz2
ftp://ftp.de.kernel.org/pub/linux/daemons/autofs/${P}.tar.bz2
ftp://ftp.uk.kernel.org/pub/linux/daemons/autofs/${P}.tar.bz2"
-DEPEND="ldap? ( ~net-nds/openldap-1.2 )"
+DEPEND="ldap? ( >=net-nds/openldap-1.2 )"
SLOT="0"
LICENSE="GPL-2"
@@ -23,6 +23,9 @@ src_unpack() {
src_compile() {
local myconf
use ldap || myconf="--without-openldap"
+ export HAVE_LDAP=1
+ export LIBLDAP="$LIBLDAP -lldap -llber"
+ export LIBS="-lldap -llber $LIBS"
./configure --host=${HOST} --prefix=/usr ${myconf} || die
emake || die
}
diff --git a/net-fs/autofs/files/ldap.diff b/net-fs/autofs/files/ldap.diff
new file mode 100644
index 000000000000..1c3fc0f2ffa1
--- /dev/null
+++ b/net-fs/autofs/files/ldap.diff
@@ -0,0 +1,14 @@
+diff -urN autofs-3.1.7/Makefile.conf autofs-3.1.7-modified/Makefile.conf
+--- autofs-3.1.7/Makefile.conf Wed Jul 17 21:28:35 2002
++++ autofs-3.1.7-modified/Makefile.conf Wed Jul 17 21:29:05 2002
+@@ -17,8 +17,8 @@
+ HESIOD_FLAGS =
+
+ # LDAP support: yes (1) no (0)
+-LDAP = 0
+-LIBLDAP=
++LDAP = 1
++LIBLDAP= -lldap -llber
+ LDAP_FLAGS =
+
+ # NIS+ support: yes (1) no (0)
diff --git a/net-fs/autofs/files/open_max.diff b/net-fs/autofs/files/open_max.diff
new file mode 100644
index 000000000000..c08d52a57f8c
--- /dev/null
+++ b/net-fs/autofs/files/open_max.diff
@@ -0,0 +1,12 @@
+diff -urN autofs-3.1.7/modules/lookup_program.c autofs-3.1.7-modified/modules/lookup_program.c
+--- autofs-3.1.7/modules/lookup_program.c Sat Nov 4 01:05:17 2000
++++ autofs-3.1.7-modified/modules/lookup_program.c Wed Jul 17 21:20:06 2002
+@@ -16,7 +16,7 @@
+
+ #include <ctype.h>
+ #include <errno.h>
+-#include <limits.h>
++#include <linux/limits.h>
+ #include <malloc.h>
+ #include <stdio.h>
+ #include <string.h>