summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-06-20 04:33:57 +0000
committerMike Frysinger <vapier@gentoo.org>2014-06-20 04:33:57 +0000
commit96615bf4708814220417325c7cb2bcd6e4be5403 (patch)
tree3604548a7cdfbd6e0aeb39049857151359eb0ffa /net-fs
parentdrop py2.6 pypy2_0, add IUSE examples, dep for tests, updrade test phase, clo... (diff)
downloadgentoo-2-96615bf4708814220417325c7cb2bcd6e4be5403.tar.gz
gentoo-2-96615bf4708814220417325c7cb2bcd6e4be5403.tar.bz2
gentoo-2-96615bf4708814220417325c7cb2bcd6e4be5403.zip
Unmount rpc.pipefs on stop as it is in /var #491714 by Jan Lam.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog5
-rw-r--r--net-fs/nfs-utils/files/rpc.pipefs.initd20
2 files changed, 18 insertions, 7 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index cfd69465ab75..592c3031b800 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.244 2014/05/21 15:58:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.245 2014/06/20 04:33:57 vapier Exp $
+
+ 20 Jun 2014; Mike Frysinger <vapier@gentoo.org> files/rpc.pipefs.initd:
+ Unmount rpc.pipefs on stop as it is in /var #491714 by Jan Lam.
21 May 2014; Justin Lecher <jlec@gentoo.org> nfs-utils-1.2.9-r3.ebuild,
metadata.xml:
diff --git a/net-fs/nfs-utils/files/rpc.pipefs.initd b/net-fs/nfs-utils/files/rpc.pipefs.initd
index 08467eed1ac0..ebae3b91582a 100644
--- a/net-fs/nfs-utils/files/rpc.pipefs.initd
+++ b/net-fs/nfs-utils/files/rpc.pipefs.initd
@@ -1,21 +1,23 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/rpc.pipefs.initd,v 1.2 2011/06/19 23:04:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/rpc.pipefs.initd,v 1.3 2014/06/20 04:33:57 vapier Exp $
+
+MNT="/var/lib/nfs/rpc_pipefs"
mount_pipefs() {
- local fstype=rpc_pipefs mntpoint=/var/lib/nfs/rpc_pipefs
+ local fstype=rpc_pipefs
# if things are already mounted, nothing to do
- mountinfo -q ${mntpoint} && return 0
+ mountinfo -q ${MNT} && return 0
# if rpc_pipefs is not available, try to load sunrpc for it #219566
grep -qs ${fstype} /proc/filesystems || modprobe -q sunrpc
# if still not available, the `mount` will issue an error for the user
# now just do it for kicks
- mkdir -p ${mntpoint}
- mount -t ${fstype} ${fstype} ${mntpoint}
+ mkdir -p ${MNT}
+ mount -t ${fstype} ${fstype} ${MNT}
}
start() {
@@ -23,3 +25,9 @@ start() {
mount_pipefs
eend $? "make sure you have NFS/SUNRPC enabled in your kernel"
}
+
+stop() {
+ ebegin "Unmounting RPC pipefs"
+ umount ${MNT}
+ eend $?
+}