summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-05-24 21:56:45 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-05-24 21:56:45 +0000
commitb349af1fff73d0f98fb39a9f68e7e799d12cc489 (patch)
treed17cc68f52d0d0c16c20d8cb682bb1ca6845eb1b /net-fs
parentAdd REE18 support (diff)
downloadgentoo-2-b349af1fff73d0f98fb39a9f68e7e799d12cc489.tar.gz
gentoo-2-b349af1fff73d0f98fb39a9f68e7e799d12cc489.tar.bz2
gentoo-2-b349af1fff73d0f98fb39a9f68e7e799d12cc489.zip
Fixing krbplugin install, and server examples location, bug #320953 , patch thanks to Honza Macháček <Hloupy.Honza@centrum.cz>
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog6
-rw-r--r--net-fs/samba/samba-3.5.3.ebuild40
2 files changed, 27 insertions, 19 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 0d7e36981437..decc16d3c409 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.418 2010/05/21 17:31:08 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.419 2010/05/24 21:56:45 vostorga Exp $
+
+ 24 May 2010; Víctor Ostorga <vostorga@gentoo.org> samba-3.5.3.ebuild:
+ Fixing krbplugin install, and server examples location, bug #320953 ,
+ patch thanks to Honza Macháček <Hloupy.Honza@centrum.cz>
21 May 2010; Víctor Ostorga <vostorga@gentoo.org> samba-3.5.3.ebuild:
Fixing build with USE=ads winbind, patch thanks to Rainer Ruecker
diff --git a/net-fs/samba/samba-3.5.3.ebuild b/net-fs/samba/samba-3.5.3.ebuild
index 5dcb775e3b4a..ab6d4a960b93 100644
--- a/net-fs/samba/samba-3.5.3.ebuild
+++ b/net-fs/samba/samba-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.5.3.ebuild,v 1.3 2010/05/21 17:31:08 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.5.3.ebuild,v 1.4 2010/05/24 21:56:45 vostorga Exp $
EAPI="2"
@@ -285,19 +285,21 @@ src_install() {
done
# install krbplugin
- if has_version app-crypt/mit-krb5 ; then
- insinto /usr/$(get_libdir)/krb5/plugins/libkrb5
- doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
- ${KRBPLUGIN}${PLUGINEXT} failed"
- elif has_version app-crypt/heimdal ; then
- insinto /usr/$(get_libdir)/plugin/krb5
- doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
- ${KRBPLUGIN}${PLUGINEXT} failed"
+ if [ -n "${KRBPLUGIN}" ] ; then
+ if has_version app-crypt/mit-krb5 ; then
+ insinto /usr/$(get_libdir)/krb5/plugins/libkrb5
+ doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
+ ${KRBPLUGIN}${PLUGINEXT} failed"
+ elif has_version app-crypt/heimdal ; then
+ insinto /usr/$(get_libdir)/plugin/krb5
+ doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
+ ${KRBPLUGIN}${PLUGINEXT} failed"
+ fi
+ insinto /usr
+ for prog in ${KRBPLUGIN} ; do
+ doman ../docs/manpages/${prog/bin\/}* || die "doman failed"
+ done
fi
- insinto /usr
- for prog in ${KRBPLUGIN} ; do
- doman ../docs/manpages/${prog/bin\/}* || die "doman failed"
- done
# install server components
if use server ; then
@@ -344,7 +346,9 @@ src_install() {
fi
# install the spooler to cups
- use cups && dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
+ if use cups ; then
+ dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
+ fi
# install misc files
insinto /etc/samba
@@ -362,7 +366,6 @@ src_install() {
# install examples
if use examples ; then
- einfo "install examples"
insinto /usr/share/doc/${PF}/examples
if use smbclient ; then
@@ -374,9 +377,10 @@ src_install() {
fi
if use server ; then
- doins -r \
- auth autofs dce-dfs LDAP logon misc pdb perfcounter \
- printer-accounting printing scripts tridge validchars VFS
+ cd ../examples
+ doins -r auth autofs dce-dfs LDAP logon misc pdb \
+ perfcounter printer-accounting printing scripts tridge \
+ validchars VFS
fi
fi