summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-07-18 21:56:22 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-07-18 21:56:22 +0000
commitbca79b205fc979545de4652c5b95548ec7fdefeb (patch)
tree1d4c4c28a7634e807a876b1fd89e1d7b0d1cd280 /net-fs
parentVersion bump for bug 91843; 2.4.1 stable on x86. Also removed unnecessary eut... (diff)
downloadgentoo-2-bca79b205fc979545de4652c5b95548ec7fdefeb.tar.gz
gentoo-2-bca79b205fc979545de4652c5b95548ec7fdefeb.tar.bz2
gentoo-2-bca79b205fc979545de4652c5b95548ec7fdefeb.zip
Version Bump, contains security fix bug 94071
(Portage version: 1.589-cvs)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/davfs2/ChangeLog8
-rw-r--r--net-fs/davfs2/davfs2-0.2.4.ebuild69
-rw-r--r--net-fs/davfs2/files/digest-davfs2-0.2.41
-rw-r--r--net-fs/davfs2/files/include-compiler.patch22
4 files changed, 99 insertions, 1 deletions
diff --git a/net-fs/davfs2/ChangeLog b/net-fs/davfs2/ChangeLog
index 441afc84a769..26cdf8c9902e 100644
--- a/net-fs/davfs2/ChangeLog
+++ b/net-fs/davfs2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/davfs2
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.12 2005/07/12 15:32:57 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.13 2005/07/18 21:56:22 genstef Exp $
+
+*davfs2-0.2.4 (18 Jul 2005)
+
+ 18 Jul 2005; Stefan Schweizer <genstef@gentoo.org>
+ +files/include-compiler.patch, +davfs2-0.2.4.ebuild:
+ Version Bump, contains security fix bug 94071
12 Jul 2005; Simon Stelling <blubb@gentoo.org>
+files/include_compiler.patch, davfs2-0.2.3-r1.ebuild:
diff --git a/net-fs/davfs2/davfs2-0.2.4.ebuild b/net-fs/davfs2/davfs2-0.2.4.ebuild
new file mode 100644
index 000000000000..b48c15c0705a
--- /dev/null
+++ b/net-fs/davfs2/davfs2-0.2.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-0.2.4.ebuild,v 1.1 2005/07/18 21:56:22 genstef Exp $
+
+inherit linux-info eutils
+
+DESCRIPTION="a Linux file system driver that allows you to mount a WebDAV server as a local disk drive. Davfs2 uses Coda for kernel driver and neon for WebDAV interface"
+SRC_URI="mirror://sourceforge/dav/${P}.tar.gz"
+HOMEPAGE="http://dav.sourceforge.net"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="ssl debug socks5"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ dev-libs/libxml2
+ net-misc/neon
+ sys-libs/zlib"
+SLOT="0"
+
+CONFIG_CHECK="CODA_FS"
+CODA_FS_ERROR="${P} requires kernel support for Coda to be found in filesystems, network filesystems"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/include-compiler.patch #81507
+}
+
+src_compile() {
+ local myconf
+
+ if use debug; then
+ myconf="--with-debug"
+ fi
+ if kernel_is 2 4; then
+ myconf="${myconf} --with-kernel-src=${KV_DIR}"
+ else
+ myconf="${myconf} --without-kernel-src"
+ fi
+
+ econf \
+ $(use_with ssl) \
+ $(use_with socks5 socks) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ einstall || die "einstall failed"
+
+ dodir /var/run/mount.davfs
+ keepdir /var/run/mount.davfs
+
+ dodoc BUGS ChangeLog davfs2.conf.template FAQ NEWS README secrets.template THANKS TODO
+ cd ${D}/usr/share
+ rm COPYING ChangeLog davfs2.conf.template FAQ NEWS README secrets.template THANKS TODO INSTALL
+
+ dodir /etc/modules.d
+ cat >${D}/etc/modules.d/davfs2 <<EOF
+alias char-major-67 coda
+alias /dev/davfs* coda
+EOF
+}
+
+pkg_postinst() {
+ update-modules
+}
diff --git a/net-fs/davfs2/files/digest-davfs2-0.2.4 b/net-fs/davfs2/files/digest-davfs2-0.2.4
new file mode 100644
index 000000000000..a78b524a35ee
--- /dev/null
+++ b/net-fs/davfs2/files/digest-davfs2-0.2.4
@@ -0,0 +1 @@
+MD5 f8f76634ddd7a26f0f277f86262887b6 davfs2-0.2.4.tar.gz 141438
diff --git a/net-fs/davfs2/files/include-compiler.patch b/net-fs/davfs2/files/include-compiler.patch
new file mode 100644
index 000000000000..995a8ec66a72
--- /dev/null
+++ b/net-fs/davfs2/files/include-compiler.patch
@@ -0,0 +1,22 @@
+diff -ur davfs2-0.2.4.orig/src/davfsd.c davfs2-0.2.4/src/davfsd.c
+--- davfs2-0.2.4.orig/src/davfsd.c 2005-07-18 23:09:23.000000000 +0200
++++ davfs2-0.2.4/src/davfsd.c 2005-07-18 23:09:48.000000000 +0200
+@@ -33,6 +33,7 @@
+ /* Linux Kernel Source */
+ /* avoid inclusion of kernel time.h, since it conflicts with userland time.h */
+ #define _LINUX_TIME_H
++#include <linux/compiler.h>
+ #include <linux/coda.h>
+
+ /* Neon */
+diff -ur davfs2-0.2.4.orig/src/davfsd.h davfs2-0.2.4/src/davfsd.h
+--- davfs2-0.2.4.orig/src/davfsd.h 2005-07-18 23:09:23.000000000 +0200
++++ davfs2-0.2.4/src/davfsd.h 2005-07-18 23:09:53.000000000 +0200
+@@ -25,6 +25,7 @@
+ /* Linux Kernel Source */
+ /* avoid inclusion of kernel time.h, since it conflicts with userland time.h */
+ #define _LINUX_TIME_H
++#include <linux/compiler.h>
+ #include <linux/coda.h>
+
+ #ifndef DIRBLKSIZ