summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-10-22 13:11:37 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-10-22 13:11:37 +0000
commite8073a1bcc05d7110334602717e2cee1b010fc12 (patch)
treeeaf0696da8ecb2b6d92543d5f4a933b1ad5a4f07 /net-ftp/filezilla
parentVersion bump (after a long time). (diff)
downloadgentoo-2-e8073a1bcc05d7110334602717e2cee1b010fc12.tar.gz
gentoo-2-e8073a1bcc05d7110334602717e2cee1b010fc12.tar.bz2
gentoo-2-e8073a1bcc05d7110334602717e2cee1b010fc12.zip
Version bump, handle symbolic links on servers
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/ChangeLog8
-rw-r--r--net-ftp/filezilla/filezilla-3.1.5.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index 538de2283c89..ba1939e3745c 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.22 2008/10/17 12:37:56 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.23 2008/10/22 13:11:37 voyageur Exp $
+
+*filezilla-3.1.5 (22 Oct 2008)
+
+ 22 Oct 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.1.5.ebuild:
+ Version bump, handle symbolic links on servers
*filezilla-3.1.4.1 (17 Oct 2008)
diff --git a/net-ftp/filezilla/filezilla-3.1.5.ebuild b/net-ftp/filezilla/filezilla-3.1.5.ebuild
new file mode 100644
index 000000000000..f19301ced4d4
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.1.5.ebuild,v 1.1 2008/10/22 13:11:37 voyageur Exp $
+
+WX_GTK_VER="2.8"
+
+inherit eutils multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-dns/libidn
+ >=x11-libs/wxGTK-2.8.9
+ >=app-admin/eselect-wxwidgets-0.7-r1"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4
+ >=sys-devel/gettext-0.11
+ >=net-libs/gnutls-2.0.4"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"
+
+ dodoc AUTHORS ChangeLog NEWS
+}