summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-05-29 14:00:06 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-05-29 14:00:06 +0000
commitb5981ea2cf9c0b64f36b663b6f96065621ef0cce (patch)
treee39cbc0d5ff44a4534708a2c9c5960c930242b57 /net-ftp/oftpd/oftpd-0.3.7-r4.ebuild
parentRemoving 3.2 versions (diff)
downloadgentoo-2-b5981ea2cf9c0b64f36b663b6f96065621ef0cce.tar.gz
gentoo-2-b5981ea2cf9c0b64f36b663b6f96065621ef0cce.tar.bz2
gentoo-2-b5981ea2cf9c0b64f36b663b6f96065621ef0cce.zip
Fix #97183 for real. The new init script had not been installed before.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/oftpd/oftpd-0.3.7-r4.ebuild')
-rw-r--r--net-ftp/oftpd/oftpd-0.3.7-r4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-ftp/oftpd/oftpd-0.3.7-r4.ebuild b/net-ftp/oftpd/oftpd-0.3.7-r4.ebuild
new file mode 100644
index 000000000000..0e90fea40bd1
--- /dev/null
+++ b/net-ftp/oftpd/oftpd-0.3.7-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/oftpd/oftpd-0.3.7-r4.ebuild,v 1.1 2009/05/29 14:00:05 rbu Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Secure, small, anonymous only ftpd"
+HOMEPAGE="http://www.time-travellers.org/oftpd"
+SRC_URI="http://www.time-travellers.org/oftpd/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-ftp/ftpbase"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Don't crash when using an unsupported address family, #159178.
+ epatch "${FILESDIR}"/oftpd-0.3.7-family.patch
+}
+
+src_configure() {
+ # local myconf
+ # ipv6 support busted according to lamer
+ # use ipv6 && myconf="${myconf} --enable-ipv6"
+ econf --bindir=/usr/sbin || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS FAQ NEWS README TODO
+ keepdir /home/ftp
+ newinitd "${FILESDIR}"/init.d.oftpd-r1 oftpd
+ newconfd "${FILESDIR}"/conf.d.oftpd-r1 oftpd
+}