summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2010-01-04 21:34:38 +0000
committerSven Wegener <swegener@gentoo.org>2010-01-04 21:34:38 +0000
commit335916b49306d7ce3c86ac05844698ec90d9619c (patch)
treef81479afaa2c803fec2d5d1c4cb60e3fd114d53f /net-ftp/tnftp/files
parentcddax is gone (diff)
downloadgentoo-2-335916b49306d7ce3c86ac05844698ec90d9619c.tar.gz
gentoo-2-335916b49306d7ce3c86ac05844698ec90d9619c.tar.bz2
gentoo-2-335916b49306d7ce3c86ac05844698ec90d9619c.zip
Version bump.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/tnftp/files')
-rw-r--r--net-ftp/tnftp/files/tnftp-20090606-glibc-2.8-ARG_MAX.patch4
-rw-r--r--net-ftp/tnftp/files/tnftp-20091122-as-needed.patch23
-rw-r--r--net-ftp/tnftp/files/tnftp-20091122-glibc-2.8-ARG_MAX.patch22
3 files changed, 47 insertions, 2 deletions
diff --git a/net-ftp/tnftp/files/tnftp-20090606-glibc-2.8-ARG_MAX.patch b/net-ftp/tnftp/files/tnftp-20090606-glibc-2.8-ARG_MAX.patch
index 8c0f91a069e8..5dd3748f5e6d 100644
--- a/net-ftp/tnftp/files/tnftp-20090606-glibc-2.8-ARG_MAX.patch
+++ b/net-ftp/tnftp/files/tnftp-20090606-glibc-2.8-ARG_MAX.patch
@@ -1,7 +1,7 @@
glibc-2.8 no loner provides the ARG_MAX macro.
---- tnftp-20090520/libnetbsd/glob.c
-+++ tnftp-20090520/libnetbsd/glob.c
+--- tnftp-20091122/libnetbsd/glob.c
++++ tnftp-20091122/libnetbsd/glob.c
@@ -55,6 +55,8 @@
* Number of matches in the current invocation of glob.
*/
diff --git a/net-ftp/tnftp/files/tnftp-20091122-as-needed.patch b/net-ftp/tnftp/files/tnftp-20091122-as-needed.patch
new file mode 100644
index 000000000000..3f70c6359387
--- /dev/null
+++ b/net-ftp/tnftp/files/tnftp-20091122-as-needed.patch
@@ -0,0 +1,23 @@
+--- tnftp-20091122/src/Makefile.am
++++ tnftp-20091122/src/Makefile.am
+@@ -22,9 +22,7 @@
+ -I$(top_srcdir) \
+ -I$(top_builddir)
+
+-tnftp_LDADD = \
+- ../libnetbsd/libnetbsd.la
+-
++tnftp_LDADD =
+
+ if USE_LIBEDIT
+ tnftp_CPPFLAGS += \
+@@ -34,6 +32,9 @@
+ ../libedit/libedit.la
+ endif
+
++tnftp_LDADD += \
++ ../libnetbsd/libnetbsd.la
++
+
+ man1_MANS = \
+ tnftp.1
diff --git a/net-ftp/tnftp/files/tnftp-20091122-glibc-2.8-ARG_MAX.patch b/net-ftp/tnftp/files/tnftp-20091122-glibc-2.8-ARG_MAX.patch
new file mode 100644
index 000000000000..5dd3748f5e6d
--- /dev/null
+++ b/net-ftp/tnftp/files/tnftp-20091122-glibc-2.8-ARG_MAX.patch
@@ -0,0 +1,22 @@
+glibc-2.8 no loner provides the ARG_MAX macro.
+
+--- tnftp-20091122/libnetbsd/glob.c
++++ tnftp-20091122/libnetbsd/glob.c
+@@ -55,6 +55,8 @@
+ * Number of matches in the current invocation of glob.
+ */
+
++#include <unistd.h>
++
+ #include "tnftp.h"
+
+ #undef TILDE /* XXX: AIX 4.1.5 has this in <sys/ioctl.h> */
+@@ -720,7 +722,7 @@
+ }
+ pathv[pglob->gl_offs + pglob->gl_pathc] = NULL;
+
+- if ((pglob->gl_flags & GLOB_LIMIT) && (newsize + *limit) >= ARG_MAX) {
++ if ((pglob->gl_flags & GLOB_LIMIT) && (newsize + *limit) >= sysconf(_SC_ARG_MAX)) {
+ errno = 0;
+ return(GLOB_NOSPACE);
+ }