summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2004-06-08 02:31:38 +0000
committerNick Hadaway <raker@gentoo.org>2004-06-08 02:31:38 +0000
commit12c13a75c18215b3bfc750459073ab10820818eb (patch)
treea68ef83a6f3eb1f07d6c86921149105023a3ca67 /net-ftp
parentAdding 50-r8 and modifying all headers to force the change. (Manifest recommit) (diff)
downloadgentoo-2-12c13a75c18215b3bfc750459073ab10820818eb.tar.gz
gentoo-2-12c13a75c18215b3bfc750459073ab10820818eb.tar.bz2
gentoo-2-12c13a75c18215b3bfc750459073ab10820818eb.zip
Initial import. A long time coming.
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pureadmin/ChangeLog9
-rw-r--r--net-ftp/pureadmin/Manifest2
-rw-r--r--net-ftp/pureadmin/files/digest-pureadmin-0.1.101
-rw-r--r--net-ftp/pureadmin/metadata.xml8
-rw-r--r--net-ftp/pureadmin/pureadmin-0.1.10.ebuild57
5 files changed, 77 insertions, 0 deletions
diff --git a/net-ftp/pureadmin/ChangeLog b/net-ftp/pureadmin/ChangeLog
new file mode 100644
index 000000000000..dc8f25a66098
--- /dev/null
+++ b/net-ftp/pureadmin/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-ftp/pureadmin
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.1 2004/06/08 02:31:38 raker Exp $
+
+*pureadmin-0.1.10 (07 Jun 2004)
+
+ 07 Jun 2004; Nick Hadaway <raker@gentoo.org> pureadmin-0.1.10.ebuild :
+ Initial import. The ebuild is based loosely on the entry submitted
+ on bug #45503.
diff --git a/net-ftp/pureadmin/Manifest b/net-ftp/pureadmin/Manifest
new file mode 100644
index 000000000000..04ca692a0bf2
--- /dev/null
+++ b/net-ftp/pureadmin/Manifest
@@ -0,0 +1,2 @@
+MD5 37c89b0fa9c873695fdeab39710ab7ff pureadmin-0.1.10.ebuild 974
+MD5 be1c1c77d4ffc790654176a4eabe1e8d files/digest-pureadmin-0.1.10 68
diff --git a/net-ftp/pureadmin/files/digest-pureadmin-0.1.10 b/net-ftp/pureadmin/files/digest-pureadmin-0.1.10
new file mode 100644
index 000000000000..70a09ac89cb4
--- /dev/null
+++ b/net-ftp/pureadmin/files/digest-pureadmin-0.1.10
@@ -0,0 +1 @@
+MD5 bc243bfcec09574a6e416f9468a982e0 pureadmin-0.1.10.tar.gz 197903
diff --git a/net-ftp/pureadmin/metadata.xml b/net-ftp/pureadmin/metadata.xml
new file mode 100644
index 000000000000..194b369637e4
--- /dev/null
+++ b/net-ftp/pureadmin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>raker@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-ftp/pureadmin/pureadmin-0.1.10.ebuild b/net-ftp/pureadmin/pureadmin-0.1.10.ebuild
new file mode 100644
index 000000000000..3fc69b8aa7ab
--- /dev/null
+++ b/net-ftp/pureadmin/pureadmin-0.1.10.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.1.10.ebuild,v 1.1 2004/06/08 02:31:38 raker Exp $
+
+IUSE="debug gnome"
+
+DESCRIPTION="PureAdmin is a GUI tool used to make the management of PureFTPd a little easier."
+HOMEPAGE="http://purify.sourceforge.net"
+SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/glibc
+ sys-libs/zlib
+ >=x11-libs/gtk+-2.0"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ # Move the docs to the correct location
+ dodoc ${D}usr/share/doc/pureadmin/*.txt
+ rm -rf ${D}usr/share/doc/pureadmin
+
+ # Add a desktop entry for gnome if requested
+ if [ `use gnome` ]; then
+ rm ${D}/usr/share/applications
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ insopts -m 0644
+ doins ${S}/tools/pureadmin.desktop
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "PureAdmin is at an alpha-stage right now and it may break"
+ ewarn "your configuration. DO NOT use it for safety critical system"
+ ewarn "or production use!"
+ echo
+ einfo "You need root-privileges to be able to use PureAdmin as for now."
+ einfo "This will probably change in the future."
+ echo
+}