summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-10 07:34:58 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-10 07:34:58 +0000
commit37f062f33549be68b8b0c5908ca9c32ded87eb88 (patch)
tree18498aacfd28c3b618446ed6750c9c2ba2775d14 /net-ftp
parentfix pid file writing (diff)
downloadgentoo-2-37f062f33549be68b8b0c5908ca9c32ded87eb88.tar.gz
gentoo-2-37f062f33549be68b8b0c5908ca9c32ded87eb88.tar.bz2
gentoo-2-37f062f33549be68b8b0c5908ca9c32ded87eb88.zip
sed expression fix
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftp/ChangeLog11
-rw-r--r--net-ftp/ftp/ftp-0.17-r1.ebuild10
-rw-r--r--net-ftp/ftp/ftp-0.17-r2.ebuild16
-rw-r--r--net-ftp/ftpd/ChangeLog7
-rw-r--r--net-ftp/ftpd/ftpd-0.17.ebuild22
5 files changed, 40 insertions, 26 deletions
diff --git a/net-ftp/ftp/ChangeLog b/net-ftp/ftp/ChangeLog
index 8beadddb5fc3..aca4ad535853 100644
--- a/net-ftp/ftp/ChangeLog
+++ b/net-ftp/ftp/ChangeLog
@@ -1,14 +1,19 @@
# ChangeLog for net-ftp/ftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ChangeLog,v 1.6 2003/02/08 23:21:09 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ChangeLog,v 1.7 2003/02/10 07:34:58 seemant Exp $
+
+*ftp-0.17-r2 (12 Nov 2002)
+
+ 09 Feb 2003; Seemant Kulleen <seemant@gentoo.org> *.ebuild :
+
+ Sed expression delimiters from / to :, closing bug #15006 by Blu3
+ <david+gentoo.org@blue-labs.org> and also changed to use epatch.
09 Feb 2003; Guy Martin <gmsoft@gentoo.org> ftp-0.17-r2.ebuild :
Added hppa to keywords.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-*ftp-0.17-r2 (12 Nov 2002)
-
05 Dec 2002; Nick Hadaway <raker@gentoo.org> ftp-0.17-r2.ebuild :
Marked stable.
diff --git a/net-ftp/ftp/ftp-0.17-r1.ebuild b/net-ftp/ftp/ftp-0.17-r1.ebuild
index 82b9a98427a2..7969938b878f 100644
--- a/net-ftp/ftp/ftp-0.17-r1.ebuild
+++ b/net-ftp/ftp/ftp-0.17-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r1.ebuild,v 1.14 2002/12/15 10:44:20 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r1.ebuild,v 1.15 2003/02/10 07:34:58 seemant Exp $
MY_P=netkit-${P}
S=${WORKDIR}/${MY_P}
@@ -8,18 +8,16 @@ DESCRIPTION="Standard Linux FTP client"
SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ppc sparc alpha"
src_compile() {
-
./configure --prefix=/usr || die
cp MCONFIG MCONFIG.orig
- sed -e "s/-pipe -O2/${CFLAGS}/" MCONFIG.orig > MCONFIG
+ sed -e "s:-pipe -O2:${CFLAGS}:" MCONFIG.orig > MCONFIG
make || die
}
diff --git a/net-ftp/ftp/ftp-0.17-r2.ebuild b/net-ftp/ftp/ftp-0.17-r2.ebuild
index 15f80ff3b36e..074a4ff39ef2 100644
--- a/net-ftp/ftp/ftp-0.17-r2.ebuild
+++ b/net-ftp/ftp/ftp-0.17-r2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r2.ebuild,v 1.5 2003/02/08 23:21:09 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r2.ebuild,v 1.6 2003/02/10 07:34:58 seemant Exp $
+
+inherit eutils
MY_P=netkit-${P}
S=${WORKDIR}/${MY_P}
@@ -8,9 +10,9 @@ DESCRIPTION="Standard Linux FTP client with optional SSL support"
SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
+DEPEND=">=sys-libs/ncurses-5.2
ssl? ( dev-libs/openssl )"
+
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ppc sparc alpha hppa"
@@ -20,14 +22,14 @@ src_unpack() {
cd ${S}
if [ "`use ssl`" ]; then
- patch -p1 < ${FILESDIR}/${MY_P}+ssl-0.2.diff || die "ssl patch failed"
- fi
+ epatch ${FILESDIR}/${MY_P}+ssl-0.2.diff
+ fi
}
src_compile() {
./configure --prefix=/usr || die
cp MCONFIG MCONFIG.orig
- sed -e "s/-pipe -O2/${CFLAGS}/" MCONFIG.orig > MCONFIG
+ sed -e "s:-pipe -O2:${CFLAGS}:" MCONFIG.orig > MCONFIG
emake || die
}
diff --git a/net-ftp/ftpd/ChangeLog b/net-ftp/ftpd/ChangeLog
index 4e5b3ef3c93a..b7dbd5d938f4 100644
--- a/net-ftp/ftpd/ChangeLog
+++ b/net-ftp/ftpd/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-ftp/ftpd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ChangeLog,v 1.4 2003/01/16 02:25:11 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ChangeLog,v 1.5 2003/02/10 07:34:58 seemant Exp $
*ftpd-0.17 (25 Nov 2002)
+ 09 Feb 2003; Seemant Kulleen <seemant@gentoo.org> ftpd-0.17.ebuild :
+
+ Sed expression delimiter from / to :, closing bug #15006 by Blu3
+ <david+gentoo.org@blue-labs.org>
+
15 Jan 2003; Nick Hadaway <raker@gentoo.org> ftpd-0.17.ebuild :
Fixed a typo in postinst and added xinetd as an RDEPEND and now
installing an /etc/xinetd.d/ftp. Also changed to epatch.
diff --git a/net-ftp/ftpd/ftpd-0.17.ebuild b/net-ftp/ftpd/ftpd-0.17.ebuild
index b3a7eca9db12..339baff05ea8 100644
--- a/net-ftp/ftpd/ftpd-0.17.ebuild
+++ b/net-ftp/ftpd/ftpd-0.17.ebuild
@@ -1,33 +1,37 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ftpd-0.17.ebuild,v 1.4 2003/01/16 02:25:11 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpd/ftpd-0.17.ebuild,v 1.5 2003/02/10 07:34:58 seemant Exp $
+inherit eutils
+
+IUSE="ssl"
+
+S=${WORKDIR}/linux-${P}
DESCRIPTION="The netkit FTP server with optional SSL support"
HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/linux-${P}.tar.gz"
-LICENSE="as-is"
+
SLOT="0"
+LICENSE="as-is"
KEYWORDS="x86"
-IUSE="ssl"
-DEPEND="virtual/glibc
- ssl? ( dev-libs/openssl )"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
RDEPEND="${DEPEND}
sys-apps/xinetd"
-S=${WORKDIR}/linux-${P}
-inherit eutils
src_unpack() {
unpack ${A}
cd ${S}
if [ "`use ssl`" ]; then
- epatch ${FILESDIR}/ssl.diff.gz || die
+ epatch ${FILESDIR}/ssl.diff.gz
fi
}
src_compile() {
./configure --prefix=/usr || die "configure failed"
cp MCONFIG MCONFIG.orig
- sed -e "s/-pipe -O2/${CFLAGS}/" MCONFIG.orig > MCONFIG
+ sed -e "s:-pipe -O2:${CFLAGS}:" MCONFIG.orig > MCONFIG
emake || die "parallel make failed"
}