summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-05-07 14:11:18 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-05-07 14:11:18 +0000
commit4831af2ad890d538e9f825c16d35dba6706e72a8 (patch)
treec96010d3111fb791a69a84e3dc8d7fc2033b19ab /net-ftp
parentFix compile with GCC 4.4 (diff)
downloadgentoo-2-4831af2ad890d538e9f825c16d35dba6706e72a8.tar.gz
gentoo-2-4831af2ad890d538e9f825c16d35dba6706e72a8.tar.bz2
gentoo-2-4831af2ad890d538e9f825c16d35dba6706e72a8.zip
Revision bump for >=net-libs/gnutls-2.7 support, switch to EAPI 2, closes bug #268583
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/ChangeLog9
-rw-r--r--net-ftp/filezilla/files/filezilla-3.2.4.1-gnutls-2.7.patch11
-rw-r--r--net-ftp/filezilla/filezilla-3.2.4.1-r1.ebuild50
3 files changed, 69 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index 1b6dd9e1e8b3..476ad03706a1 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.42 2009/05/04 12:03:08 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.43 2009/05/07 14:11:18 voyageur Exp $
+
+*filezilla-3.2.4.1-r1 (07 May 2009)
+
+ 07 May 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.2.4.1-r1.ebuild, +files/filezilla-3.2.4.1-gnutls-2.7.patch:
+ Revision bump for >=net-libs/gnutls-2.7 support, switch to EAPI 2, closes
+ bug #268583
04 May 2009; Bernard Cafarelli <voyageur@gentoo.org>
-filezilla-3.1.3.1.ebuild, -filezilla-3.1.4.1.ebuild,
diff --git a/net-ftp/filezilla/files/filezilla-3.2.4.1-gnutls-2.7.patch b/net-ftp/filezilla/files/filezilla-3.2.4.1-gnutls-2.7.patch
new file mode 100644
index 000000000000..7e9dbfa260b5
--- /dev/null
+++ b/net-ftp/filezilla/files/filezilla-3.2.4.1-gnutls-2.7.patch
@@ -0,0 +1,11 @@
+--- configure.in.orig 2009-05-07 15:27:48.000000000 +0200
++++ configure.in 2009-05-07 15:33:53.000000000 +0200
+@@ -319,7 +319,7 @@
+ # GnuTLS
+ # ------
+
+- AM_PATH_LIBGNUTLS(2.0.4,, AC_MSG_ERROR([[
++ PKG_CHECK_MODULES(LIBGNUTLS, gnutls >= 2.0.4,, AC_MSG_ERROR([[
+ ***
+ *** libgnutls 2.0.4 or greater was not found. You may want to get it from
+ *** ftp://ftp.gnutls.org/pub/gnutls/]]))
diff --git a/net-ftp/filezilla/filezilla-3.2.4.1-r1.ebuild b/net-ftp/filezilla/filezilla-3.2.4.1-r1.ebuild
new file mode 100644
index 000000000000..4fdad7b47a45
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.2.4.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.2.4.1-r1.ebuild,v 1.1 2009/05/07 14:11:18 voyageur Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit autotools eutils multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="dbus test"
+
+RDEPEND="net-dns/libidn
+ >=x11-libs/wxGTK-2.8.9
+ >=app-admin/eselect-wxwidgets-0.7-r1
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4
+ >=sys-devel/gettext-0.11
+ >=net-libs/gnutls-2.0.4
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gnutls-2.7.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) --disable-autoupdatecheck || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"
+
+ dodoc AUTHORS ChangeLog NEWS
+}