summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-04-11 16:15:52 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-04-11 16:15:52 +0000
commit6e063927c1cc792884fe515f1521ea87b471d012 (patch)
tree460e63b019b5c17452f551a0cb2afffbc7ef16be /net-ftp
parentAdded ruby.eclass support (Manifest recommit) (diff)
downloadgentoo-2-6e063927c1cc792884fe515f1521ea87b471d012.tar.gz
gentoo-2-6e063927c1cc792884fe515f1521ea87b471d012.tar.bz2
gentoo-2-6e063927c1cc792884fe515f1521ea87b471d012.zip
Version bump. Closes #46598
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/Manifest10
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.0.11
-rw-r--r--net-ftp/lftp/lftp-3.0.1.ebuild52
4 files changed, 65 insertions, 5 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index ce7b7e6b6ab1..04f6a59839d0 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.38 2004/03/27 05:48:18 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.39 2004/04/11 16:15:51 zx Exp $
+
+*lftp-3.0.1 (11 Apr 2004)
+
+ 11 Apr 2004; Chris Aniszczyk <zx@gentoo.org> lftp-3.0.1.ebuild:
+ Version bump. Closes #46598
30 Mar 2004; Chris Aniszczyk <zx@gentoo.org> lftp-2.6.10.ebuild,
metadata.xml:
diff --git a/net-ftp/lftp/Manifest b/net-ftp/lftp/Manifest
index 519cbc0e260d..f89259b774b6 100644
--- a/net-ftp/lftp/Manifest
+++ b/net-ftp/lftp/Manifest
@@ -1,6 +1,8 @@
+MD5 877fe5dcaad2b3010699d460ac0c526c lftp-2.6.10.ebuild 1336
+MD5 e176405caee5b9de4a00be381f9497cf lftp-2.6.11.ebuild 1341
+MD5 dde767127b8d685d2654dc75f804cf46 ChangeLog 5723
+MD5 2785f01da3c8ca5f05936ecd5e8f675e lftp-3.0.1.ebuild 1252
+MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 0000187694fd92f30e8669216ab2d7a4 files/digest-lftp-2.6.10 65
MD5 d640fa2520c5748b7ebfba9feeae8f91 files/digest-lftp-2.6.11 65
-MD5 90615da868f3fe014830744314985960 ChangeLog 5724
-MD5 29eda9443194cd2b1a021c07fdfb83b2 lftp-2.6.10.ebuild 1337
-MD5 6923f2acfefeb8751f3c93988de7c771 lftp-2.6.11.ebuild 1342
-MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
+MD5 f3f81fdb1ae3f2163617edfdffc9229a files/digest-lftp-3.0.1 64
diff --git a/net-ftp/lftp/files/digest-lftp-3.0.1 b/net-ftp/lftp/files/digest-lftp-3.0.1
new file mode 100644
index 000000000000..0bb9ceda2b73
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.0.1
@@ -0,0 +1 @@
+MD5 1417136e92a01218b9500615ee6855c6 lftp-3.0.1.tar.bz2 1213419
diff --git a/net-ftp/lftp/lftp-3.0.1.ebuild b/net-ftp/lftp/lftp-3.0.1.ebuild
new file mode 100644
index 000000000000..a51dd96bf668
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.0.1.ebuild,v 1.1 2004/04/11 16:15:51 zx Exp $
+
+IUSE="ssl socks5 nls"
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc sparc ~alpha ~hppa ~mips ~ia64"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )
+ alpha? ( dev-lang/perl )
+ alpha? ( >=sys-apps/sed-4 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf}
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}