summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-05-13 02:48:26 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-05-13 02:48:26 +0000
commit6f5a44fb0bdb2b0d45be8a780ddeba52317a1305 (patch)
tree1d2729577a251079c4965fee86bc932575db534c /net-ftp
parentCommented invalid syntax (lone xinerama) (diff)
downloadgentoo-2-6f5a44fb0bdb2b0d45be8a780ddeba52317a1305.tar.gz
gentoo-2-6f5a44fb0bdb2b0d45be8a780ddeba52317a1305.tar.bz2
gentoo-2-6f5a44fb0bdb2b0d45be8a780ddeba52317a1305.zip
version bump in bug #49983
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.0.31
-rw-r--r--net-ftp/lftp/lftp-3.0.3.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 73675b4cf031..f9c74a84d496 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.41 2004/04/26 04:43:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.42 2004/05/13 02:48:26 dragonheart Exp $
+
+*lftp-3.0.3 (13 May 2004)
+
+ 13 May 2004; Daniel Black <dragonheart@gentoo.org> +lftp-3.0.3.ebuild:
+ version bump in bug #49983
26 Apr 2004; Aron Griffis <agriffis@gentoo.org> lftp-2.6.10.ebuild,
lftp-2.6.11.ebuild, lftp-3.0.1.ebuild, lftp-3.0.2.ebuild:
diff --git a/net-ftp/lftp/files/digest-lftp-3.0.3 b/net-ftp/lftp/files/digest-lftp-3.0.3
new file mode 100644
index 000000000000..4c9982780be7
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.0.3
@@ -0,0 +1 @@
+MD5 ee346d91ecd280a8e7f6ea406ceed144 lftp-3.0.3.tar.bz2 1214354
diff --git a/net-ftp/lftp/lftp-3.0.3.ebuild b/net-ftp/lftp/lftp-3.0.3.ebuild
new file mode 100644
index 000000000000..52aecc6408d7
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.0.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.0.3.ebuild,v 1.1 2004/05/13 02:48:26 dragonheart Exp $
+
+IUSE="ssl socks5 nls"
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )
+ alpha? ( dev-lang/perl )
+ alpha? ( >=sys-apps/sed-4 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf} || die "econf failed"
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}