summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-08-04 02:24:05 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-08-04 02:24:05 +0000
commit885d641ae7b562493ab92d277f999f6cffc4bce8 (patch)
tree2fdea652bc43c144a91f6bb50542f9eb357c137c /net-ftp
parentupdated version contributed by markus-krainer@chello.at (Markus Krainer) (diff)
downloadgentoo-2-885d641ae7b562493ab92d277f999f6cffc4bce8.tar.gz
gentoo-2-885d641ae7b562493ab92d277f999f6cffc4bce8.tar.bz2
gentoo-2-885d641ae7b562493ab92d277f999f6cffc4bce8.zip
xinetd file and minor fixes
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/proftpd/ChangeLog10
-rw-r--r--net-ftp/proftpd/files/digest-proftpd-1.2.6_rc1-r11
-rw-r--r--net-ftp/proftpd/files/proftpd.xinetd15
-rw-r--r--net-ftp/proftpd/proftpd-1.2.6_rc1-r1.ebuild104
4 files changed, 129 insertions, 1 deletions
diff --git a/net-ftp/proftpd/ChangeLog b/net-ftp/proftpd/ChangeLog
index b729716aff67..1134c7f9be61 100644
--- a/net-ftp/proftpd/ChangeLog
+++ b/net-ftp/proftpd/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for net-ftp/proftpd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.8 2002/07/19 16:08:39 nitro Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.9 2002/08/04 02:24:05 blocke Exp $
+*proftpd-1.2.6_rc1-r1 (03 Aug 2002)
+
+ 03 Aug 2002; Bruce A. Locke <blocke@shivan.org> proftpd-1.2.6_rc1-r1.ebuild,
+ files/digest-proftpd-1.2.6_rc1-r1:
+
+ Added xinetd file contributed by alextxm@tin.it (Alessandro Pisani) and
+ fixed minor directory and documentation buglets
+
*proftpd-1.2.6_rc1 (19 Jul 2002)
19 Jul 2002; Kyle Manna <nitro@gentoo.org> proftpd-1.2.6_rc1.ebuild
diff --git a/net-ftp/proftpd/files/digest-proftpd-1.2.6_rc1-r1 b/net-ftp/proftpd/files/digest-proftpd-1.2.6_rc1-r1
new file mode 100644
index 000000000000..07de557fe643
--- /dev/null
+++ b/net-ftp/proftpd/files/digest-proftpd-1.2.6_rc1-r1
@@ -0,0 +1 @@
+MD5 8bbe9e82cbcde203edfbf6dfc0562b71 proftpd-1.2.6rc1.tar.bz2 565290
diff --git a/net-ftp/proftpd/files/proftpd.xinetd b/net-ftp/proftpd/files/proftpd.xinetd
new file mode 100644
index 000000000000..282400d75d30
--- /dev/null
+++ b/net-ftp/proftpd/files/proftpd.xinetd
@@ -0,0 +1,15 @@
+#
+# ProFTPd FTP daemon - http://www.proftpd.org
+#
+service ftp
+{
+ flags = REUSE
+ socket_type = stream
+ instances = 30
+ wait = no
+ user = root
+ server = /usr/sbin/proftpd
+ log_on_success = HOST PID
+ log_on_failure = HOST RECORD
+ disable = yes
+}
diff --git a/net-ftp/proftpd/proftpd-1.2.6_rc1-r1.ebuild b/net-ftp/proftpd/proftpd-1.2.6_rc1-r1.ebuild
new file mode 100644
index 000000000000..8ea2f4f266b8
--- /dev/null
+++ b/net-ftp/proftpd/proftpd-1.2.6_rc1-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.6_rc1-r1.ebuild,v 1.1 2002/08/04 02:24:05 blocke Exp $
+
+PV=1.2.6rc1
+P=${PN}-${PV}
+S=${WORKDIR}/${P}
+
+DESCRIPTION="An advanced and very configurable FTP server"
+SRC_URI="ftp://ftp.proftpd.org/distrib/source/${P}.tar.bz2"
+HOMEPAGE="http://www.proftpd.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+
+src_unpack() {
+
+#Fix bug #3791
+
+ unpack ${P}.tar.bz2
+ cd ${WORKDIR}/${P}
+ patch contrib/mod_sql_postgres.c < ${FILESDIR}/mod_sql_postgres.c.patch || die "config patch failed"
+}
+
+src_compile() {
+ local modules myconf
+
+ modules="mod_ratio:mod_readme:mod_linuxprivs"
+ use pam && modules="${modules}:mod_pam"
+ use ldap && modules="${modules}:mod_ldap"
+
+ if [ "`use mysql`" ] ; then
+ modules="${modules}:mod_sql:mod_sql_mysql"
+ elif [ "`use postgres`" ] ; then
+ modules="${modules}:mod_sql:mod_sql_postgres"
+ myconf="--with-includes=/usr/include/postgresql"
+ fi
+
+ use ldap && export LDFLAGS="-lresolv"
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/sbin \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/run \
+ --sysconfdir=/etc/proftpd \
+ --enable-shadow \
+ --disable-sendfile \
+ --enable-autoshadow \
+ --with-modules=${modules} \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ #Note rundir needs to be specified to avoid sanbox violation
+ #on initial install. See Make.rules
+ make \
+ prefix=${D}/usr \
+ sbindir=${D}/usr/sbin \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/run \
+ rundir=${D}/var/run/proftpd \
+ sysconfdir=${D}/etc/proftpd \
+ install || die
+
+ #dobin contrib/genuser.pl
+ dodir /home/ftp
+ touch ${D}/home/ftp/.keep
+
+ touch ${D}/var/run/proftpd/.keep
+
+ dodoc contrib/README.mod_sql ${FILESDIR}/proftpd.conf \
+ COPYING CREDITS ChangeLog NEWS README* \
+ doc/{license.txt,GetConf}
+ dohtml doc/*.html
+ docinto rfc
+ dodoc doc/rfc/*.txt
+
+ cd ${D}/etc/proftpd
+ mv proftpd.conf proftpd.conf.distrib
+
+ insinto /etc/proftpd
+ newins ${FILESDIR}/proftpd.conf proftpd.conf.sample
+
+ if [ "`use pam`" ] ; then
+ insinto /etc/pam.d
+ newins ${S}/contrib/dist/rpm/ftp.pamd ftp
+ fi
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/proftpd.xinetd proftpd
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/proftpd.rc6 proftpd
+}