summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-03-17 18:34:48 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-03-17 18:34:48 +0000
commit8dc4f9f9d9fffeb9dbe7bf797ea3ae4fa67e5766 (patch)
tree4ebfa3bd1a148b643f0b57a6aae16d5eaf452e53 /net-ftp
parentVersion bumped. closes #17658. (diff)
downloadgentoo-2-8dc4f9f9d9fffeb9dbe7bf797ea3ae4fa67e5766.tar.gz
gentoo-2-8dc4f9f9d9fffeb9dbe7bf797ea3ae4fa67e5766.tar.bz2
gentoo-2-8dc4f9f9d9fffeb9dbe7bf797ea3ae4fa67e5766.zip
Version bumped. Ebuild submitted in #17666 by bugsubmit@snerk.org
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/proftpd/ChangeLog11
-rw-r--r--net-ftp/proftpd/files/digest-proftpd-1.2.81
-rw-r--r--net-ftp/proftpd/proftpd-1.2.8.ebuild113
3 files changed, 122 insertions, 3 deletions
diff --git a/net-ftp/proftpd/ChangeLog b/net-ftp/proftpd/ChangeLog
index 7bfc41f26bd2..ed9da07c9a94 100644
--- a/net-ftp/proftpd/ChangeLog
+++ b/net-ftp/proftpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/proftpd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.23 2003/03/05 15:30:02 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.24 2003/03/17 18:34:48 mholzer Exp $
+
+*proftpd-1.2.8 (17 Mar 2003)
+
+ 17 Mar 2003; Martin Holzer <mholzer@gentoo.org> proftpd-1.2.8.ebuild:
+ Version bumped. Ebuild submitted in #17666 by bugsubmit@snerk.org
+
+*proftpd-1.2.7 (15 Dec 2002)
17 Jan 2003; Daniel Ahlberg <aliz@gentoo.org> files/proftpd.conf :
Closes #13734.
@@ -8,8 +15,6 @@
15 Dec 2002; Daniel Ahlberg <aliz@gentoo.org> proftpd-1.2.7.ebuild :
Marked as stable.
-*proftpd-1.2.7 (15 Dec 2002)
-
05 Mar 2003; Will Woods <wwoods@gentoo.org> proftpd-1.2.7.ebuild:
Added alpha to KEYWORDS
diff --git a/net-ftp/proftpd/files/digest-proftpd-1.2.8 b/net-ftp/proftpd/files/digest-proftpd-1.2.8
new file mode 100644
index 000000000000..df77a27525df
--- /dev/null
+++ b/net-ftp/proftpd/files/digest-proftpd-1.2.8
@@ -0,0 +1 @@
+MD5 35e669cb085879eea21c6db9e7af2040 proftpd-1.2.8.tar.bz2 746193
diff --git a/net-ftp/proftpd/proftpd-1.2.8.ebuild b/net-ftp/proftpd/proftpd-1.2.8.ebuild
new file mode 100644
index 000000000000..6dd799107392
--- /dev/null
+++ b/net-ftp/proftpd/proftpd-1.2.8.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.8.ebuild,v 1.1 2003/03/17 18:34:48 mholzer Exp $
+
+IUSE="ldap pam postgres mysql ssl tcpd"
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An advanced and very configurable FTP server"
+SRC_URI="ftp://ftp.proftpd.org/distrib/source/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.proftpd.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~hppa ~alpha ~ppc"
+
+DEPEND="net-libs/libpcap
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r3 )"
+
+src_unpack() {
+
+ unpack ${MY_P}.tar.bz2
+
+ cd ${S}
+}
+
+
+src_compile() {
+ local modules myconf
+
+ modules="mod_ratio:mod_readme"
+ use pam && modules="${modules}:mod_auth_pam"
+ use tcpd && modules="${modules}:mod_wrap"
+
+ if use ldap; then
+ einfo ldap
+ modules="${modules}:mod_ldap"
+ export LDFLAGS="-lresolv"
+ fi
+
+ if use ssl; then
+ einfo ssl
+
+ # enable mod_tls
+ modules="${modules}:mod_tls"
+ fi
+
+ if use mysql; then
+ modules="${modules}:mod_sql:mod_sql_mysql"
+ elif use postgres; then
+ modules="${modules}:mod_sql:mod_sql_postgres"
+ myconf="--with-includes=/usr/include/postgresql"
+ fi
+
+ econf \
+ --sbindir=/usr/sbin \
+ --localstatedir=/var/run \
+ --sysconfdir=/etc/proftpd \
+ --enable-shadow \
+ --disable-sendfile \
+ --enable-autoshadow \
+ --with-modules=${modules} \
+ ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install() {
+ # Note rundir needs to be specified to avoid sandbox violation
+ # on initial install. See Make.rules
+ einstall \
+ sbindir=${D}/usr/sbin \
+ localstatedir=${D}/var/run \
+ rundir=${D}/var/run/proftpd \
+ sysconfdir=${D}/etc/proftpd \
+ || die
+
+ keepdir /home/ftp
+ keepdir /var/run/proftpd
+
+ dodoc contrib/README.mod_sql ${FILESDIR}/proftpd.conf \
+ COPYING CREDITS ChangeLog NEWS README* \
+ doc/{license.txt,GetConf}
+ dohtml doc/*.html
+ docinto rfc
+ dodoc doc/rfc/*.txt
+
+ mv ${D}/etc/proftpd/proftpd.conf ${D}/etc/proftpd/proftpd.conf.distrib
+
+ insinto /etc/proftpd
+ newins ${FILESDIR}/proftpd.conf proftpd.conf.sample
+
+ if use pam; then
+ insinto /etc/pam.d
+ newins ${S}/contrib/dist/rpm/ftp.pamd ftp
+ fi
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/proftpd.xinetd proftpd
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/proftpd.rc6 proftpd
+}
+
+pkg_postinst() {
+ groupadd proftpd &>/dev/null
+ id proftpd &>/dev/null || \
+ useradd -g proftpd -d /home/ftp -s /bin/false proftpd
+}