summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-07-06 04:23:41 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-07-06 04:23:41 +0000
commit9153578ba13d6a02a1f3ac28a61cc7a2f78fc18e (patch)
tree056326b2b6b07d86a7b5e062eaa30a7bc4aec30b /net-ftp
parentStable x86 (diff)
downloadgentoo-2-9153578ba13d6a02a1f3ac28a61cc7a2f78fc18e.tar.gz
gentoo-2-9153578ba13d6a02a1f3ac28a61cc7a2f78fc18e.tar.bz2
gentoo-2-9153578ba13d6a02a1f3ac28a61cc7a2f78fc18e.zip
version bump
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.5.13
-rw-r--r--net-ftp/lftp/lftp-3.5.1.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 27b02138e6ff..e244c0c2fcc7 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.107 2006/06/26 02:34:02 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.108 2006/07/06 04:23:41 dragonheart Exp $
+
+*lftp-3.5.1 (06 Jul 2006)
+
+ 06 Jul 2006; Daniel Black <dragonheart@gentoo.org> +lftp-3.5.1.ebuild:
+ version bump
26 Jun 2006; Javier Villavicencio <the_paya@gentoo.org> lftp-3.4.6.ebuild:
Add ~x86-fbsd keyword.
diff --git a/net-ftp/lftp/files/digest-lftp-3.5.1 b/net-ftp/lftp/files/digest-lftp-3.5.1
new file mode 100644
index 000000000000..44f275690471
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.5.1
@@ -0,0 +1,3 @@
+MD5 d2bafc5c3758b7745ac8463a75c17d3e lftp-3.5.1.tar.gz 1740768
+RMD160 3e7f50635978a936acc89a4e300d2bab9cc57ff0 lftp-3.5.1.tar.gz 1740768
+SHA256 3ebdbfef681d8d8859d7d415ccfadc012bd08ce88de69f104c1d202661e1a634 lftp-3.5.1.tar.gz 1740768
diff --git a/net-ftp/lftp/lftp-3.5.1.ebuild b/net-ftp/lftp/lftp-3.5.1.ebuild
new file mode 100644
index 000000000000..c5f86a60adca
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.5.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.5.1.ebuild,v 1.1 2006/07/06 04:23:41 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+
+#SRC_URI="http://the.wiretapped.net/mirrors/lftp/${P}.tar.bz2"
+# Was a bit too slow and unreliable last time I tried (dragonheart)
+SRC_URI="ftp://lftp.yar.ru/lftp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? ( >=net-proxy/dante-1.1.12 )
+ socks5? ( virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ !ppc-macos? ( >=sys-libs/readline-5.1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+
+src_compile() {
+ local myconf="$(use_enable nls)"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ use ppc-macos && myconf="${myconf} --with-included-readline"
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}