summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-05-20 13:27:34 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-05-20 13:27:34 +0000
commita1b02681134807ba1be71912c0a70347651e914e (patch)
treead7f69d4b392c89747f5aeb734df9247ff190f01 /net-ftp
parentVersion bump by Christian Strahl (bug 548682). (diff)
downloadgentoo-2-a1b02681134807ba1be71912c0a70347651e914e.tar.gz
gentoo-2-a1b02681134807ba1be71912c0a70347651e914e.tar.bz2
gentoo-2-a1b02681134807ba1be71912c0a70347651e914e.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/ChangeLog8
-rw-r--r--net-ftp/filezilla/filezilla-3.11.0.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index d016a8119993..fa60d07be525 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.123 2015/03/31 20:01:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.124 2015/05/20 13:27:34 voyageur Exp $
+
+*filezilla-3.11.0 (20 May 2015)
+
+ 20 May 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.11.0.ebuild:
+ Version bump
31 Mar 2015; Ulrich Müller <ulm@gentoo.org> filezilla-3.7.3.ebuild,
filezilla-3.8.1.ebuild, filezilla-3.9.0.5.ebuild, filezilla-3.9.0.6.ebuild,
diff --git a/net-ftp/filezilla/filezilla-3.11.0.ebuild b/net-ftp/filezilla/filezilla-3.11.0.ebuild
new file mode 100644
index 000000000000..0b4c9d983f8d
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.11.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.11.0.ebuild,v 1.1 2015/05/20 13:27:34 voyageur Exp $
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE="aqua dbus nls test"
+
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-db/sqlite-3.7
+ >=dev-libs/tinyxml-2.6.1-r1[stl]
+ net-dns/libidn
+ >=net-libs/gnutls-3.1.12
+ aqua? ( >=x11-libs/wxGTK-3.0.2.0-r1:3.0[aqua] )
+ !aqua? ( >=x11-libs/wxGTK-3.0.2.0-r1:3.0[X] x11-misc/xdg-utils )
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.10.2-debug.patch
+ append-cppflags -DTIXML_USE_STL
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-tinyxml=system \
+ --disable-autoupdatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ doicon src/interface/resources/48x48/${PN}.png
+
+ dodoc AUTHORS ChangeLog NEWS
+
+ if use aqua ; then
+ cat > "${T}/${PN}" <<-EOF
+ #!${EPREFIX}/bin/bash
+ open "${EPREFIX}"/Applications/FileZilla.app
+ EOF
+ rm "${ED}/usr/bin/${PN}" || die
+ dobin "${T}/${PN}"
+ insinto /Applications
+ doins -r "${S}"/FileZilla.app
+ fi
+}