summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-02-20 09:19:05 +0000
committerPeter Volkov <pva@gentoo.org>2008-02-20 09:19:05 +0000
commite14d2916f9cebbbf36c2ce79d068e643bff1a620 (patch)
tree2e9fcf258c95d1bd27da1bfccadc0dbb026d0809 /net-ftp
parentFixed compilation problem repoted by Andrew Cowie <andrew AT operationaldynam... (diff)
downloadgentoo-2-e14d2916f9cebbbf36c2ce79d068e643bff1a620.tar.gz
gentoo-2-e14d2916f9cebbbf36c2ce79d068e643bff1a620.tar.bz2
gentoo-2-e14d2916f9cebbbf36c2ce79d068e643bff1a620.zip
Fixed filtering out of LDFLAGS, bug 209740, thank you Diego Pettenò! Compiler is now set correctly.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/netkit-tftp/ChangeLog9
-rw-r--r--net-ftp/netkit-tftp/netkit-tftp-0.17-r3.ebuild10
-rw-r--r--net-ftp/netkit-tftp/netkit-tftp-0.17-r4.ebuild10
-rw-r--r--net-ftp/netkit-tftp/netkit-tftp-0.17-r5.ebuild52
4 files changed, 70 insertions, 11 deletions
diff --git a/net-ftp/netkit-tftp/ChangeLog b/net-ftp/netkit-tftp/ChangeLog
index bd0fa327ef23..a76f457dc87b 100644
--- a/net-ftp/netkit-tftp/ChangeLog
+++ b/net-ftp/netkit-tftp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/netkit-tftp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/ChangeLog,v 1.8 2008/02/05 11:05:07 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/ChangeLog,v 1.9 2008/02/20 09:19:05 pva Exp $
+
+*netkit-tftp-0.17-r5 (20 Feb 2008)
+
+ 20 Feb 2008; <pva@gentoo.org> netkit-tftp-0.17-r3.ebuild,
+ netkit-tftp-0.17-r4.ebuild, +netkit-tftp-0.17-r5.ebuild:
+ Fixed filtering out of LDFLAGS, bug 209740, thank you Diego Pettenò!
+ Compiler is now set correctly.
05 Feb 2008; Markus Rothe <corsair@gentoo.org> netkit-tftp-0.17-r4.ebuild:
Stable on ppc64
diff --git a/net-ftp/netkit-tftp/netkit-tftp-0.17-r3.ebuild b/net-ftp/netkit-tftp/netkit-tftp-0.17-r3.ebuild
index ec783e268a17..f13782cf0dc1 100644
--- a/net-ftp/netkit-tftp/netkit-tftp-0.17-r3.ebuild
+++ b/net-ftp/netkit-tftp/netkit-tftp-0.17-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/netkit-tftp-0.17-r3.ebuild,v 1.2 2007/06/26 02:25:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/netkit-tftp-0.17-r3.ebuild,v 1.3 2008/02/20 09:19:05 pva Exp $
inherit eutils
@@ -18,11 +18,11 @@ PROVIDE="virtual/tftp"
src_compile() {
# Change default man directory
- epatch ${FILESDIR}/man.patch
+ epatch "${FILESDIR}"/man.patch
# Solve QA warning by including string.h
- epatch ${FILESDIR}/memset.patch
+ epatch "${FILESDIR}"/memset.patch
- ./configure --prefix=/usr --installroot=${D} || die
+ ./configure --prefix=/usr --installroot="${D}" || die
emake || die
}
diff --git a/net-ftp/netkit-tftp/netkit-tftp-0.17-r4.ebuild b/net-ftp/netkit-tftp/netkit-tftp-0.17-r4.ebuild
index 736b42a665e5..d725460c9865 100644
--- a/net-ftp/netkit-tftp/netkit-tftp-0.17-r4.ebuild
+++ b/net-ftp/netkit-tftp/netkit-tftp-0.17-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/netkit-tftp-0.17-r4.ebuild,v 1.3 2008/02/05 11:05:07 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/netkit-tftp-0.17-r4.ebuild,v 1.4 2008/02/20 09:19:05 pva Exp $
inherit eutils
@@ -28,10 +28,10 @@ src_unpack() {
find -name Makefile -exec sed -ie 's,install -s,install,' \{\} \;
# Solve QA warning by including string.h
- epatch ${FILESDIR}/memset.patch
- epatch ${FILESDIR}/${P}-tftp-connect-segfault.patch
- epatch ${FILESDIR}/${P}-tftp-manpage-typo.patch
- epatch ${FILESDIR}/${P}-tftp-fix-put-zero-size.diff
+ epatch "${FILESDIR}"/memset.patch
+ epatch "${FILESDIR}"/${P}-tftp-connect-segfault.patch
+ epatch "${FILESDIR}"/${P}-tftp-manpage-typo.patch
+ epatch "${FILESDIR}"/${P}-tftp-fix-put-zero-size.diff
}
src_compile() {
diff --git a/net-ftp/netkit-tftp/netkit-tftp-0.17-r5.ebuild b/net-ftp/netkit-tftp/netkit-tftp-0.17-r5.ebuild
new file mode 100644
index 000000000000..47c001014bc5
--- /dev/null
+++ b/net-ftp/netkit-tftp/netkit-tftp-0.17-r5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/netkit-tftp-0.17-r5.ebuild,v 1.1 2008/02/20 09:19:05 pva Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="the tftp server included in netkit"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-tftp-0.17.tar.gz"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="!virtual/tftp
+ virtual/inetd"
+PROVIDE="virtual/tftp"
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+
+ # Change default man directory
+ sed -i -e 's:MANDIR="$PREFIX/man":MANDIR="$PREFIX/share/man":' \
+ -e 's:^LDFLAGS=::' configure
+
+ # don't prestrip binaries
+ find -name Makefile -exec sed -i -e 's,install -s,install,' \{\} \;
+
+ # Solve QA warning by including string.h
+ epatch "${FILESDIR}"/memset.patch
+ epatch "${FILESDIR}"/${P}-tftp-connect-segfault.patch
+ epatch "${FILESDIR}"/${P}-tftp-manpage-typo.patch
+ epatch "${FILESDIR}"/${P}-tftp-fix-put-zero-size.diff
+}
+
+src_compile() {
+ ./configure --prefix=/usr --installroot="${D}" \
+ --with-c-compiler="$(tc-getCC)" || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin
+ doman tftp/tftp.1 tftpd/tftpd.8
+ make install || die
+
+ dodoc "${FILESDIR}"/{tftp-dgram,tftp-stream} BUGS ChangeLog README
+ einfo "Take a look at /usr/share/doc/${PF}/tftp-* files"
+ einfo "for sample xinetd configuration files."
+}